Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

No internet connection from inside. Need help!!!!

Posted on 2006-03-26
3
Medium Priority
?
311 Views
Last Modified: 2010-03-19
I have a Cisco 2600 router. I have it pulling DHCP from the ISP. Wanside is performing address pull. The ISP can see my router from the outside. However, I can get no internet connection from my internal LAN. This is my running config:

no aaa new-model
ip subnet-zero
ip cef
!
!
ip name-server 204.yyy.yyy.yyy
ip name-server 216.yyy.yyy.yyy
no ip dhcp-client broadcast-flag
!
!
!
!
interface Ethernet0/0
 description line Real World Interface
 ip address dhcp client-id Ethernet0/0 hostname Wewahitchka
 ip nat outside
 full-duplex
!
interface Ethernet0/1
 description LAN INTERFACE
 ip address 172.16.0.1 255.255.0.0
 full-duplex
!
router rip
 network 12.0.0.0
 network 172.16.0.0
!
ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 12.yyy.yyy.1
!
0
Comment
Question by:wrt1mea
  • 2
3 Comments
 
LVL 20

Expert Comment

by:calvinetter
ID: 16294403
You need to setup NAT in order for workstations to be able to connect.
  Do this:
access-list 100 permit ip 172.16.0.0 0.0.255.255 any
ip nat inside source list 100 interface e0/0 overload

If 12.yyy.yyy.1 is your ISP's gateway, then there's no point in having RIP configured with it.
  Also do this:
router rip
  no network 12.0.0.0

cheers
0
 
LVL 1

Author Comment

by:wrt1mea
ID: 16294460
I need to apply this access-list to my Lan or Wan inteface?
0
 
LVL 20

Accepted Solution

by:
calvinetter earned 2000 total points
ID: 16294485
Nope, just run those 2 lines at the top of my post.  The ACL is just telling the router what subnets to NAT to the outside.  
Oops, just noticed you don't have 'ip nat inside' assigned to your interface...
  Run this:
int e0/1
ip nat inside

*Now* you should be good to go.  Sorry, I saw 'ip nat outside' on the external interface & didn't closely check your LAN interface.  Need my morning caffein!

cheers
0

Featured Post

Get quick recovery of individual SharePoint items

Free tool – Veeam Explorer for Microsoft SharePoint, enables fast, easy restores of SharePoint sites, documents, libraries and lists — all with no agents to manage and no additional licenses to buy.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

WARNING:   If you follow the instructions here, you will wipe out your VTP and VLAN configurations.  Make sure you have backed up your switch!!! I recently had some issues with a few low-end Cisco routers (RV325) and I opened a case with Cisco TA…
This article is in regards to the Cisco QSFP-4SFP10G-CU1M cables, which are designed to uplink/downlink 40GB ports to 10GB SFP ports. I recently experienced this and found very little configuration documentation on how these are supposed to be confi…
In this video we outline the Physical Segments view of NetCrunch network monitor. By following this brief how-to video, you will be able to learn how NetCrunch visualizes your network, how granular is the information collected, as well as where to f…
Michael from AdRem Software outlines event notifications and Automatic Corrective Actions in network monitoring. Automatic Corrective Actions are scripts, which can automatically run upon discovery of a certain undesirable condition in your network.…

580 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question