NDR generated for .local but mailbox is hosted by ISP

Hi Guys

I have tried to work this out on my own and read 4 million articles on the web buit can't get it yet and know there is a simple solution.

I have a global domain box catchall@domain.com hosted for me and user accounts fred@domain.com also hosted.
I have all of this working fine but when someone sends an email to internaluser@domain.com(exchange hosted) and also an externaluser@domain.com (isp hosted) they get a ndr saying externaluser@domain.local failed. The user has collected the mail through their isp hosted email but the sender of the mail does not think they have as they have got an NDR for them.
This is only a problem if there is an internal and external username in the to field.

Any help appreciated.

Paul
kennedypdAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Since both your Exchange Server and your ISP server are authoritative mail servers for your domain, you need to modify just one small piece of information which tells the Exchange Server to send any message that is addressed to a person who does not have an Exchange mailbox to the ISP server instead.

You will find that in your Server Management Console under the following:
Advanced Management > First Organization (Exchange) > Servers > Servername > Protocols > SMTP > Default SMTP Virtual Server.  Right click that and select Properties.

Then select the MESSAGES TAB and at the very bottom you'll see "Forward all mail with unresolved recipients to host"
In this box enter the FQDN of your ISP's mail server (ie, mail.domain.com).  There's a good little overview about how this works if you click help on that particular window.

That's all there is to it... :-)

Good Luck!

Jeff
TechSoEasy

0
kennedypdAuthor Commented:
Hi Jeff

I will try and explain a bit clearer as to where I am at.

When I originally set this up people in the office could not send mail to our external users as the exchange server would hold the mail as it believed it was in control of the domain. I went into the default recipient policy and made domain.local the primary and removed the tick for domain.com. This enabled the system to send mails externally to domain.com.

The issue that I am now having is that when someone externally send an email with a internal and external user in the to field it goes to our isp who delivers a copy of it into the external users pop3 mailbox and a copy of it goes to the catchall mailbox which is downloaded to our exchange server. When the exchange server gets the email it delivers the mail to the internal users mailbox and sends a NDR to the sender saying that externaluser.domain.LOCAL does not exist.

Here is a copy of the NDR
Subject: Mail System Error - Returned Mail

This is a system generated message. Please DO NOT REPLY.

Your message was not delivered for the following reason:

Your message was not delivered because the destination computer was not found.  Carefully check that it was spelled correctly and try sending it again if there were any mistakes.

It is also possible that a network problem caused this situation, so if you are sure the address is correct you might want to try to send it again.  If the problem continues, contact your friendly system administrator.

     Host hireco.local not found

The following recipients did not receive this message:

     <anthony@HIRECO.LOCAL>


I have tried the suggestion above but it did not help.

Cheers
Paul
0
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
You need to go back and undo what you originally did to the default recipient policy.  That's why what I suggested isn't working.

Jeff
TechSoEasy
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
After you've done that... rerun the Configure Email and Internet Connection Wizard (CEICW) which is linked in the Server Management Console > Internet and Email > Connect to the Internet

Jeff
TechSoEasy
0
kennedypdAuthor Commented:
Hi Jeff

I am still having issues with this. I am no longer getting NDR but if someone spells the users name wrong invaliduser@domain.com then it goes into the isp catchall mailbox and my exchange server picks it up, doesn't recognise the user so sends it back out to the internet and it ends up back in the catchall mailbox. The whole process starts all over again so the mail will cycle every 15 minutes causing my bandwidth usage to rocket.
0
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Hmm.. that's kinda funny (sorry, I know it's a pain to you... but it wasn't something I thought of because I make this configuration with the combination of remote users having POP3 accounts with the ISP and all internal users just get their mail via Exchange.  Which means you don't use a catch-all account at the ISP.

Is there a reason you don't want to use the EXCHANGE SMTP as your email server?  It's really quite easy to set up and manage... and if you're worried about a backup you can STILL keep the POP3 connector...

For your external users you would set them up with an Exchange Mailbox that automatically forwards to a GMail account which can be configured to have any "SEND AS" address as you want.  They can also have the mail come into Outlook or another mail client via the GMail account.  http://mail.google.com/support/bin/answer.py?ctx=%67mail&hl=en&answer=20616

This would be a pretty sweet configuraton and would solve a number of problems for you including no bandwidth at all with your ISP.

You do not need an additional CAL for these mailboxes because the user never actually logs into the domain... the message is forwarded out without any interaction on their part.

Your only other option would be to NOT use a catch-all account at the ISP and instead configure separate POP3 accounts for EVERYONE.  You can list all of these accounts in the Exchange POP3 connector and it will retrieve them all.

Jeff
TechSoEasy
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.