• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 991
  • Last Modified:

JRE Issue

Hi everyone, this is my problem...
In my desktop I have installed JRE version 1.4.2 and JRE 1.3.1, I use 1.4.2 to have access to a server and 1.3.1 to a different server. The last version I installed was 1.4.2 so that's the default JRE and it is the only one that uses the explorer, I want to switch from 1.4.2 to 1.3.1, but is hasn't been possible.
I was researching and this is what I have done:
- I changed the environment variable PATH = c:\more_directories;C:\ca_appsw\;C:\tng\services\bin;C:\Program Files\JavaSoft\JRE\1.3.1_02\bin  (and this is supposed to switch form one to another)

-I modified the registry key "HKEY_LOCAL_MACHINE\Software\JavaSoft\Java Runtime Environment\"  to the version 1.3

-I tried to enable the version 1.4.2 from webstart

-I tried to switch it from the java control panel 1.4.2, and form the explorer when I try to acces to the web page, appears an error "c++ runtime, internal error explorer".

-I deinstall an reinstall both versions.

- When I go to command prompt and type "java - version" it says that I'm using the version 1.3.1 BUT when I open the explorer and try to acces to the server it uses 1.4.2, it is still using the default one. I tried to use the "Java web start" application, but nothing.

Do you know any idea what I'm doing wrong, or if there is another procedure that you have tried?, or check if I have to install first one version and then  another one, a special procedure...
I would appreciate your help!, Thanks a lot!  

A.
0
amphill
Asked:
amphill
  • 7
  • 6
  • 5
  • +1
3 Solutions
 
javaoptimizerCommented:
Hi,

all the JRE's are backward compatible, hence i dont think there will be any problem if you use JRE version 1.4.2. Hence can you specify what problem are you facing if by default the JRE version is 1.4.2 while opening your Internet Explorer.

Cheers
0
 
sciuriwareCommented:
Because 1.4.2 IS NOT BACKWARD COMPATIBLE (!!!!) to 1.3.1,
it is probably better to replace both by 1.5.0

I found some things that work with 1.3, NOT with 1.4.2 and DO with 1.5

;JOOP!
0
 
Mayank SAssociate Director - Product EngineeringCommented:
I prefer using Java 5.0 now, too. Also make sure you modify your JAVA_HOME environment variable accordingly. In the registry, the default version is stored in HKEY_LOCAL_MACHINE\Software\JavaSoft\Java Runtime Environment\CurrentVersion.
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
sciuriwareCommented:
Yes and:  1.5 == 5.0 (funny SUN).

;JOOP!
0
 
Mayank SAssociate Director - Product EngineeringCommented:
:)
0
 
amphillAuthor Commented:
Well, the problem is: the server  that uses 1.3.1  only uses the 1.3.1, I tried to connect to that server with 1.4.2 and 1.5 and nothing. That's the reason why I have to keep the old 1.3.1 version. And the second server It uses the 1.4.2, so, that's my problem.

This is the error that cames up when I try to connect to the server that uses 1.3.1 and the default JRE is 1.4.2:

"E005034 RMI connection failure."
"E009999 Internal error"

Any idea????

0
 
Mayank SAssociate Director - Product EngineeringCommented:
You're using RMI too? There might be some difference in the way the various Java versions handle RMI - I know there is a difference between 5.0 and 1.4 (5.0 does not need stubs).
0
 
sciuriwareCommented:
I fear that the only way to go on is to scale down completely to 1.3.1_15 (latest)
until the other side upgrades.

;JOOP!
0
 
amphillAuthor Commented:
Well, I'm a newbie in Java, but I belive that the server it is using RMI, so that's the reason why it is a conflict between versions.
I just tried to test this with JRE 1.5, and it is the same problem, the same error:

"E005034 RMI connection failure."
"E009999 Internal error"

Damn!

0
 
amphillAuthor Commented:
Do you really belive that the only solution is to Install and deinstall the JRE over and over again, instead of switching from one to another?

Just a bit painless...
0
 
amphillAuthor Commented:
nothing?
0
 
Mayank SAssociate Director - Product EngineeringCommented:
Did you try: >> the only way to go on is to scale down completely to 1.3.1_15 (latest)
0
 
sciuriwareCommented:
amphill, you don't install over and again, but you must make a choice.

;JOOP!
0
 
amphillAuthor Commented:
So I have to make a choice between them, either I have JRE 1.3.1 or 1.4.2?
Can't I have them installed at the same time, and just switch between them?
0
 
Mayank SAssociate Director - Product EngineeringCommented:
You can switch, based on the environment variable settings (CLASSPATH, etc)
0
 
sciuriwareCommented:
It is even possible to switch automatically depending on the application.
All you need is to set an other JAVA_HOME for different applications.

Note: you should install JRE 1.3.1_15 first, then 1.4.2_10, 1.5.0_06 as last
to get the right plug-in in your browser.

Note: the CLASSPATH is not important here: it can be the same for different
versions of the JRE but different for applications.

;JOOP!
0
 
Mayank SAssociate Director - Product EngineeringCommented:
If you run it from the command-prompt and from the folder which contains the JRE, then the PATH variable is important. You should make it point to the JRE version you want to run from. An easy way is:

SET PATH=%JAVA_HOME%\bin;%PATH%
0
 
sciuriwareCommented:
The contribution by 'javaoptimizer' is questionable.

;JOOP!
0
 
sciuriwareCommented:
Forced gratitude.

;JOOP!
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 7
  • 6
  • 5
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now