• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 5385
  • Last Modified:

GoBack screws with partition

So I took the 250GB SATA hard drive out of a Sony Vaio computer because it won't boot.  There's no need to explain why it won't boot, and in fact I already know why it won't boot - the fact that it won't boot is not important.  (I point this out because I have far too often seen people here try to provide solutions to issues the person posting the question does not have.  So please, in the interest of saving time, don't try to get me to boot from that hard drive.)  What IS important is that I want to be able to access the data on that hard drive while it's mounted in an external enclosure but I can't because of Norton GoBack version 4.x.xx. This is a good time to point out that I have tried all the solutions offered by Symantec for removing GoBack, disabling GoBack, etc, including "GB_Prog.exe /u" but they did not work for me.  The only thing I was unable to try was loading the GoBack drivers in the PC that I'd connect the drive to - I can't get to the frickin-frackin drivers because Sony didn't give me any CDs for GoBack and if the drivers are on the hard drive, I can't get to them because it won't boot and I can't read the drive in another box, and around and around we go again...

As you may know, Norton GoBack does *something* to the hard drive - changes the partion table or the MBR or both or more.  At any rate, if you mount the hard drive in a computer as a slave -or- in an external (USB) enclosure, Windows XP will not assign a drive letter to it and Disk Manager has the option greyed out.

I am afraid that if I boot from a WinXP CD into recovery console and do a fixmbr, it might just make things worse.  I don't know if GoBack imbeds itself in the MBR, the Partition table, or elsewhere.  If anyone else has positive results from doing a fixmbr, I might be willing to try it, but only if you can assure me you did it and it worked!

If someone has experience with loading GoBack drivers on another box *and* is able to provide those drivers to me, I'll try that, too, with proper "coaching".

Otherwise maybe there's another solution.

TIA.



 

0
kenlotterman
Asked:
kenlotterman
  • 4
  • 3
  • 2
1 Solution
 
garycaseCommented:
GoBack does indeed change the MBR so that it gets control and THEN takes over all disk management for the protected volumes.

You've already tried the simple GBProg /u technique to remove it  ==>  I assume you did it correctlly; but just to be sure:   Did you install the drive in question as the ONLY drive on the PC (as Master), and then boot to a DOS boot disk w/CD support and execute the GBProg /u at that point?   Note that GBProg /u will NOT work if the drive is in an external enclosure (in case that's what you tried).

You also indicated the drive will not boot.  ... however, will it START to boot and give you the "GoBack bar" that precedes the boot process?   IF you get that, pressing space and selecting "Disable GoBack" will undo the modifications to the MBR.

Assuming you've already tried both of those, and they don't work ...

You need a copy of GoBack to resolve this, and it will NOT work with the drive mounted externally;  it has to be on an IDE channel.   (Note that if you buy the downloadable GoBack on Symantec's site you can return it for a refund within 60 days; so if you just need it for this but don't decide to keep it you can get a refund)

(1)  Be sure the drive in question is NOT installed.
(2)  Install GoBack on your primary drive (reboot as needed)
(3)  Turn off the computer and install the drive in question as a 2nd drive.
(4)  Boot the computer => GoBack should recognize the 2nd drive and "reconnect" to its MBR
(5)  Uninstall GoBack

0
 
garycaseCommented:
... by the way, you're absolutely right that you do NOT want to do anything else to the MBR at this point.  That could easily result in NO ability to recover your information.
0
 
rindiCommented:
If the above doesn't work (might be a problem since goback seems to need an IDE channel and your disk is SATA), you might try accessing your data through knoppix.

http://knoppix.net

You'll need some place to copy the data to if you can access it that way, either space on a network or a 2nd drive will do, but the 2nd drive will have to be fat32, as knoppix doesn't support ntfs writing. This of course also means you can't save files larger than 4GB. You could of course also use ext3 or some other linux filesystem, but that is difficult to access in windows....

another tool you can try is getdataback, it should be able to access drives invisible to windows:

http://runtime.org

Good luck.
0
Nothing ever in the clear!

This technical paper will help you implement VMware’s VM encryption as well as implement Veeam encryption which together will achieve the nothing ever in the clear goal. If a bad guy steals VMs, backups or traffic they get nothing.

 
garycaseCommented:
... I misspoke => it needs at ATA channel (either PATA or SATA)    SATA will work fine.
0
 
kenlottermanAuthor Commented:
OK so I have to eat some crow here.  

I mentioned in my original post that I don't have to explain why the drive won't boot.  I did that to head off the inevitable responses from well-meaning folks that don't read the entire question and then throw suggestions out to try to fix a problem that doesn't even exist.  "... you could try changing the jumpers..."  I apologize for being so glib - turns out I may have saved myself time had I not been so.

Well, I tried the solution from garycase, but wouldn't ya know, I get the same exact results.  But in my original post I didn't describe the results well enough for you to know what those results are.

While booting, Norton GoBack comes up as it's supposed to, but then shows a message with "Norton GoBack (122)" in the title bar and the following in the window:  "Norton GoBack rebooted your computer because it detected your system was unstable.  Allowing it to continue running would have casued corruption on disk #1."   then there's more (more on more later).   I click OK, and the "press spacebar" message comes up.  If I leave it alone, Windows begins to load.  At a certain point, Windows shows that it needs to check the drive for problems and BAM! the PC reboots, bringing me right back to "Norton GoBack (122)."  I cannot boot into any mode; normal, safe, command, etc.

If I hit the spacebar when that option comes up and try to disable NGB, it starts the disable process and immediately I get a message with "Norton GoBack (141)" in the title bar and "Norton GoBack needs to reboot your computer because your system has become unstable.  This could be caused by memory failures, unreliable hard disk transfers..." (there's a little more).  "Code 0x15"

Also, restoring to an earlier point does not help at all.

Which brings me to the solution offered by garycase:  The exact same thing happens with the "bad" drive mounted as a second disk, except NGB says "disk #2" instead of #1.  Friggin GoBack.  It's not letting me get past a point of uninstalling or disabling it.  I can't even start Windows with the "bad" drive installed as a slave!  

Because the data on the hard drive is quite important, we sent the drive to Ontrack Data Recovery, and they said it would be $2000 to recover the data.  Well, the data isn't worth *that* much, so I paid them their hundred bucks and got the drive back.  But they *did* tell me:
* The hard disk has electronic failure.
* There are no structure problems found.

Before I sent it to them, I tried Active Undelete and it didn't work because it stumbled over a bad sector.

By the way, if you're wondering if I had a backup?  http://www.experts-exchange.com/Storage/Q_21770217.html explains that issue.

At any rate, I will try Knoppix and getdataback later today or later this week.  Meanwhile if you have any other suggestions for "manually removing" goback, I'm open.

A lot less hair today than yesterday...
0
 
rindiCommented:
A very good alternative to ontrak, because cheaper and they only charge you if they are succesfull recovering the data (which they normally are), is the following:

http://www.gillware.com/

But first try knoppix and getdataback.
0
 
garycaseCommented:
I've sent many people to Gillware with excellent results -- in all but one case their data was recovered with no problem.   They charge about $400 -- and, as rindi noted, they have a "no recovery, no fee" policy.

GetDataBack is excellent, but unfortunately is NOT "GoBack-aware" (at least it wasn't just a few months ago), so it's very unlikely it will help (but since it's free to try it won't hurt to do so).

Since you can get to the "spacebar" menu for GoBack, I'd try "disabling" GoBack several times in a row -- I've seen cases where that will work on the 3rd or 4th try (I have no idea why -- GoBack can sometimes be strange in its behavior).

I'd also double-check your BIOS to be sure you don't have it set to prevent Boot sector viruses => when GoBack attempts to uninstall it "looks" like a Boot sector virus (since it's modifying the boot sector).

I asked you already -- and I presume you did it correctly -- but just to be absolutely sure, did you use the "GBProg /u" correctly, as I described in the 2nd paragraph of my original post?

Finally -- since you CAN get past the GoBack "spacebar menu" and the system "starts to boot" ==> press F8 immediately after the "spacebar menu" disappears and select Safe Mode.   First see if you can boot to Safe Mode itself;  if not, try Safe Mode w/Command Prompt.   If you can boot to either of these you will have access to your files :-)   ... and if the Windows disk check starts up ABORT it (since you know it's going to fail & reboot).

0
 
kenlottermanAuthor Commented:
GetDataBack did it!  But only after 1.5 hours on phone with Iomega, who once again gave up far too easily, and another hour with some Symantec guy in India who had me boot from CD into recovery console and do a fixmbr.  That got WIndows to start but bluescreened after autocheck was nto found.  But I was then able to get getdataback to read the drive and I was able to recover the data I was after!  So Rindi gets this one - thanks all for your help!!

breakin' out the champagne....


-Ken
0
 
rindiCommented:
your welcome
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 4
  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now