?
Solved

Enabling APM and Remote shutdown in Windows 2000 Pro on a Dual Processor Machine

Posted on 2006-03-26
16
Medium Priority
?
280 Views
Last Modified: 2010-04-25
Hi,

I have a Tyan Tiger MPX S2466N-4M Motherboard with Dual 2.0ghz Athlon Procs and the latest Bios installed. When windows 2000 shuts down, it hangs at the 'its ok to turn the box off' screen instead of completely shutting down, either from a local or a remote shutdown command. The Bios has power management enabled, but windows does not have the APM tab in the power management section that has been referenced in numerous posts (its service pack 4).
I recently upgraded the Phoenix Bios, thinking that that would help, (the old bios did have a power management section, and it was enabled). I have been looking around, but found no references to being able to get this to work after the fact, i.e. being able to load power management features into W2K if they are not there initially. is there any known way around this.......

*Additional...... I found a post from 'Dog' that suggested installing Legacy nt/apm support. I followed the advice and that solved half the issue.....The machine now shuts down all the way, from the Start, Shutdown Dialog, but still won't shutdown all the way if i issue a 'remote' shutdown command using 'Shutdown.exe' i.e. Shutdown /s /m \\machine name. It is still hanging at the 'Safe to turn off' message......I'm nearly there, if this last bit can get solved...Dude's, I'll be a happy camper, then i can get the rest of the troublemakers in line!

Any insights and suggestions would be greatly appreciated....

Thanks

Andy M
0
Comment
Question by:AndyM66_Experts
  • 7
  • 5
  • 2
14 Comments
 
LVL 26

Expert Comment

by:PCBONEZ
ID: 16298171
Go here:
http://support.microsoft.com/?kbid=242495

Read down, it says:
• Windows 2000 does not support APM on computers with multiple processors.

.
0
 
LVL 2

Expert Comment

by:Peregian
ID: 16299233
right click taskbar and select task manager then use the shut down menu from the task manager. Works for me where the shutdown.exe didn't most times
0
 
LVL 2

Expert Comment

by:Peregian
ID: 16299240
I should mention Im using xp so not sure if w2k has same menu in task manager.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 26

Expert Comment

by:PCBONEZ
ID: 16307426
It does exist in W2k but it's easeir to press "control"+"alt"+"delete" and the task manager will pop-up for you.
0
 
LVL 2

Expert Comment

by:Peregian
ID: 16307628
That only works for local task manager. To get remote task manger right click task bar is the easiest.
0
 
LVL 2

Expert Comment

by:Peregian
ID: 16517071
why just pcbonez
0
 
LVL 26

Accepted Solution

by:
PCBONEZ earned 400 total points
ID: 16517119
Because the question was basically "Why can't I shut down my dual CPU W2k system with APM."

And the answer was:
• Windows 2000 does not support APM on computers with multiple processors.

-Other- ways to shut it down or ways to shutdown other configurations don't pertain to the question asked.
.
0
 
LVL 2

Expert Comment

by:Peregian
ID: 16517160
If you read his post he said he solved the apm part and was just having problems with shutting down useing shutdown.exe. The way I suggested works better than shutdown.exe
0
 
LVL 26

Expert Comment

by:PCBONEZ
ID: 16517176
Whatever....
0
 

Author Comment

by:AndyM66_Experts
ID: 16520003
Gentlemen,please accept my apologies for the long absence.......

I have learned a great deal, scouring around for a solution to this problem, having read a great many informative posts on this subject, some more so than others, but all in the right spirit.

My question wasn't just about APM, it was a combination of APM and shutdown.exe. The end goal here was to have the ability to remotly shutdown WIN2K Workstations. To say that APM isn't supported in a Dual Proc Win2k environment, was only the first piece of the puzzle, and not the solution. Ok, so that was established, the next step was 'is there a way around it', and yes there is, and I added that piece of the puzzle to the post as additional . The final piece was using psshutdown.exe instead of using regular shutdown.exe, which is mentioned in numerous previous posts.

So, for a fact Win2k doesn't support APM on Dual Proc Machines out of the box, installing legacy nt/apm support as mentioned above helps.
The other half of the issue, 'Remote Shutdown' was solved with Psshutdown, (works like a charm) why it works when the Microsoft shutdown.exe won't ......!

At any rate, getting the latest Bios, adding the nt/apm legacy support and using psshutdown solved the problem, and works every time. So for anyone else looking for an answer to this issue using Windows 2k Workstation, this is the fix.

As far as how the points are distributed, I feel like i did most of the leg work myself and pieced together what was already floating around out there. PCBONEZ was the first to point out that APM in a Dual Proc Win2k setup wasn't supported, but didn't elaborate, so i looked for a post that addressed this a little deeper, and found one (Unfortunatly i can't find the post to reference). Peregian was there in spirit, but didn't help solve anything. If it was upto me I would give PCBONEZ 100 points for that piece of the puzzle, and PEREGIAN 10 for taking a stab. Unless the Administrative staff think otherwise, then I'll leave it upto their discretion.

Thanks to all that took part
All the Best
Andy M
0
 
LVL 26

Expert Comment

by:PCBONEZ
ID: 16520561
How does one elaborate on: "That's NOT supported" followed with a link to the Microsoft page that says so??
.
Anyway.
I'm glad you found an unsupported third party solution to the rest of your question.
The reason it's unsupported is that it's not (or not adequatly) tested and it has a history of problems.
Versions 2.31 and earlier have known Security flaws that can be used by malicious users to gain administrative privileges on remote systems. This has also been exploited by the sasser worm.
.
The current version is 2.51 (March 27, 2006). New security issues (if they still exist) have yet to be reported.
Personally, I hope they don't find any. I could use a program like Psshutdown myself.
.
Perhaps a link to Psshutdown info would helpful to others.
http://www.sysinternals.com/Utilities/PsShutdown.html
.
0
 
LVL 26

Expert Comment

by:PCBONEZ
ID: 16543146
Bear in mind experts that if the asker doesn't happen to like you the Moderators will just give the points back even when the asker flat out says you've answered 1/2 of a multi-part question.
.
0
 

Author Comment

by:AndyM66_Experts
ID: 16545536
PCBONEZ,
You answered half the question, and i awarded you points, I believe that was fair enough, you pointing the way lead me to more info which eventually enabled me to get around the problem, for that i am greatful, I'm hoping that the 'asker doesn't happen to like you' comment is a generalization, and not aimed at me personally, I appreciated your answer and your later elaboration, how i feel about you personally didn't enter into it, I'm just greatful for the help. I am concerned that the Moderator refunded the points, I'm new here, so, why that happened I can't say, I can only say that I belive that you earned the points and should be awarded them, and I hope that DarthMod re-considers and gives you the 100 points.

A~

0
 
LVL 26

Expert Comment

by:PCBONEZ
ID: 16547995
@AndyM66_Experts
@DarthMod

I dunno what exactly happened but thank you both for fixing it.
.

0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Basic computer tune-up with little or no hardware upgrades. Giving an old computer a tune-up usually results in a minimal performance gain, but a gain nonetheless. Several times a week, I’m faced with users at work who ask to make their computers…
I use more than 1 computer in my office for various reasons. Multiple keyboards and mice take up more than just extra space, they make working a little more complicated. Using one mouse and keyboard for all of my computers makes life easier. This co…
Finding and deleting duplicate (picture) files can be a time consuming task. My wife and I, our three kids and their families all share one dilemma: Managing our pictures. Between desktops, laptops, phones, tablets, and cameras; over the last decade…
Want to learn how to record your desktop screen without having to use an outside camera. Click on this video and learn how to use the cool google extension called "Screencastify"! Step 1: Open a new google tab Step 2: Go to the left hand upper corn…
Suggested Courses

830 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question