Problems applying patch

Hi,

I run Opatch from the patch directory and get the following output and eventual error:

Location of Oracle Universal Installer components = C:\Program Files\Oracle\oui
Location of OraInstaller.jar  = "C:\Program Files\Oracle\oui\lib"
Oracle Universal Installer shared library = C:\Program Files\Oracle\oui\bin\win3
2\oraInstaller.dll
Location of Oracle Inventory Pointer = N/A
Location of Oracle Inventory = C:\Program Files\oracle\inventory
Path to Java = "C:\Program Files\Oracle\jre\1.3.1\bin\java.exe"
Log file = C:\APPS\ORACLE/.patch_storage/<patch ID>/*.log

Creating log file "C:\apps\oracle\.patch_storage\4387563\Apply_4387563_03-27-200
6_16-10-50.log"

SKIPPING_COMPONENT=oracle.rdbms,9.2.0.5.0

MISSING_COMPONENT : oracle.rsf.rdbms_rsf, 9.2.0.5.0
SKIPPING_COMPONENT=oracle.rsf.xdk_rsf,9.2.0.5.0
SKIPPING_COMPONENT=oracle.isearch.is_common,9.2.0.5.0
SKIPPING_COMPONENT=oracle.rsf.net_rsf,9.2.0.5.0
SKIPPING_COMPONENT=oracle.cartridges.locator,9.2.0.5.0
SKIPPING_COMPONENT=oracle.cartridges.context,9.2.0.5.0
SKIPPING_COMPONENT=oracle.options.odm,9.2.0.5.0
SKIPPING_COMPONENT=oracle.rdbms.csmig,9.2.0.5.0
SKIPPING_COMPONENT=oracle.rsf.precomp_rsf,9.2.0.5.0
SKIPPING_COMPONENT=oracle.rdbms.sqlplus,9.2.0.5.0
SKIPPING_COMPONENT=oracle.rsf.ldap_rsf,9.2.0.5.0
SKIPPING_COMPONENT=oracle.java.javavm.javatools,9.2.0.5.0
SKIPPING_COMPONENT=oracle.rsf.oracore_rsf,9.2.0.5.0
SKIPPING_COMPONENT=oracle.options.olap.cwmlite,9.2.0.5.0
SKIPPING_COMPONENT=oracle.emprod.oemagent.base_oemagent,9.2.0.5.0
SKIPPING_COMPONENT=oracle.rsf.dbjava_rsf,9.2.0.5.0
SKIPPING_COMPONENT=oracle.cartridges.ordimg,9.2.0.5.0
SKIPPING_COMPONENT=oracle.rsf.nlsrtl_rsf,9.2.0.5.0

This Oracle Home does not have components/versions required by the patch.

ERROR: OPatch failed during pre-reqs check.
OPatch returns with error code = 150

Does anyone know why the install is failing?

Thanks
TRAININGBSCAsked:
Who is Participating?
 
Pradeepgv03Commented:
Hi,
Please  make sure that ORACLE_HOME env variable is set properly before running opatch.
in windows use set ORACLE_HOME=<TOYOURORACLEHOME>.

Regards,
Pradeep
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.