Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2388
  • Last Modified:

Setting up FreeNX server

Hello!

I am using SUSE 10.0 behind a Belkin router/modem. I have confugured the router to forward port 5555 to 22 on my linux box.
I installed the freenx server using yast and configured it using:
nxsetup --install --setup-nomachine-key --purge --clean
and it seems to be running fine. I can ssh rome my remote machine but cannot connect using the nomachine client for windows

Any help would be greatly appreaciated
0
philmccrackin69
Asked:
philmccrackin69
  • 7
  • 6
  • 2
2 Solutions
 
kalifiCommented:
Hi philmccrackin69,

Could you please provide the error message that you get, if it's posibile.

Miro
0
 
philmccrackin69Author Commented:
NX> 203 NXSSH running with pid: 3732
NX> 285 Enabling check on switch command
NX> 285 Enabling skip of SSH config files
NX> 200 Connected to address: xxx.xxx.xxx.xxx on port: 6666
NX> 202 Authenticating user: nx
NX> 208 Using auth method: publickey
HELLO NXSERVER - Version 1.4.0-44 OS (GPL)
NX> 105 hello NXCLIENT - Version 1.5.0
NX> 134 Accepted protocol: 1.5.0
NX> 105 SET SHELL_MODE SHELL
NX> 105 SET AUTH_MODE PASSWORD
NX> 105 login
NX> 101 User: phil
NX> 102 Password:
NX> 103 Welcome to: linux user: phil
NX> 105 listsession --user="phil" --status="suspended,running" --geometry="1280x1024x32+render" --type="unix-kde"
NX> 127 Sessions list of user 'phil' for reconnect:

Display Type             Session ID                       Options  Depth Screen         Status      Session Name
------- ---------------- -------------------------------- -------- ----- -------------- ----------- ------------------------------


NX> 148 Server capacity: not reached for user: phil
NX> 105 startsession --session="Home" --type="unix-kde" --cache="8M" --images="32M" --cookie="******" --link="adsl" --kbtype="pc102/gb" --nodelay="1" --encryption="1" --backingstore="never" --geometry="fullscreen" --media="0" --agent_server="" --agent_user="" agent_password="******""  --screeninfo="800x600x32+render"

NX> 1000 NXNODE - Version 1.4.0-44 OS (GPL)
NX> 700 Session id: linux-1012-6C545761BDAC3C0397050ADCF1C8C88A
NX> 705 Session display: 1012
NX> 703 Session type: unix-kde
NX> 701 Proxy cookie: f005d98a1d8539c6e7ff57b050cf98ba
NX> 702 Proxy IP: 127.0.0.1
NX> 706 Agent cookie: f005d98a1d8539c6e7ff57b050cf98ba
NX> 704 Session cache: unix-kde
NX> 707 SSL tunneling: 1
NX> 1004 Error: Session did not start.
NX> 504 Session startup failed.
NX> 999 Bye
/usr/bin/nxserver: line 720: kill: (30831) - No such process
Killed by signal 15.

thanks
0
 
kalifiCommented:
Hi philmccrackin69,

I assume that the problem is in the configuration of the FreeNX server - the Linux side.
Please try to install the FreeNX server following this article:
http://madpenguin.org/cms/index.php/?m=show&id=5755&page=1

Hope that helps
Miro
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
philmccrackin69Author Commented:
Thanks for your help!
But that's exactly the tutorial i used!
I have retried it three times - but still the same error

Any further suggestions would be greatly apprieciated!

Cheers phil
0
 
pjedmondCommented:
NX relies heavily on ssh. Try the following to confirm that the keys and permissions are all correct.:

This is to be done on the client machine, not the server
mv ~/.ssh/id_dsa ~/.ssh/id_dsa.bak
cp /usr/NX/share/client.id_dsa.key ~/.ssh/id_dsa
chmod 600 ~/.ssh/id_dsa
ssh nx@{NXSERVER}
HELLO NXSERVER - Version 1.4.0-02 OS_(GPL)
NX> 105 quit
quit
Quit
NX> 999 Bye
Connection to {NXSERVER} closed.

http://fedoranews.org/contributors/rick_stout/ssh/

may help check that the ssh is correctly configured.

With respect to client configuration, check that everything is tunnelled through ssh, otherwise your firewall will prevent it from working (client configuration).

HTH:)
0
 
pjedmondCommented:
Looking at your logs, I'm fairly certain that your problem is that you haven't tunnelled everything through ssh in the client settings. I can reproduce the same error that you get.
0
 
philmccrackin69Author Commented:
hi,

I am using a windows machine as the client using the nomachine client software. Under the advanced tab i have checked "Enable  SSL encription of all traffic" how do i enable ssh tunneling of everything?

Thanks
0
 
pjedmondCommented:
That looks as if you've done the correct thing!

The other major problem that I get with this, (which doesn't give quite the same error that you've got) is that if you look at the processes, you'll see that you sometimes get a 'zombie' nx,nxssh, or cygwinserver process running on the windows machine that causes a fault part way through the connection process.

Try closibng the nx client and killing off all these errant processes.

Also can you access the nx server locally (i.e. not through the firewall)?

Also, not sure if SUSE uses rpms, but this site makes the nx install a breeze if rpms are used:

http://fedoranews.org/contributors/rick_stout/freenx/
0
 
philmccrackin69Author Commented:
thanks

I've not tried connecting locally i'll do that tonight then let you know

phil
0
 
pjedmondCommented:
Obiously, if you can connect locally, then you need to start playing with the firewall.

Good luck:)
0
 
philmccrackin69Author Commented:
Hi tried last night and couldn't connect locally....

Any Ideas what the problem could be

Error from local machine below:

Cheers Phil

NX> 203 NXSSH running with pid: 31768
NX> 285 Enabling check on switch command
NX> 285 Enabling skip of SSH config files
NX> 200 Connected to address: 127.0.0.1 on port: 22
NX> 202 Authenticating user: nx
NX> 208 Using auth method: publickey
HELLO NXSERVER - Version 1.4.0-44 OS (GPL)
NX> 105 hello NXCLIENT - Version 1.5.0
NX> 134 Accepted protocol: 1.5.0
NX> 105 SET SHELL_MODE SHELL
NX> 105 SET AUTH_MODE PASSWORD
NX> 105 login
NX> 101 User: phil
NX> 102 Password:
NX> 103 Welcome to: linux user: phil
NX> 105 listsession --user="phil" --status="suspended,running" --geometry="1280x1024x24+render" --type="unix-kde"
NX> 127 Sessions list of user 'phil' for reconnect:

Display Type             Session ID                       Options  Depth Screen         Status      Session Name
------- ---------------- -------------------------------- -------- ----- -------------- ----------- ------------------------------


NX> 148 Server capacity: not reached for user: phil
NX> 105 startsession --session="NewConnection" --type="unix-kde" --cache="8M" --images="32M" --cookie="******" --link="lan" --kbtype="pc105/gb" --nodelay="1" --encryption="1" --backingstore="when_requested" --geometry="800x600+240+188" --media="0" --agent_server="" --agent_user="" agent_password="******""  --screeninfo="800x600x24+render"

NX> 1000 NXNODE - Version 1.4.0-44 OS (GPL)
NX> 700 Session id: linux-1021-7741200CC52E50162B33D140896CCB00
NX> 705 Session display: 1021
NX> 703 Session type: unix-kde
NX> 701 Proxy cookie: f2a1e6fde6e38a2e414e432bbc34d6ec
NX> 702 Proxy IP: 127.0.0.1
NX> 706 Agent cookie: f2a1e6fde6e38a2e414e432bbc34d6ec
NX> 704 Session cache: unix-kde
NX> 707 SSL tunneling: 1
NX> 1004 Error: Session did not start.
NX> 504 Session startup failed.
NX> 999 Bye
Killed by signal 15.
0
 
pjedmondCommented:
Just a thought, but in your sshd configuration file, you will have a line that reads:

Protocol 1,2

Change it to read:

Protocol 2

This will force everything to work on protocol 2, and is a good idea as even if your sshd is fully uptodate, any ssh protocol 1 servers get unnecessary attention!

Have a look in the sshd logs and messages logs as this type of failure implies perhaps a permissions or access problem?
0
 
philmccrackin69Author Commented:
Done that but still no joy!!!!

messages log seems fine!
Apr  4 09:11:21 linux sshd[16748]: Accepted publickey for nx from 127.0.0.1 port 28646 ssh2
Apr  4 09:11:22 linux sshd[16783]: Accepted keyboard-interactive/pam for phil from 127.0.0.1 port 28647 ssh2
Apr  4 09:11:36 linux sshd[16903]: Accepted keyboard-interactive/pam for phil from 127.0.0.1 port 28653 ssh2

There is nothing in the nxserver.log

cheers

phil
0
 
philmccrackin69Author Commented:
Not sure what i did!!!! But it just satrted working
Thanks for all your help!!!
0
 
pjedmondCommented:
No problem - an nxserver restart is often required for new settings to take effect...glad you've got it sorted:)
0

Featured Post

Transaction-level recovery for Oracle database

Veeam Explore for Oracle delivers low RTOs and RPOs with agentless transaction log backup and transaction-level recovery of Oracle databases. You can restore the database to a precise point in time, even to a specific transaction.

  • 7
  • 6
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now