[Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 617
  • Last Modified:

505 Delete Failed

Hi,

I am in the process of uploading a new website and I have hit a problem.

I'm using WS_FTP to upload the site to my server.  I was trying to create a password protected page and uploaded an .htaccess file and .htpasswd file along with the rest of my files.  When doing this I created a new folder for the page I wanted password protected (I'm trying to figure out how to do this) and put those files there.  Unfortunately, now the site won't work, so I want to delete those files.  I tried deleting everything from the folder and then deleting the folder but when I go to delete the folder I get a 550 Delete: File Exists error.  As I look in the folder, there is nothing there, but interestingly enough, when I deleted the contents of the folder I did not see the .htaccess and .htpasswd files.   It is showing that the size of the folder is 4096 so I figure there must be something in it (which would be why I can't delete it) but I don't see anything there.  Please let me know if you need more information to help with my problem, just ask away!  I apologize in advance if I didn't explain it properly but I am a novice at this.

Thanks in advance!

Tara
0
garden_frog
Asked:
garden_frog
1 Solution
 
ComputronCommented:
You may have hidden files in that folder and your operating system is not configured to show them. There are two ways you can attack this.

#1 open mycomputer, go to tools, folder options at the top of the window, then click the view tab and tell explorer to show you hidden files and folder

#2 open a command prompt and navigate to the folder of your website. It will be something similiar to cd \inetpub\wwwroot\mywebsite then press enter. You can view hidden files by typing attrib *.* then pressing enter. To remove the hidden attribute use attrib -h *.* then press enter. This should allow you to view the files via explorer so you can then delete them.
0
 
periwinkleCommented:
The problem is in your .htaccess file - you need to delete it.

using ws-ftp, log into the site using the classic interface.

In the box on the remote system (below mkdir on my copy of ws-ftp), add:

-ahl

and press enter.  This will show long listings, and show all files, including hidden ones.

Then, delete the .htaccess file.
0
 
garden_frogAuthor Commented:
Thanks so much!  That worked perfectly!!!  I appreciate the help!
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now