WSUS error: Compiler Error Message: CS0016: Could not write to output file...access is denied

Hello, all-

I have an issue regarding a WSUS installation that has me completely unnerved.  The error message is given after completing a WSUS install, then accessing the home administration page.  WSUS was up and running smoothly for over one year, then I noticed this and have been unable to troubleshoot it effectively.

I've completely removed WSUS and all downloaded components to start from scratch...error remains constant.

Here is the error in its entirety:

Server Error in '/WSUSAdmin' Application.

Compilation Error
Description: An error occurred during the compilation of a resource required to service this request. Please review the following specific error details and modify your source code appropriately.

Compiler Error Message: CS0016: Could not write to output file 'c:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\Temporary ASP.NET Files\wsusadmin\f88e1ebf\ae1e5c8d\isolbzpj.dll' -- 'Access is denied. '

Show Detailed Compiler Output:

c:\windows\system32\inetsrv> "c:\windows\\framework\v1.1.4322\csc.exe" /t:library /utf8output /R:"c:\windows\\framework\v1.1.4322\mscorlib.dll" /R:"c:\windows\\framework\v1.1.4322\temporary files\wsusadmin\f88e1ebf\ae1e5c8d\assembly\dl2\0afdce00\00f74862_2f67c501\adminstrings.dll" /R:"c:\windows\assembly\gac\system.enterpriseservices\1.0.5000.0__b03f5f7f11d50a3a\system.enterpriseservices.dll" /R:"c:\windows\assembly\gac\\1.0.5000.0__b77a5c561934e089\" /R:"c:\windows\assembly\gac\\1.0.5000.0__b03f5f7f11d50a3a\" /R:"c:\windows\assembly\gac\system.drawing\1.0.5000.0__b03f5f7f11d50a3a\system.drawing.dll" /R:"c:\windows\\framework\v1.1.4322\temporary files\wsusadmin\f88e1ebf\ae1e5c8d\assembly\dl2\235055fe\00819851_2f67c501\admincontrols.dll" /R:"c:\windows\assembly\gac\system.xml\1.0.5000.0__b77a5c561934e089\system.xml.dll" /R:"c:\windows\assembly\gac\\1.0.5000.0__b03f5f7f11d50a3a\" /R:"c:\windows\\framework\v1.1.4322\temporary files\wsusadmin\f88e1ebf\ae1e5c8d\assembly\dl2\01e9e814\0016535c_2f67c501\administration.dll" /R:"c:\windows\assembly\gac\system\1.0.5000.0__b77a5c561934e089\system.dll" /R:"c:\windows\assembly\gac\system.web\1.0.5000.0__b03f5f7f11d50a3a\system.web.dll" /out:"C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\Temporary ASP.NET Files\wsusadmin\f88e1ebf\ae1e5c8d\isolbzpj.dll" /D:DEBUG /debug+ /optimize- /warnaserror /w:1  "C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\Temporary ASP.NET Files\wsusadmin\f88e1ebf\ae1e5c8d\isolbzpj.0.cs"

Microsoft (R) Visual C# .NET Compiler version 7.10.6310.4
for Microsoft (R) .NET Framework version 1.1.4322
Copyright (C) Microsoft Corporation 2001-2002. All rights reserved.

error CS0016: Could not write to output file 'c:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\Temporary ASP.NET Files\wsusadmin\f88e1ebf\ae1e5c8d\isolbzpj.dll' -- 'Access is denied. '


Please note that I have verified file access permissions for the following:

1.  %systemroot%\temp, %systemroot%\tmp
2.  %systemroot%\WINDOWS\Microsoft.NET, including all child objects

I can't believe it is a file permissions issue as the error states because I've done the following, simply to test:

1.  I've ensured localmachine\aspnet account has full permissions to folders and child objects
2.  I've added localmachine\aspnet account to the localmachine\administrators group
3.  I've done steps 1 and 2 for the network service account
4.  Effective permissions shows these accounts to have full control.

Am I missing something?

The way things have gone lately, I'm seriously considering getting away from Microsoft's instability.


Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

mattguilAuthor Commented:
I've even given 'everyone' full control of the files and child objects mentioned above just to test the permissions error.

Same result.
mattguilAuthor Commented:
Here is the solution you posted:



You see this error if you have previously run IISLockdown on this machine.

If so, please check the permissions on C:\WINNT\Microsoft.NET\Framework\v1.1.4322\cvtres.exe. Depending on the options used, IISLockdown many have denied ASP.NET access to this file.

ASP.NET requires Read & Execute permissions on this file.

If you review my submitted question...this has been done.  Tha


I have already followed these steps using this article.  No dice.
Cloud Class® Course: Microsoft Windows 7 Basic

This introductory course to Windows 7 environment will teach you about working with the Windows operating system. You will learn about basic functions including start menu; the desktop; managing files, folders, and libraries.

oops...sorry...I saw the Everyone part, but glanced over the part you posted.

And the OS is ??
mattguilAuthor Commented:
Server 2003 standard.
Most I can do is point you in a general direction...since I'm not there:

and basically:

I wish I could be more help...

You said WSUS was up and running smooth for over a year, but right before that you say you get the error during an install.  What happened?  Was the server's role possibly changed (like running dcpromo or similar) or did you install SP1 or what?  Just curious what might have changed after it'd been running fine for so long.
mattguilAuthor Commented:
That's the mystery.  I can't pinpoint any major changes is a project server that is running WSUS and Spysweeper Enterprise.  I had an ipconflict that I resolved, but other than that...nothing major.

While troubleshooting, I rolled back all OS updates, including .Net Framework updates back to version 1.4...still no dice.

Very frustrating to say the least.  I believe I'll wind up backing up the Spysweeper install, and reformatting the server.  Tough to swallow, especially with an already overflowing workload.  

Ah, the life of an admin.

Thanks for the help.  I appreciate it, and will follow the links you sent.  More than likely, I've already checked into them as I've completely exhausted my googles.  

Thanks again,
Have you tried reapplying updates at this point like SP1 and .NET framework 2.0 ?

I'm curious especially if applying .NET framework would help.
mattguilAuthor Commented:
I'll do that now.  sp1 is installed, and was from the beginning (pre-good-functioning-wsus-install).

I never removed sp1.  

I'll let you know how reapplying the updates goes.

Check the permissions on the temp path that the *system* environment variables "Temp" and "Tmp" point to.
Set the necessary permissions as described here:
PRB: CS0013 or CS0016 Compilation Errors in ASP.NET Web Applications
mattguilAuthor Commented:
Already tried that.  No dice.

Thanks for the input.
mattguilAuthor Commented:
Okay, updates complete with the same error result.

I'm wondering if this may be an issue concerning the Microsoft SQL Desktop Engine.

However, I'm having trouble finding documentation on how/when that engine is actually used.  Could a misconfigured or non functioning MS SQL Desktop Engine be the culprit involved in the admin page errors?
It seems unlikely to me considering the errors.

Since you started from scratch again anyway could you do this(?) :

follow these instructions in order

1.  Uninstall WSUS
2.  Uninstall IIS (if you can, not sure if you have other things on the server that depend on it)
3.  Uninstall MSDE
4.  Install SQL 2005 Express (replacement for MSDE)
5.  Install IIS with  
6.  Install WSUS

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Same Problem, Same steps, Same rate of dandruff production - As a footnote did you exclude certain system files/folder from whatever Anti Virus file level scanner you use/d ?
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.