[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 680
  • Last Modified:

Data lights flash on HP LaserJet but nothing gets printed from a Mac that had permission problems.

I'm on a Mac running OS X.2.8. While trying to print from MS Word 2004 originally, I got the error message,

"Word cannot print due to a problem with the current printer. Make sure you have a printer selected in Print Center. You may need to print again or adjust your printer settings."

I also got an error when trying to print from TextEdit:

"Print. Error while printing."

I figured I'd try to re-install the printer. After downloading the hp LaserJet Installer v4.9 EN, I tried to run it and it gave me an error message that I wasn't an administrator and couldn't run the installer. Of course the account WAS set up with admin priviledges.

I've had this problem before with Jaguar when permissions were messed up, so I tried to run Disk Utility to fix the permissions, however, even the permissions to run Repair Disk Permissions under First Aid were messed up and wouldn't let it fix anything. I manually used chmod and chown to fix the permissions on the file and that let Repair Disk Permissions run with enough priviledges to fix the permission problems. I was then able to run the HP Installer for the the printer. Of course I deleted the HP folder out of the printers folder before running the installer to make sure the old ppds were gone.

After doing this, and re-setting up the printer, after I hit the print button, the data and attention lights on the printer flash for a second or two and then it just stops and nothing prints. Other Macs at the college have no problem printing to the printer, and when I tried to set up and print to an HP 4050 across campus, the same thing happened. the data light flashed briefly, but nothing ever got printed. Also, there was no message kicking back to the Mac. The job just dissappeared.

I tried going into another previously setup admin account on the same machine and tried to print from that account only to find out that it still had the same error messages popping up from before I tried to fix the permissions. Any ideas on how to solve this would be greatly appreciated... Thanks everyone!
0
dscits
Asked:
dscits
  • 4
  • 3
  • 2
  • +1
1 Solution
 
dscitsAuthor Commented:
Oh, I think I forgot to mention, it's using a jetDirect card so it's a network printer.
0
 
hdhondtCommented:
You don't mention which Laserjet, but on the assumption that the printer has PostScript installed, I would bypass the installer. Get the ppd file and copy it to Library/Printers/PPDs/.../english (can't remember the exact folder name) or anywhere else on the hard disk.

Install the printer from Print Centre, and if it can't find the ppd file, point it to the location where you installed it. That's all that is needed with a PostScript printer.
0
 
dscitsAuthor Commented:
The printer is an HP Laserjet 4200n printer.
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
dscitsAuthor Commented:
I also tried creating and printing from a new account and had the same error messages pop up.
0
 
wyliecoyoteukCommented:
Sounds Like your CUPS setup is screwed.
It may be applying the wrong filter or driver, or the port or queue may be  wrong.
If you can't print to any printer, it is more than a driver issue.
If the light is flashing and nothing is printing, then the printer is not recognising the header.

try browsing http://localhost:631, and see if CUPS pops up

Unfortunately, I do not have a Mac at home (where I use EE), but this works with Linux


0
 
macassistCommented:
Check out Print Centre Repair from http://www.fixamacsoftware.com/software/pcr3/index.php - you can clear out the temp folders and check the permissions on the underlying CUPS system (I think wyliecoyoteuk is right that it's a problem with CUPS) - this has helped many of my customers get out of similar situations.

Regards

Sean

PS I would probably delete all printers, run Print Centre Repair (clear out temp folders and repair permissions), then re-setup the new printers, then recheck the permissions in PCR.
0
 
hdhondtCommented:
As the 4200 supports PostScript, CUPS is not needed. PostScript is by far the preferred printer language on the Mac. When you add a printer from the Print Centre, the Mac will see it on the network under AppleTalk (or you can create a TCP/IP port for it if you prefer) and the only file it needs is the ppd. HP make it hard to get the ppd, but you can get it from a Windows PC that has the driver installed - it's just a text file (search for *.ppd under c:\winnt\system32\spool). But I suspect that the HP installer has already  installed it on the Mac anyway.

Finally, if all else fails, you can start by installing it as a "generic PostScript printer" (the default if the Print Centre can't find the ppd). That will work but you will miss printer specific features (duplexing, special paper sizes, etc)
0
 
macassistCommented:
CUPS is the underlying printing technology in OS X, whether the printer is AppleTalk, Rendezvous, Windows, IP, whatever and no matter the language used.

You can confirm this by going to the CUPS admin page mentioned by wyliecoyoteuk and seeing that all printers of all types are presented on the Manage Printers page.

Yes, you only need a PPD for a PostScript printer, but the underlying engine which is using that PPD is CUPS - Print Centre is just a frontend to CUPS.

What the original poster described matches what I've seen sereral times with a CUPS system with mucked up permissions or temp files.

Hope that's of use

Sean
0
 
hdhondtCommented:
Thanks macassist - I did not realise cups is that deeply embedded into OSX
0
 
dscitsAuthor Commented:
Thanks, Print Centre Repair did the trick. That's an awesome piece of software. I'm registering a copy right now. Even though the Repair Disk Permissions utility fixed most of the problems, there were still permissions issue problems with print center that were only fixed by using Print Centre Repair. As always, thank you experts, you're amazing!
0

Featured Post

Upgrade your Question Security!

Add Premium security features to your question to ensure its privacy or anonymity. Learn more about your ability to control Question Security today.

  • 4
  • 3
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now