Zero display service error with P4, 3.00 GHz, ATI Radeon 600/550 series PVI-express, error happened after reinstalling new driver

After reinstalling a new (or possibly old) driver of ATI, i got the error message "Zero display driver error"
I play momentan mainly Everquest2, and have permanent VPU recoveries and reboots.
So I switch between Catalyst 5.2 (more solid) and 6.3, the newest package.

After having the PCI.SYS error and my system was practically dead, I reinstalled everything new.
New MB Intel 945 GTP, existing CPU P4, 3.00 GHz, 1022 MB DDR-2 RAM, new Harddrive Seagate and existing Graphics card ATI 600 Pro.
After finishing the basic installation of Windows XP Professional with SP 2, I got on the recovery console same error message PCI.SYS missing or corrupt.
All installation is nicely done, all drivers are newest (microsoft, intel and ATI)

Can you give some useful advice?
manfred1311Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

manfred1311Author Commented:
to tip 1: I get this blue screen with PCI.SYS error exactly when i start recovery console, but have no problem to start windows OS, I already copied this file new and have for all purposes on a floppy too, error message still continues, file is ok.

to tip 2: very useful, would have liked it earlier, found out by myself the hard way
pls chech the file version that should be correct, Windows overwrites this file with SP 2, an existing hotfix i cannot find (have hotfix number)
original file is version 5.1.2600.0, SP 2 file is 5.1.2600.2180
now the problem: with file 2180 i can run windows, with file 0 i can run recovery console, this cannot be right
One thing more to check: have XP pro SP2, but get recgnized as win2000, any knowledge about this?

3. Download file no more exists, link

4. Microsoft is static, i don't have hardware incombatibity or fault products, RAM modules are checked separately with MEMTEST and MEMTEST86 for min 2 hours each module with no errors, only problem could be incombatibility with ATI

I wait for response, and response to my other problems, think they are combined
If you need error reports, have plenty of them, from ati, microsoft and EQ2

best regards
manfred


nobusCommented:
i'm starting to think you have a corrupt xp cd.
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

manfred1311Author Commented:
was thinking the same, but could not yet check it, because after a clean new setup of new OS on new components got immediately same errors, any way to solve this without having to buy new Win CD (my primary problem is that i live in mexico and here it's very hard to find an english version of XP pro (I'm german), but i have an 5 years old original WIN XP home edition CD, I really should try to set this up, thanks for suggestion.

btw, your service is really quite good, subscribed for 1 month, am sure will continue,
any other prices for more licenses ?

keep you informed, but pls check about ATI problem, this is a problem that i share with thousands, not setupCD problem, the registry entries are very strange sometimes,
only thing i could not try is other MEMORY configuration, have no BIOS possibilities, or at least don't know

regards
manfred
nobusCommented:
one thing that is bugging me, is : you replaced all hardware, except the ATI card. Can this be the source of your problems? I suggest trying another video card, even a cheap pci one for testing the issue.
manfred1311Author Commented:
replaced it too, had earlier another ATI card (300 series), but i live in mexico and ATI is here only solution, all others are VERY hard to get for PCI-express,
for example, for my DDR-2 RAM I waited nearly 2 months (wanted 2 GB, got just 4 sticks with 256 MB), so I really would like to change back to Geforce (had them last 10 years), but at the moment no chance.
manfred1311Author Commented:
Have a very strange situation:
I have a second SATA Harddrive, that was "infected" with the PCI.SYS error and blue screen
Now I formatted this drive new, disconnected the drive with OS WIN XP Pro and WANTED to install my Win XP Home Edition (Original) on the new formatted drive.
The BIOS I reset to optimal defaults, rearranged startup positions and rebooted.
After all drivers were loaded from CD I got the blue screen with PCI.SYS error.
What can cause this, practically a virgin system ?
nobusCommented:
it would be a bad device, so i suggest installing your system with only the essentials connected :
mobo + cpu, 1 ram stick, video card, keyb + mouse, 1 disk and cd drive
According to this link, it is bad hardware : (and how to fix it)

http://support.microsoft.com/?id=319136
manfred1311Author Commented:
exactly this i did, with the exception that i ran 4 mem sticks
but the microsoft link is not acceptable for me, it thinks of an OS on harddisk
I tried to install a NEW OS on fresh formatted HD
how can something be missing on an empty space ?
I think, windows has some info stored somewhere (MBR?)
other possibilities: I made just a quick format (will try it other way) I disconnected PC for more than 1 minute (should be enough)
The problem same can result in ATI driver errors, after i changed back my harddisk, I got about 15 to 20 errormessages regarding Windows recovered from a "serious error caused by ATI driver"
Both Microsoft and ATI did not respond or have no idea, are researching
I cannot imagine I am the only one with this problem
I no more send them (microsoft has already 100s of them from me)
which version of PCI.SYS is correct (should be newer edition that comes with SP2, but microsoft proposes to overwrite it with the old one (see your link and other 2 or 3 links i found in knowledgebases)
The Intel drivers (spacial the integrated audio system driver) require SP2 installed (PCI.SYS new ed)
The ATI Catalyst requires SP2 and Framework installed (PCI.SYS new ed)
But microsoft OS only functions with PCI.SYS old edition
There is no logic, something is wrong
My OS ONLY works with PCI.OLD, Recovery console ONLY works with PCI.NEW, System restore don't work at all, I am NOT able to restore my system even to a date 5 minutes ago, I think, same PCI.NEW is required
When I overwrite PCI.SYS, I am NO MORE ABLE TO RESTART MY SYSTEM IN ANY WAY, everything, really everything is blocked by this PCI.SYS error screen
One last point of view, my system is new setup about 14 days ago, but I had to make 100s "unclean" reboots, so the chance for data corruption is very high

Pls check this, you are my last hope
manfred

nobusCommented:
>>   how can something be missing on an empty space ?   <<   that is why i suspected a bad xdp cd.
try if this looks ok : download the knoppix cd, and boot from it.
If all looks fine, you have a good hardware, AND a software problem; if not the opposite.

www.knoppix.org
manfred1311Author Commented:
so, now we know more,
have clean system, only hardware is MB INtel D945 GTP (3 weeks old), P4 3.00 GHz (about 2 years old), ATI Radeon 600 PRO PCI- Express (2 month old)
4 RAM sticks (tried it same with only 1 and tried all 4) DDR 2 256 MB, 1 CD ROM TDK, 1 PS 2 Mouse, 1 Keyboard, 1 Harddrive SATA Seagate 150 GB
Harddrive is fresh formatted (3 weeks old), even have new tower with plenty of fans
now i tried to install WIN XP PRO from CD > fails with blue screen PCI.SYS error (this XP CD is running in my office with no problems)
now I try my other OS, WIN XP Home edition (Original CD) > fails with blue screen PCI.SYS error
So the software should not be a problem, the chance that 2 OS CDs have same mistake is practically 0
Keyboard and Mouse are not trouble devices (hope so)
all MEM sticks i tested with MEMTEST 2 hours each with no error messages
the motherboard is new, former had Intel D 915 GEV and Intel D 945 GTP, last one was destroyed by ? (5 days after warranty end)

Si I don't believe it's bad hardware or bad software
I think it's an incompatibility between some programs, that overwrite important files

I wanted to download KNOPPIX, but my internet speed sucks terrible (have Broadband DSL connection, until today quite fast)
My actual download speed is 3 kb per sec, so the download would take 18 days
once again, i cannot believe that i am the only one having this problem
PCI.SYS is just killing > original one MUST get overwritten by SP 2, new one don't work at all, Hotfix 890463 (for fixing PCI.SYS problem) no more exists
one last question: what are fault bucket errors ?
 regards
manfred1311
manfred1311Author Commented:
Thanks for prompt response

Interesting article about fault buckets, I could not find anything useful in any windows databank
second link found earlier, but not very useful for fixing my problems
third link is very useful, lot of new aspects for me, article of Brien M Posey very useful for non-experts like me,
just what i was looking for and never found, thanx
so your links kept me busy until now (roughly 10 hours), but now i have a new WINXP startdisk with SP2 included, and I can imagine, with this I can prevent the PCI.SYS error, let's just try it, but before that step I want to create a KNOPPIX-CD, just to be on the safe side

Nobus, thanks for all this info that really helped me understand a little bit better the problem situation, whether it really solves the problem, i have to find out.
I keep you informed
(as i saw you get scaled by a point system, you likely would get my max points for your kind of service both in time aspects and info aspects, good job til now)

manfred1311


manfred1311Author Commented:
I forgot to mention something:
the link to paul thurrott's SUPERSITE (really earns this name) was just great,
step by step docu that works for everybody, even the amateurs like me, not the Hitech talking of knowledgebase articles like microsoft and most others.
Other thing, a lot of the links in your links are no more active, if you want to actualize your databank (i know the things in this business change VERY fast)

would like a KNOPPIX guide from Paul Thurrott.

btw, found Omega drivers for ATI, will try them out (recommended by you?)

manfred1311
manfred1311Author Commented:
new start-CD don't work, I get NTLDR is missing error (should not be on CD)
Bootorder is correct, CD ROM, Harddrive......, made Floppy Disc with missing files (NTLDR.com and NTDETECT.COM and BOOT.INI)
After my knowledge this error only occurs when MBR is heavy fragmented or damaged, so just on harddisks, am I wright thinking?
Tried Omega driver for ATI card, same problems, but possibly has no chance with all the faults on my harddisk
 manfred1311
nobusCommented:
>>  Other thing, a lot of the links in your links are no more active  << sometimes servers go off line, but they worked all when i posted them.
i do not understand this :   >>  new start-CD don't work, I get NTLDR is missing error   <<  can you clarify what does not work, and when do you get the error? Normally, NTLDR error you get when starting from the harddisk, when it does not find the NT loader, needed to start the OS
i did not find a knoppix guide, but it works similar to windows, this can be of interest :

http://microsoft.weblogsinc.com/2004/11/20/excellent-guide-to-recovering-windows-data-with-knoppix/
manfred1311Author Commented:
don't be offended, I just posted it for your info, what you know you must not look for
thanks again, article is very useful, simple computer language, good understandable for me
ok, i produced a bootable start-CD, checked it in all parts, it's identical like in the desciption,
I fomatted my older disk new (not quick) and deleted the partition (found out after formatting still were 22 MB data on the disk)
I hope i think right to put the harddisk in state of "like a virgin", brandnew
then i disconnected my running hard disk, so only "virgin" in PC, 1 CD ROM, ATI card, nothing else
I changed BIOS startroutine to 1 cd 2 harddisk 3 floppy 4 intelnet and powered down for more 1 minute
Power on, disk in drive and wait for 1st screen: NTLDR is missing > reboot (did it 3 times)
checked BIOS, all ok, checked CD, right CD, just don't get recognized in startup
my thinking: still data on harddrive? MBR active ? I have to wipe the disk ?

In the meantime I updated my OS system with exactly this disk, but from windows, practically repaired it or reinstalled it
everything looks quite good so far, will test now
keep you informed

before i updated, i switched the pci.sys, replaced it with the original one, and tried to get the recovery console running,
and was quite surprised, that absolutely nothing changed, recovery console ends in blue death, win is working
but if it's not the driver, what forces the error screen?
So I checked device manager, resources by connection, input/output:
question: is it normal that start and ending adress is same?
00000000 - 0000000f direct memory access controller
00000060 - 00000060 motherboard resources
other thing i don't understand: PCI-Bus properties: Driverdate 07/01/2001
                                                                          Version 5.1.2600.0
but in driver details:                                             Version 5.1.2600.2180 (xpsp_sp2_rtm.040803-2158) ?

made just complete virusscan, no virus found
updated BIOS and all other INTEL files to latest,
stay at the moment with OMEGA ATI driver (don't use CLI.EXE, that caused me troubles)
and hope the testing now gives me more stability in the system (last days iexplorer and many other programs were no more working nicely and quite often shut down by windows: sorry for inconvenience, but restart program new....)
scandisk, some other performance and i go testing..

keep you informed and hope you don't get bored by all this
manfred1311

nobusCommented:
>>   my thinking: still data on harddrive? MBR active ? I have to wipe the disk   << could be .
you can test the drive with one of these, and zero fill the drive, this will erase all data on the drive.
Now regarding the PCI.SYS error : i found here a reference to this error, and the problem was cured by using an xp CD with SP2 integrated.  Maybe that is something to try?
...and as long as the problems are interesting, i will not be bored; in fact it is from those Q's that i learn a lot too.
manfred1311Author Commented:
installed from a CD incl SP2, just not yet checked it for this matter
but i have a lot less problems now, but off course new ones
regarding my hardware, some of my drivers require 1.) SP2 , 2.) Framework 1.1, another Framework 2.0 (Microsoft says it's no problem to install both, did it)
3.) one server (installed new SQL Server from MS, small edition)
With Event View checked running procedures and fixed until now quite a lot of things, with each restart I get less error messages
will try to eliminate as much as possible by my own, I don't touch anything I don't understand, only things with exact guide
all drivers and BIOS are uptodate (except ATI graphics card BIOS, don't know if it can be updated, ATI has no BIOS downloads)
now i check PCI.SYS by running recovery console........
......am right back
manfred1311Author Commented:
am right back ! just took some time

running recovery console ends in PCI.SYS death screen, possibly I have to install it new to get rid of this error
In the meantime I installed Omegadriver 6.3 instead of ATI drivers, at least fixed DISPLAY SERVICE ERROR with it.
Eliminated most errors, just 1 remaining, SQL server error, want to fix it end of the week
remains 1 question open for now>

Can the BIOS of the ATI Radeon x600 series get updated? and where I can get the BIOS file?
nobusCommented:
the bios? i never heard of a video card with bios. if you mean the drivers, look here :

https://support.ati.com/ics/support/default.asp?deptID=894&task=knowledge&folderID=293

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
manfred1311Author Commented:
sorry, i got a bit confused, a lot of new data in my head, sorry, mixed it up

but got just 30 minutes new problem: Cleaning ARP cache could not get done by windows
contact network administrator (don't have)
found arp commands, but don't know what to do
changed ip address from dynamic to static, but did not resolve error message

only other error is SQLserver want 2 startparameters, 0 is not accepted
i did not touch anything til now in this matter
nobusCommented:
manfred1311Author Commented:
in the meantime system was frozen by "PAGE FAULT IN NON PAGED AREA"
no more safe boot, no CD boot, all ended in death screen
then I removed ATI graphics card and could enter system again

a CD boot was rejected with error message "could not find file HPT3xx.sys"
checked it and "I" found it on CD, compared it with original file, is same, strange

at the moment don't have ANY error message
thanks to your help
but I'm not convinced that it stays that way

btw, installed earlier the program "FREE registry cleaner" (it's not free, so I bought it)
but whenever I ran it and it fixed problems, I got new problems and error messages
so I just run "SYSTEM MECHANIC 6.0", with included Virus scanner Kaspersky (since nearly 2 years with minor problems)

I run some additional tests and hope all is fine

nobusCommented:
actually, you can have had 2 problems at the same time, say ram and video card - that way you keep running around.  I suggest to test all parts and devices on a known good PC
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Desktops

From novice to tech pro — start learning today.