Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

How to give access permission and share my files in my home network?

Posted on 2006-03-27
18
Medium Priority
?
343 Views
Last Modified: 2013-11-16
Hi,

I am using a wireless adapter and has established a wireless connection to a router. There are 3 computers connecting to the router using wireless connection, including my computer.
I have no problem with internet connection.
I have access to all computers in the network and are able to get their shared files. The other 2 computers have access to each other but cannot access my computer. The computers can see me in the network, but when they try to click on my computer and access my folders, it says something like:
"
You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.

Logon failure: the user has not been granted the requested logon type at this computer
"

I can ping to all the computers in the network, the other computers also can ping to my computer. They can see my computer in the network, just cant access.

I am using Microsoft Windows XP professional. How do i set to allow access permission for other computers?

Thanks.

0
Comment
Question by:oldb
  • 8
  • 6
  • 3
  • +1
18 Comments
 
LVL 30

Expert Comment

by:Irwin Santos
ID: 16307492
what OS are the OTHER computers using?
0
 
LVL 15

Expert Comment

by:Juan Ocasio
ID: 16307510
Make sure the other computers have an account on our computer and also try turning off Microsfot Firewall if you have sp2 and the firewall is running.
0
 
LVL 4

Expert Comment

by:wylie_uk
ID: 16309394
try sharing a folder on your PC and set the access permisions to 'everyone ful control'

to do this you must disable simple file sharing in folder options>View from the explorer tools menu (in any folder window) then right click the shared folder and go to properties then the security tab.

click ADD and then type the word 'everyone' and check all the allow tabs.

this is not an idea securce way to share a folder but you wil lnow be able to tell if you are having user permision issues, as it shoudl just allow anyone to view this folder.

if you are having trouble browsing your computer from the network, try typing the path name in directy \\computer\shared_foler in the adress bar.

also do you have any firewall running on your PC, i have know zonealarm to cause issues browsing the network, when the LAN is not a 'trusted' network in the firewall settings..

good luck.

0
Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

 

Author Comment

by:oldb
ID: 16329281
Hi

To irwinpks:
All other computers are using Microsoft Windows XP professional

To wylie_uk:
I cannot find the security tab that you are talking about.
How do I add 'everyone' ? from where?
Can you pls give a clearer direction, thanks.

If I have a user permission issue, how can I set the other computers to 'thrusted' ?


 
0
 
LVL 30

Expert Comment

by:Irwin Santos
ID: 16329784
the security tab will be available when you right click on the folder of the hosting computer.
0
 

Author Comment

by:oldb
ID: 16330670
Is that called "sharing and security" ?

If so, I can not find the "ADD" that wylie_uk was talking about.
0
 
LVL 30

Expert Comment

by:Irwin Santos
ID: 16330731
right click then go to properties, then SECURITY tab..

ADD is there!
0
 
LVL 4

Expert Comment

by:wylie_uk
ID: 16334921
hi..

the security tab does now show as default, to enable it open my computer and from the tools menu select 'folder options then go to the view tab, scrol down the very bottom and uncheck 'use simple file sharing' then click OK

then on your new folder you wish to share, right click it and go to propertieson the sharing tab, select share this folder (just enable file sharing if you have no already done so, it shoulf offer it if it hasnt enabled it already), so if file sharing is enabled, check the radio button that says share this folder, and click the permissions button, 'Everyone' shoudl show up on the permisons window, allow full control/change/read here, then click ok.

then back in the folder properties window, click the security tab that should now show up (with simple file sharing turned off). once in the security tab, click ADD then, then where is says 'eneter the object names to select' type the word 'everyone' then click ok

back now at the folder properties window security tab, highlight the newly entered everyone and select all the allow boxes below and click ok.

another thing you realy need to do is to go to the shared folder from another PC by typing in its path IE. //computername/share  note the the share name is not always the same and the folder name.

try this to test, becasue the issue might not be acess to a share but rather a issue with browsing the remote PC.

also whilst sitting at the pc your haveing trouble seeing on the network, see if you can browse the network and see the shares on the pc your sitting at.

let me know how you get on.
0
 

Author Comment

by:oldb
ID: 16347112
Hi wylie_uk

I have set the security settings as you said, but other computers still cannot access my computer.

I tried the //computername/share command. I can browse other computers,within the folders they set to share. But the other computer cant browse me. Although they can ping to me by using ping "192.some_address" in ms-dos mode.

I have no problem seeing the network, I can browse my own shared folders from:
"My Network Places->Entire Network->Microsoft Windows Network->Mshome->comp_name"

However, my own shared folders do not appear in the 'Entire Network' subfolder as a normal folder. The folders appear in a section called: "Unspecified". And I can not access my folders in the unspecified section. I seen in the other computers, their shared folders will appear in the "Entire Network" folder.

Thanks,
But I still havent solve the problem yet..........................??????!!!!!!!!!!
0
 
LVL 4

Expert Comment

by:wylie_uk
ID: 16347537
ok this is not a simple file permissions issue..
lets see if we can track down whats wrong.

you say you can ping the troublesome PC via ping 192.x.x.x ? can you however ping the computer by its computer name?

check in your services that the server and computer browser are running, if they are not turn them on and set them to automatic.

look in your event viewer under application and system and see if thier are any tell tail error messages. i should have asked you to do this from the outset hehe.

what is the history of this machine? do you know if anyone has turned off any services etc to make it more secure?

do you have a 3rd party firewall? such as zonealarm..if you do make sure firesharing is allowed or that your LAN is set as a trusted network. if you are using windows firewal make sure also file and printer sharing is enable/allowed in the expections.

 
0
 

Author Comment

by:oldb
ID: 16349853
Hi wylie_uk

I can ping "computer_name" from other computer to  my computer.

The event viewer is full of events, how am I going to know which one is related?

I am using norton antivirus, I should have told you , but I tried turning off the anti-virus before and the problem still exist.

I am thinking, maybe I have changed some settings about the security before or norton has changed it for me. How can I set all the settings to default? What is the method in windows that can block access permission?

Thanks
0
 
LVL 4

Expert Comment

by:wylie_uk
ID: 16350428
do you have Service pack 2 installed?

if you are running pre-SP2 you might have internet conection firewall enabled on your network connection?
check in your network connections, check the properties for you lan network connection in the advnaced tab.

did you make a completly new share with full permissions for everyone?

in the event viewer do you have any errors? (red x's) < important may totaly reveal issue.

anti-virus wil not pretent access to shared folders normaly, does your norton come with internet security?

if it does uninstall it completely > Reboot. IT will be the only way to know for sure it is not causing this issue.

and are you running any other type of firewall, including windows inbuilt firewall that comes with service pack2 if it does unistall what you can and disable what you cant.

did you check the services 'server' and 'computer browser' are running? to do this right click my computer and choose manage, then navigate to serivices and applications>services and check the list to see if they are runing

check 'file and printer sharing for microsoft networks' and 'client for microsoft networks' are installed, check this by going to your network connections in the control panel and right clicking your network connection and selecting properties for your LAN and seeing if it appears there.

ok one other thing.. if you have a share named shareX on your troublesome PC sitting still at your toublesome PC can you navigate to \\troublesomePC\shareX or even \\127.0.0.1\shareX please remember the share name is sometimes not the same as the orig folder name.

IF you cannot shortcut navigate to shares on the local PC from the local PC it is unlikely it is a firewall/conection issue.
0
 
LVL 4

Accepted Solution

by:
wylie_uk earned 1600 total points
ID: 16350494
ok i was also thinking that it might be a local security issue.

control panel>adminitrative tools>local security policy

local policies>>user rights asignment>>access this computer from the network 'everyone,ASPNET,Administrator' possibly others i am on a domain here so the rights wil be dif to yours'

also in the same list 'deny acess to this computer from the network' would be good to know if there is anything here at all.
0
 

Author Comment

by:oldb
ID: 16405916
Hi wylie_uk

Sorry for replying so late, have been busy.

Under the "access this computer from the network":
it is empty in security settings. Do I need to add anything in?

But,

Under the 'deny acess to this computer from the network':
It has a security policy called: SUPPORT_388945a0
I changed deleted it to nothing.

Under the 'deny logon locally':
SUPPORT_388945a0, Guest
I deleted it to nothing as well

But it still does not give permission for other computers access

0
 
LVL 4

Expert Comment

by:wylie_uk
ID: 16406828
quote 'Under the "access this computer from the network":
it is empty in security settings. Do I need to add anything in?'

YES! this is most likely why your stuff is not working

in this section add access for the following

Administrators
ASPNET
Backup Operators
Everyone
Power Users
Users
0
 
LVL 4

Expert Comment

by:wylie_uk
ID: 16406843
by the way, once you have updated local security policy, it might take a little while to impliment, you can force an update by typing 'gpupdate /force' at the comand prompt.
0
 
LVL 4

Expert Comment

by:wylie_uk
ID: 16406883
ok something else that might help..

if your not sure what the default settings for a particular policy should be...

right click 'user rights assignment' choose HELP, then in the help screen, expand 'user rights assignment' then click the policy your looking for, then in the right hand window it should have the info and default settings.
0
 

Author Comment

by:oldb
ID: 16414034
Hi,

I changed the "access this computer from the network":
Administrators
Authenticated Users
Everyone
Backup Operators
Power Users
Users

But it still does not give permission for other computers access......

I really appreciate ur help
0

Featured Post

Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article explains the fundamentals of industrial networking which ultimately is the backbone network which is providing communications for process devices like robots and other not so interesting stuff.
In this article, the configuration steps in Zabbix to monitor devices via SNMP will be discussed with some real examples on Cisco Router/Switch, Catalyst Switch, NAS Synology device.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

810 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question