SBS Permissions

I have a customer that has SBS 2003 with only 3 users. They use Medisoft and Quickbooks 06 Pro from which they maintain the common databases on the server in a shared folder. Every couple of weeks they lose connectivity between their client apps and the shared databases on the server and one or more of the users' permissions get changed. One user has only power user rights on the server and on their local machine and Quickbooks Pro is denying her access. Is this an SBS permissions problem?
kdsturg48Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

heathcote123Commented:
In what way to the perissions get changed?

Hve you tried turning on file auditing to see what is changing them?
0
kdsturg48Author Commented:
No I haven't turned on auditing but I will try it and let you know how it goes.
0
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Quickbooks requires that users have LOCAL Administrator rights.  This is something that is contentious among security experts, but generally is not a huge issue.  The only thing that it really does is allow the users to install software on their machines.  This can be countered with a proper Software Restriction Group Policy.

http://www.microsoft.com/technet/prodtechnol/winxppro/maintain/rstrplcy.mspx

There are also some posted work-arounds here:
http://threatcode.com/admin_rights.htm

You should NOT grant Power User rights to those users on the domain.

Jeff
TechSoEasy
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

kdsturg48Author Commented:
I did try giving the user local Admin rights and I also went into the registry and gave rights on the Quickbooks entries. Still couldn't get the domain power user login rights in Quickbooks. So you are saying that local Admins should not be granted power user on the domain? Does that cause problems with programs like Quickbooks?
0
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
kdsturg48,

I don't use the domain power user group... it's really kindof funky and has a couple of "DENY" permission entries... so best to stay clear of it.  You should just create a new security group on the server for QuickBooks and grant that group full access to the server shared folder which has the QBDatabase.  Then, your user should be a member of that group and then should also have local admin rights on whatever workstation they are using.

No reason to go into the registry -- the local admin should have rights by default.  Otherwise, if not you should reinstall the program.

Jeff
TechSoEasy
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
kdsturg48Author Commented:
The reason I went into the registry was because that was a recommendation I ran across when I looked the error up on the Quickbooks site. Sounds like a good idea to set up a Quickbooks user group. I'll give that a try.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.