RDP stopped working after reboot....

I have an ISA 2004 firewall and everything was working perfectly for a long time until the other day when I gave the box a reboot. Now everything is still working except for the RDP from my workstation into the ISA firewall itself.
I have tried RDP from external computers to internal ones and that works, RDP works into my own machine, it's just the firewall.

The rule I have for that is still there. The system policy still allows it and has my IP address, my IP address hasn't changed.....what else could be making this happen???
LVL 1
wlandymoreAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

TannerManCommented:
I assume the RDP service is running on the ISA itself? Just something to check out. It could be that on the reboot a dependancy service failed to start in time and didn't allow RDP to get fired off. Just a long shot.
0
wlandymoreAuthor Commented:
Is that in the regular services in admin. tools?

I don't see anything there for RDP....
0
wlandymoreAuthor Commented:
yeah, I can't see any service running for it and doing a netstat doesn't show 3389 as listening.

How can I re-enable that to open the port for me?
0
Managing Security & Risk at the Speed of Business

Gartner Research VP, Neil McDonald & AlgoSec CTO, Prof. Avishai Wool, discuss the business-driven approach to automated security policy management, its benefits and how to align security policy management with business processes to address today's security challenges.

TannerManCommented:
Right click on my computer
choose manage
go into services/applications
go into services
scroll down till you see TERMINAL SERVICES
right click on it and choose START
that should get you going .
0
wlandymoreAuthor Commented:
yeah, that service was already started. I thought you were saying that there was a specific RDP service which I said I hadn't heard of it.

The only thing I can get from the firewall itself is when I do the logging. It shows an 'initiated' connection and then right after it just closes the connection. Like I said, I seem to have everything up and running, I'm allowed to access it via RDP as far as rules are concerned, but I don't seem to be able to get in.

I have a recent backup of the firewall configuration....maybe I should just try a restore. I really didn't want to do that though so I was hoping it was something easy I was missing.
0
TannerManCommented:
If that service is running then your netstat -a should show 3389 listening. Your firewall logs are your only course of diagnosis at this point, from what I can tell.

(I tested the netstat -a 33889 listening on my ISA 2k4 running on Windows 2k3)
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
wlandymoreAuthor Commented:
Yeah, I did the restore after hours and everything came back. I don't know why this just happened after the reboot but everything's gravy now.

thanks for the help.

(I'm giving you the points since you provided good suggestions and there wasn't much of a way to predict that the restore would clear up a problem like this)
0
TannerManCommented:
Thanks.
Just dang glad it worked for you. I have had issues similar with a paticular rule. I could remove the rule and re-add it and all was well. Strange in deed.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Software Firewalls

From novice to tech pro — start learning today.