?
Solved

Change of Domain password stops MQ on client working

Posted on 2006-03-28
3
Medium Priority
?
3,871 Views
Last Modified: 2013-12-10
We have several developers using Websphere MQ on there PC's. We are running a Windows 2003 Network and have a group set up "domain mqm" of which these developers are members. When they first install all works fine. However the moment they have to change there doman password they get the following error message

"Could not Initialize Websphere MQ service objects. 0x8000401A. The server process could not be started because the configured identity is incorrect. Check the username and password. (AMQ4100).

On their local machines; that are running either XP Pro (SP2) as well as/or W2K (SP4) the services are set to start with Local User credentials. All users have local admin rights with their Domain credentials.

I have tried to remove them from the domain group and rejoin them but still no avail, the only solution is to uninstall the application and re install. I have searched through the IBM support forums but can not find a solution

Any ideas
0
Comment
Question by:smartstream-stp
1 Comment
 
LVL 23

Accepted Solution

by:
rama_krishna580 earned 400 total points
ID: 16343781
Hi,

Problem seems like:
You install WebSphere® MQ (WMQ) v5.3 on Windows® XP SP1. You create a queue manager, some queues, and a channel. After reboot, when you try to open the MQServices or MQExplorer you receive "AMQ4100 Could not initialize WebSphere MQ Services objects 0x8000401A. The server process could not be started because the configured identity is incorrect. Check the username and password".  
 
Cause  :
During install, there is a panel asking whether the domain controllers(DC's) are Windows 2000 or not. A more 'accurate' statement is whether the DC's are a new active directory (AD) domain or not (that is, a Windows NT4 domain or a Windows NT4 to AD migrated domain).

You answered yes to this question and so you were asked for a userid. In this case you entered your own userid. The wizard confirms the supplied userid has enough authentication to start the dcom object and since it does it deletes the musr_mqadmin account as it is no longer required.
The problem with putting your own userid would be that when you sign off, all your processes will be terminated. Similarly strmqm, runmqsc, and runmqlsr are all a problem in this Windows setup because they get terminated on signoff.
 
Solution:
By running amqmsrvn -regserver, WMQ redefines the musr_mqadmin account and configures the dcom object to use it. In a new active directory domain, this would have failed, but because this was migrated, it all works and solves this problem.
As a reference, all the WMQ processes should run under the dcom id except amqmtbrn (which runs under the signed on userid), and amqsvc (which normally runs under SYSTEM).
 
R.K
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Upgrading Tomcat – There are a couple of methods to upgrade Tomcat is to use The Apache Installer is to download and unzip and run the services.bat remove|install Tomcat6 Because of the App that we are working with, we can only use Tomcat 6.…
There are numerous questions about how to setup an IBM HTTP Server to be administered from WebSphere Application Server administrative console. I do hope this article will wrap things up and become a reference for this task. You need three things…
We’ve all felt that sense of false security before—locking down external access to a database or component and feeling like we’ve done all we need to do to secure company data. But that feeling is fleeting. Attacks these days can happen in many w…
Please read the paragraph below before following the instructions in the video — there are important caveats in the paragraph that I did not mention in the video. If your PaperPort 12 or PaperPort 14 is failing to start, or crashing, or hanging, …
Suggested Courses
Course of the Month14 days, 9 hours left to enroll

840 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question