Testing an IPX tunnel (very slow)

Help... have to make a IPX tunnel through a ip only network.  Got it working on a Cisco 2600 but having issues on a 2500.  I think I have just missed something somewhere.  Here is my config

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Test_IPX_Router
!
enable secret 5 xxxxxxxx
enable password xxxxxx
!
ip subnet-zero
ipx routing
!
dlsw local-peer peer-id 40.120.41.1 lf 1500
dlsw remote-peer 0 tcp 10.68.2.1 lf 1500
!
!
!
interface Loopback1
description LOCAL-PEER. DIAL ACCESS#
 ip address 40.120.41.1 255.255.255.0
 no ip directed-broadcast
!
interface Tunnel20
 ip address 172.31.7.2 255.255.255.0
 no ip directed-broadcast
 ipx network 172318
 tunnel source Ethernet0
 tunnel destination 10.64.7.3
!
!
interface Serial1
 description SDLC LINK TO 3174 Waco
bandwidth 192
 no ip address
 no ip directed-broadcast
 encapsulation sdlc
 no ip route-cache
 no ip mroute-cache
 no keepalive
 nrzi-encoding
 clockrate 9600
 sdlc role primary
 sdlc vmac 4000.3174.0800
 sdlc address C1
 sdlc xid C1 017408C1
 sdlc partner 4200.0461.8080 C1
 sdlc dlsw C1
!
!
interface Ethernet0
 ip address 40.120.43.2 255.255.255.0
 ip helper-address 10.64.1.21
 ip helper-address 10.64.4.21
 no ip directed-broadcast
 ip accounting mac-address input
 ip accounting mac-address output
 ipx network 12043
!
router eigrp 1
 network 10.0.0.0
 network 40.0.0.0
 no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet0
ipx route 0.0.0.0. 0.0.0.0 tunnel20
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit
!
!


!
!
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password xxxxx
 login
!
end




The router that this traffic passes through (the ip only network) is simpler with the following config:  I know the Tunnel is correct on the other end because my 2600 has no problems.  I have to make this work on both 2500 and 2600's because we have over 65 sites and both routers are currently used in the field.




Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Test_IP_Only
!
enable secret 5 xxxxx
enable password xxxxxx
!
ip subnet-zero
!
!
!
interface Ethernet0/0
 ip address 40.120.43.1 255.255.255.0
 ip helper-address 10.64.4.21
 ip helper-address 10.64.1.21
 no ip directed-broadcast
!
interface Ethernet1/0
 ip address 10.64.9.10 255.255.255.0
 ip helper-address 10.64.4.21
 ip helper-address 10.64.1.21
 no ip directed-broadcast
!
router eigrp 1
 network 10.0.0.0
 network 40.0.0.0
!
ip classless
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password xxxxx
 login
!
end

Test_IP_Only#  
LVL 2
chiefcrazythumbAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

chiefcrazythumbAuthor Commented:
show ipx traffic
System Traffic for 0.0000.0000.0001 System-Name: Test_IPX_Router
Rcvd:   9185 total, 143 format errors, 0 checksum errors, 0 bad hop count,
        0 packets pitched, 8640 local destination, 0 multicast
Bcast:  2299 received, 7697 sent
Sent:   14422 generated, 545 forwarded
        0 encapsulation failed, 0 no route
SAP:    19 SAP requests, 10 SAP replies, 4 servers
        1 SAP advertisements received, 179 sent
        0 SAP flash updates sent, 7 SAP format errors, last seen from 0.0000.0000.0000
RIP:    20 RIP requests, 20 RIP replies, 175 routes
        0 RIP advertisements received, 871 sent
        2141 RIP flash updates sent, 0 RIP format errors
Echo:   Rcvd 0 requests, 0 replies
        Sent 0 requests, 0 replies
        0 unknown: 0 no socket, 0 filtered, 0 no helper
        0 SAPs throttled, freed NDB len 0
Watchdog:
        0 packets received, 0 replies spoofed
Queue lengths:
        IPX input: 0, SAP 0, RIP 0, GNS 0
        SAP throttling length: 0/(no limit), 0 nets pending lost route reply
        Delayed process creation: 0
EIGRP:  Total received 8594, sent 10840
 Updates received 1062, sent 2136
        Queries received 1576, sent 0
        Replies received 0, sent 1576
        SAPs received 1, sent 1
NLSP:   Level-1 Hellos received 0, sent 0
        PTP Hello received 0, sent 0
        Level-1 LSPs received 0, sent 0
        LSP Retransmissions: 0
        LSP checksum errors received: 0
        LSP HT=0 checksum errors received: 0
        Level-1 CSNPs received 0, sent 0
        Level-1 PSNPs received 0, sent 0
        Level-1 DR Elections: 0
        Level-1 SPF Calculations: 0
        Level-1 Partial Route Calculations: 0
Test_IPX_Router#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
Ethernet0              40.120.43.2     YES NVRAM  up                    up      
Loopback1              40.120.41.1     YES NVRAM  up                    up      
Serial0                unassigned      YES unset  administratively down down    
Serial1                unassigned      YES unset  up                    up      
Tunnel20               172.31.7.2      YES NVRAM  up                    up      
Test_IPX_Router#show ipx server
Codes: S - Static, P - Periodic, E - EIGRP, N - NLSP, H - Holddown, + = detail
4 Total IPX Servers

Table ordering is based on routing and server info

   Type Name                       Net     Address    Port     Route Hops Itf
E     4 xxxxAPPS              A4011B51.0000.0000.0001:0451 300060672/02   2  Tu20
E     4 xxxxDATA              A401A512.0000.0000.0001:0451 300060672/02   2  Tu20
E     4 xxxx                 4CE1AF5.0000.0000.0001:0451 300065536/02   2  Tu20
E     4 xxxx50              4EA731B.0000.0000.0001:0451 300065536/02   2  Tu20
Test_IPX_Router#
0
chiefcrazythumbAuthor Commented:
Here are the oddities about this...  
1.      When I install a new router with this config (2600 or 2500) it seems to run real slow.  A telnet session takes a good while to connect... even one router away... BUT, about 30 min later or so and it becomes normal (like the routes take that long to update).  
2.      An IPX pc on the 40.120.43 network (between the two routers above) loads the novel script extremely and painfully slows.  After it does load... the computer does not show up in the show ipx server list.  

I'm at a loss here.  It works for the 2600 but I did have the same issues there as well.  Seems to be a routing or routing update issue.  I'm not sure.  Please help I'm not a Cisco genius and my super is looking to me to make this work... this is a test bed for a very large project that needs to be completed right away.

Thanks!
500 points!
0
chiefcrazythumbAuthor Commented:
****I have set the pc to auto detect all ipx types
0
Redefine Your Security with AI & Machine Learning

The implications of AI and machine learning in cyber security are massive and constantly growing, creating both efficiencies and new challenges across the board. Check out our on-demand webinar to learn more about how AI can help your organization!

chiefcrazythumbAuthor Commented:
Somebody has got to see my error here... anyone?
0
Don JohnstonInstructorCommented:
It only causes this behavior (slow) when you create the tunnel on a 2500?

Is the first config you posted what you're doing with the 2500?

How much memory is on the 2500?

-Don
0
chiefcrazythumbAuthor Commented:
Yes, I have it working well on the 2600.  But have not been able make this work correctly on the 2500.  The only real changes were to the interface names and some routing details but I cannot figure it out.  I'm thinking I made some errors... but I was hoping for an expert eye to look over my config and see if there was any noticeable mess ups.  I can’t find it.

Memory - I will post this ASAP
0
chiefcrazythumbAuthor Commented:
Test_IPX_Router#show memory summary
               Head   Total(b)    Used(b)    Free(b)  Lowest(b) Largest(b)
Processor     61DB4   14275148    1026652   13248496   13238304   13243480
      I/O    E00000    2097152     335396    1761756    1761756    1761304
0
Don JohnstonInstructorCommented:
First off, I haven't done an IPX tunnel in A LONG TIME! :-)

That said, I can't find anything wrong with the config and it looks like you've got plenty of RAM. If you've tried this on other 2500's and get the same results then I'd guess you're running into a limitation of the 2500. I never had an issue like this but then again, I was using version 10 and 11 code. It could be that after adding in all the features, the 2500 just doesn't have enough horsepower.

-Don
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
chiefcrazythumbAuthor Commented:
What about this statement though

ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet0
ipx route 0.0.0.0. 0.0.0.0 tunnel20

I'm not sure if its correct for this configuration.  It was just an attempt to make it work.  On my 2600 there are 2 ethernet ports and the ip route was only pointed to the interface without the tunnel on it.  On the 2500 there is only one ethernet interface and so I pointed the ip route to it, and no ipx route.  

2600 route

!
ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet1/0

It maybe that the 2500 just cant do this job...
0
chiefcrazythumbAuthor Commented:
Hey Don guess what...

I had tested this on two 2500 routers and it failed.  I just got in another 2500 from a closed location and tested it again and it works fine.  Now I just have to isolate the issue to IOS or memory or just crapy equipment.

Thanks for your help
0
chiefcrazythumbAuthor Commented:
I will post what I find out though...
0
Keith AlabasterEnterprise ArchitectCommented:
Nice one Don :)
0
Don JohnstonInstructorCommented:
Thanks Keith!

Even a blind squirrel will find a nut every now and then. :-D

-Don
0
Keith AlabasterEnterprise ArchitectCommented:
lol
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking Protocols

From novice to tech pro — start learning today.