Eth0 and Eth1 assumed to be an ethernet device fedora

hey experts,

I recently installed Fedora core 5 on my dell xps laptop;Everthing seems to be ok except my wireless thing. So I installed the relevant firmware,kernel module,Ipw2200 packages for my intel pro 2915g wireless card. The problem is  network manager thinks that the the wireless card is also a ethernet one .So when I go to ethernet devices it gives me broad com and intel pro 2915g ,whereas in my wireless deivces I couldn't find the device . Is there any way to make the network manager to think eth1 as wireless device.??/

Ps: Eth0 is wired connection and Eth1 is wireless connection

thanks
Sundeep.
LVL 3
sundeepgopalAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

sheetbirdCommented:
This isn't really a problem.  When your laptop needs to get something of the network, be it internet, NFS, LDAP or whatever it goes to the network device you have configured wether its Wired or Wireless.  These are just two different ways to connect to a network.  As far as not being mentioned under "Wireless" I'm guessing maybe that's for Bluetooth stuff like PDAs, phones etc that can connect to you laptop wirelessly.  If you're looking for Bluetooth you'll have to get a Bluetooth adapter.
kamichieCommented:
This is Linux's normal specification of these devices, when you install a wireless card, it should show up as an eth0 or eth1. This is just how linux handles networking, however what is really confusing is that you don't see the wireless card. I am assuming your running iwconfig in the console and not seeing anything? If you are seeing devices, then everything should be fine, you just have to use iwconfig to configure your wireless network, then eth1 will be able to acquire an ip address.
sundeepgopalAuthor Commented:
hey kamichie
yes
 when I run iwconfig I get
 lo       no wireless device
 eth0   no wireless device

I remember one the guys who used the same packages for the intel pro 2915g got it working..I installed all the packages perfectly but
I'm not able to get my wireless device working ...

Do you hav any ideas?? hope hope hope....
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

kamichieCommented:
Interesting, Okay which version of the kernel are you running?
sundeepgopalAuthor Commented:
My kernel version is 2.6.15-1.2054_FC5..I don't know where i went wrong ..I tried installing diferent pacakages but hardly with any result
rindiCommented:
what happens when you run iwconfig eth0?
rindiCommented:
Sorry, my mistake, I wanted to enter iwconfig eth1.
kamichieCommented:
Did you install the IPW2200 drivers from Fedora Core or from the ipw2200 website. If so which version did you use? Did you upgrade the IEEE80211 Subsystem. If you don't have any idea what I'm talking about, let me know and we will start from the begining.

One final thought, did you install the firmware for the drivers. Without it the drivers will not work.
sundeepgopalAuthor Commented:
hey rindi,
iwconfig eth1 gives
 no such device
When I type NetworkManager $ , I get the network Icon near the toolbar ,beside the clock display. And It directly connected to wired connection .

and kamichie ,I installed all the relevant packages from the website
the packages I installed are
ipw2200-1.1.0-40.rhfc5.at.i386.rpm
ipw2200-firmware-2.4-7.at.noarch.rpm
ipw2200-kmdl-2.6.15-1.2054_FC5-1.1.0-40.rhfc5.at.i686.rpm




kamichieCommented:
Interesting, look in the Fedora Packges for the IEEE80211 subsytem upgrade, the newer version of the IPW2200 drivers won't work without this. And for some crazy reason the IEEE802111 subsystem was rolled back to an older version in the 2.6 kernels. I would suggest trying to upgrade that kernel module. At least thats what I had to do on my Slack Box with the 2.6 kernel.
rindiCommented:
You should get the current firmware for the device and your kernel.

http://ipw2200.sourceforge.net/

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Distributions

From novice to tech pro — start learning today.