Unable to access "My My Network Places" from a specific network/vlan.

Ok I have working on this problem for weeks and can’t find a solution to it. My problem is that one out of my 5 networks is unable to browse “My Network Places”. Users from the other 4 can browse theirs fine but on one building the cant.

Now before I start getting turn of your firewall solutions ill tell you that is not the problem. The windows firewall is disable through the whole domain.

So let me explain my set up to you.

5 subnets 192.168.1.0 – 192.168.5.0/24

For my layer 3 routing I use a cisco 3560 switch.

Each of one of my networks is a vlan that plugs into my 3560 switch.

Each one of my vlans forwards dhcp broadcast using the ip helper-address command

There are not acl list between vlans and every vlan interface is configure the exact same way.


Ok now for what I have tried on the troubled network, I have used browstat status, elect, getmaster, forceannounce, and announce. Each one of these commands except status gives me an access denied error. The status command just tells me that “browsing is not active on this domain”.

Each one of the other networks provides me with successful results using each command.


Does anyone have any idea what might be going on here?
LVL 2
djohnson104Asked:
Who is Participating?
 
masterbakerCommented:
You don't happen to have any old workstations (Windows 9x) or Linux servers running Samba do you?  Just curious as they could cause browsing problems (could - not guaranteed).

One workaround you could try (if this is do-able) is to create a 6th VLAN (for IP network 192.168.6.0) and start migrating PCs to it.  Assuming everything works as I'd expect, you should be able to get PCs up and running here.  Eventually you'll narrow down where/who the culprit is.  I realize this could be a major undertaking, so you may try batches of computers at first.  Just a thought in case you aren't able to track down the cause.  Sometimes you have to cut your losses and just move on! :)

Jeff
0
 
Keith AlabasterEnterprise ArchitectCommented:
As you done these checks, I am assuming you have performed the obvious such as ensuring nbt is enabled on the card etc. i'll also assume you can ping all the other devices by both IP and by name.

Download and install ethereal (www.ethereal.com), its a free analyser. Run it on the troubled PC.
Start a capture and try to browse the network places. What do you see in the log?
0
 
djohnson104Author Commented:
Yes nbt is enabled, this is a problems on a network with 100+ computers so its not just one. I can ping i can access though \\computername.

I have ran ethereal and have seen the browser request and host announcment but it never lets any computer become master browser.
0
Cloud Class® Course: MCSA MCSE Windows Server 2012

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

 
Keith AlabasterEnterprise ArchitectCommented:
Just as a test, an you add an entry in the lmhosts file with the nsame and ip address of the master browser on a different subnet?
0
 
Keith AlabasterEnterprise ArchitectCommented:

Do the other machines see this machine OK?
Also, if you plug this PC into a different VLAN port, does it work then?
0
 
djohnson104Author Commented:
yes if i move any comptuer from that network to another it works fine.

Im not sure what you mean by add the nsame and ip address. Do you mean a name and ip addres?
0
 
Keith AlabasterEnterprise ArchitectCommented:
Sorry, tired and poor typing. Yes, that is what I meant.
0
 
djohnson104Author Commented:
i added the computer name and ip address

computername 192.168.11.23

on the lmhost file and nothing has changed.
0
 
Keith AlabasterEnterprise ArchitectCommented:
Did you reboot the PC for it to take effect?
have you got a sanitised output of the switch config? For a whole subnet to be having the same issue the common element is normally the place to look. especially as you have four other subnets on the switch that rae working.
0
 
djohnson104Author Commented:
the layer 3 switch has ever interface configured the same. Im just lost.
0
 
Keith AlabasterEnterprise ArchitectCommented:
All the same? Can you post the config?
0
 
djohnson104Author Commented:
Keith, i have posted the router config in the cisco forums and a cisco tech has even worked on the phone with me. We dont thing that that has anything to do with my problem.

Mastebaker thats a goood idea i am going to go over there and check for a linux machine today and see if i can find one.  I have also been told by another forum to bring up a DC on that network and it should take over the masterbrowser from anything. If that does not work then i will resort to Masterbaker's last suggetion and start moving to vlans.

Thanks for the help guys ill keep you posted.
0
 
djohnson104Author Commented:
Fixed it!!!

Masterbaker you guessed it right but it was not a 98 or linux machine. We build simulators at our work and we have random XP machines around and 4 of the where in a workgroup. So i found the master browser in there. I found it by running the browstat getmaster command and running ethereal. When i ran this it told me access denied so i figured etheral has to tell me whos saying access denied, so i ran it and it did. Ran gfi network security scanner on it and wala it was master browser. Disabled master browser on those four computers and then one of my domain computer grabbed master and everything works fine. Thanks.
0
 
masterbakerCommented:
Nice sleuthing work there!  I'm glad I could help get you going in the right direction.

Jeff
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.