All mail I send from sendmail gets bulked even though it isn't spam.

Posted on 2006-03-28
Last Modified: 2013-12-16
All the mail we send out is getting bulked even though it isn't spam. Here is an example header..


X-Apparently-To: via; Tue, 28 Mar 2006 11:33:18 -0800
X-Originating-IP:      []
Return-Path:      <>
Authentication-Results:'; domainkeys=neutral (no sig)
Received:      from (EHLO ( by with SMTP; Tue, 28 Mar 2006 11:33:18 -0800
Received:      from (localhost.localdomain []) by (8.13.4/8.13.4) with ESMTP id k2SJXHXv002660 for <>; Tue, 28 Mar 2006 11:33:17 -0800
Received:      (from apache@localhost) by (8.13.4/8.13.4/Submit) id k2SJXHJ6002659; Tue, 28 Mar 2006 11:33:17 -0800
Date:      Tue, 28 Mar 2006 11:33:17 -0800
Message-Id:      <>
Subject:      lets test this out
From:      ''  Add to Address BookAdd to Address Book  Add Mobile Alert
Reply-to:      ''
MIME-Version:      1.0
Content-type:      text/html; charset=iso-8859-1
X-Mailer:      PHP/5.0.4
Content-Length:      27


The name of the server used to be and I changed it to but that didn't work. I think it has to do with the bottom recieved line
'Received:      (from apache@localhost) by'
The mail is being sent out from local host and it should be sent out from

Does anyone know how to change this or have any ideas? Our members aren't even getting responses to their questions..

Question by:andy_thedestroyer
    LVL 4

    Expert Comment

    Is it using sendmail or postfix? (Or something else perhaps).

    You may want to confirm your actual domain name is in /etc/hostname and /etc/hosts. This will ensure programs that use gethostbyname() will retrieve your correct domain name.

    Also, ensure your HELO is set to a domain name other than 'localhost.localdomain' or similar. For postfix you would do the below in

    smtp_helo_name =

    This problem would usually be down to the mail system you're using being unable to retrieve your domain name. If this doesn't solve it, post up the mail app you're running and a config file.
    LVL 1

    Author Comment

    It is Sendmail.

    How do I set the HELO in sendmail.

    When I changed the name of the system to match the domain I did it in the files /etc/hosts and /etc/sysconfig/network

    I have never configures sendmail before so I am kind of taking stabs here but I did find this line

     O DaemonPortOptions=Port=smtp,Addr=, Name=MTA

    shouldn't I set this to the ip that my domain resolves to instead of localhost


    thanks for the help!!!

    Accepted Solution

    With O DaemonPortOptions set as only localhost you won't be able to receive any mail as sendmail will only be listening on localhost.

    This should be set to if you want all interfaces to listen or a combination of O DaemonPortOptions statements if you have more than one interface and need to exclude any.

    Also your domain has no MX record and your host at has different fwd and reverse dns entries which may also be causing you bulk issues with some mailhost. Are you only getting problems sending to YAhoo or all recipients ?

    LVL 1

    Author Comment

    We are getting bulked or marked as spam no matter who I send to and we are NOT spammers.

    I am not so concerned with recieveing email because we user another server for that. This one is just for sending.

    I am not the best with DNS issues. I noticed the forward and reverse issues. I configured the NS so now

    nslookup  AND

    resolves to

    but a reverse lookup


    still points to

    Non-authoritative answer:        name =  
    Authoritative answers can be found from:   nameserver =   nameserver =   nameserver =        internet address =        internet address =        internet address =  

    that is the old name of the server. I changed it to but this is still getting shown
    How do I change this?

    I know very little about MX records. I know we don't have one and I have been doing some reading but and still having trouble.
    Do you know how to set this up? or know a good tech article?

    I also see that the line in the gmail header I included below and apache@localhost
    I am using php to send this out and the return path and the recieved lines always have these address no matter what I send from php
    They should say

    X-Gmail-Received: 95f02ce614852dbe93561746eeeae42db6f0a3f7
    Received: by with SMTP id v10cs35937pyl;
            Thu, 30 Mar 2006 15:44:44 -0800 (PST)
    Received: by with SMTP id 1mr409036nzm;
            Thu, 30 Mar 2006 15:44:44 -0800 (PST)
    Return-Path: <>
    Received: from ([])
            by with ESMTP id 15si546116nzp.2006.;
            Thu, 30 Mar 2006 15:44:44 -0800 (PST)
    Received-SPF: neutral ( is neither permitted nor denied by best guess record for domain of
    Received: from (localhost.localdomain [])
          by (8.13.4/8.13.4) with ESMTP id k2UNihok002378
          for <>; Thu, 30 Mar 2006 15:44:43 -0800
    Received: (from apache@localhost)
          by (8.13.4/8.13.4/Submit) id k2UNihda002377;
          Thu, 30 Mar 2006 15:44:43 -0800
    Date: Thu, 30 Mar 2006 15:44:43 -0800
    Message-Id: <>
    Subject: lets test this out 2
    From: ''
    Reply-To: ''
    MIME-Version: 1.0
    Content-type: text/html; charset=iso-8859-1
    X-Mailer: PHP/5.0.4

    i don't want to get bulked any more
    LVL 2

    Assisted Solution

    this is an easy fix...
    you need to setup a reverse dns entry, contact the company that assigned you your ip addresses and have them set up[ a PTR entry, then your mails wont get dropped or bulked unless ppl report it as spam.
    LVL 1

    Author Comment

    I set up a PTR entry points to but I am still getting bulked

    do I need to set a a reverse zone in the named.conf on something like
    zone "" in {
        type master;
        file "reverse/";


    Expert Comment

    You need to get whoever provides you internet conectivity to add the entry for you.

            primary name server =
            responsible mail addr =

    They will need to add a PTR record in this zone file as :-

    89                     PTR

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    IT, Stop Being Called Into Every Meeting

    Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

    Suggested Solutions

    Title # Comments Views Activity
    Read only access to a user 5 83
    AWS Linux Root Drive 3 72
    VMWare Workstation 12.0 3 69
    Help needed with BIND9 DNS on Ubuntu. 22 43
    This is the error message I got (CODE) Error caused by incompatible libmp3lame 3.98-2 with ffmpeg I've googled this error message and found out sometimes it attaches this note "can be treated with downgrade libmp3lame to version 3.97 or 3.98" …
    Linux users are sometimes dumbfounded by the severe lack of documentation on a topic. Sometimes, the documentation is copious, but other times, you end up with some obscure "it varies depending on your distribution" over and over when searching for …
    Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
    Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:

    779 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    17 Experts available now in Live!

    Get 1:1 Help Now