500pts: Failed to update database "C:\INETPUB\..\APP_DATA\ASPNETDB.MDF" because the database is read-only.

Hi there,

I am getting a real problem with ASP.NET 2.0, all i am trying to do is run a recovert password (using the login controls) and i got the following error.

Does anybody know how to fix this? I have tried the SSEUTIL answer here and it didn't work. http://forums.asp.net/909168/ShowPost.aspx

I also ensured that Network Services user has READ/WRITE/EXECUTE premissions on the directory below and that each file isn't read only (properties on the file in win explorer) and also that it inherits ACL from the directory which it seems to do..

Bit of strange one this, it isn't created (and i am not using) a beta version of VS 2005 Pro... but a full retail version.

The PC is the local PC with IIS 5.1 and VS installed... it is the one i am using for developing.. I don't need to copy my files to the IIS directory below as that is where i have created it and open it in VS 2005 from there..

I did read that if you use IIS 5.1 then the user should be ASPNET ... but i don't seem to have that user but a Network Services user...

Any help or guidance would be really appreciated... i have come to a stop stage and can't get any further..

Thanks

ian

Server Error in '/igdotcom' Application.
Failed to update database "C:\INETPUB\WWWROOT\IGDOTCOM\APP_DATA\ASPNETDB.MDF" because the database is read-only.
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Data.SqlClient.SqlException: Failed to update database "C:\INETPUB\WWWROOT\IGDOTCOM\APP_DATA\ASPNETDB.MDF" because the database is read-only.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.


ianinspainAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ianinspainAuthor Commented:
thanks! I got it i think.... althought it wasn't sseutil that fixed it... it was the post that helped..

You see i never had aspnet user access to the folder of app_data.... and when i searched for it ... I couldn't find it as although my IIS is 5.1 and local - i am also connected to a domain and i was searching the domain users rather than LOCAL and it only showed me NETWORKSERVICES..

Thanks- assigning points
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
ASP.NET

From novice to tech pro — start learning today.