CPU Utilisation staying at 100%

I seem to have a problem with my CPU utilisation maxing out at 100% and staying there whenever anything that uses 3D graphics is open on my desktop.

System:
AMD Athlon 2400+ (Not overclocked)
1.25GB DDR 333 RAM (Not overclocked)
Windows XP Pro (SP1)
2 HDD (One is 80GB one is 200GB)
Sapphire Radeon 9950 256MB (Unlocked to a 9600 but not overclocked from there)
Belkin Wireless keyboard and mouse
One PCI card (Wireless Lan adaptor)

The problem's started occuring over the last week or so (I installed the new graphics card over a month ago). Whenever I open a game or application that uses graphics (examples include Homeworld 2, Empire at War, Football Manager (which is 2d graphics), or even ATITool (which just features a spinning cube) ) the CPU maxes out to 100% and I struggle to use the mouse or keyboard etc. Some of these games aren't that new and used to run just fine on my old Radeon 9200.

I've checked all the obvious things (spyware, viruses, rouge processes etc), I've dialled down the clock speed of the graphics card to below the manufacturers standards, and I've removed all grpahics card drivers and installed the latest catalyst drivers.

It's driving me crazy. Can anyone help?
cwoolhouseAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Chris BRetiredCommented:
So what does task manager sat is using the CPU. Open it first, then alt-tab during the game or whatever. In Processes, click the cpu tab twice to put the max user at the top.

Chris B
0
cwoolhouseAuthor Commented:
The task manager says that whicherver app I have opened is using the CPU. Just tried it now, Homeworld 2 is using 100% CPU, although it's just sat at the menu screen (i.e. it's not actually doing anything). Same if I open up ATITool and have the 3d view on, it uses 100% cpu.

It's clearly something to do with apps which use the graphics card, but I don't understand how adding a graphics card which is twice as powerful than the previous one can cause extra CPU utilisation. That and the fact that it only started happening a week or so ago.

It also happens within the game as well. i.e. The keyboard doesn't respond every time and the mouse is slow. This happened with Battlefront 2, Empire at War and Homeworld 2.

0
CallandorCommented:
Reinstall the video card driver, and make sure hardware acceleration is enabled.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

cwoolhouseAuthor Commented:
I've literally just removed every reference to ATI from the machine (and registry entries), resintalled the latest Catalyst drivers and checked that hardware acceleration is on full. No change.

Aaaargh.
0
Chris BRetiredCommented:
You have got tne .Net framework installed? Control Center requires this to function.

Chris B
0
cwoolhouseAuthor Commented:
Yep. .Net 1.1.
0
nobusCommented:
first i would check the video card : is the fan running normally, temp ok, power cable connected?
Then i would look at the cpu temperature, here  alist with the max temps :

www.heatsink-guide.com/maxtemp.shtml

if it is too high, it will downgrade the speed.
You can also test your video card by running dxdiag from the run box, select display, and 2D and 3D tests
0
cwoolhouseAuthor Commented:
Fixed it!!! Although the solution is very, very weird.

Checked the cpu temp in the BIOS, 48 degrees C. No problem there. Decided to give the heatsink and fan a vacuuming anyway. Did that, case back together, voila, problem solved!!

If anyone can explain that one I'll buy them a pint.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
CallandorCommented:
It would seem that your cpu was overheating and the temperature sensor was incorrectly reporting it.  When the cpu overheated, it slowed the cpu to a crawl as the thermal protection kicked in to save itself.  Once you cleaned the heatsink, it functioned as it should and no more thermal protection occurred.
0
cwoolhouseAuthor Commented:
I think I might just invest in a brand spanking new heatsink and fan just to make extra sure.

Thanks for everyone's help.
0
cwoolhouseAuthor Commented:
Yes please Callendor.
0
nobusCommented:
i thought i pointed him directly to the cpu temp and speed?
0
nobusCommented:
Holy smoke !
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Desktops

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.