?
Solved

squid error on port 8888

Posted on 2006-03-29
9
Medium Priority
?
445 Views
Last Modified: 2008-02-01
Hello all

we installed squid proxy and it's working fine but we have a problem when accessing a web page on port 8888 http://www.xyz.com:8888/

we get the following error on the client

While trying to retrieve the URL: http://www.xyz.com:8888/ 
The following error was encountered:
•      Connection Failed
The system returned:
    (13) Permission denied
The remote host or network may be down. Please try the request again.

Accessing directly the page is ok.
0
Comment
Question by:lemaitre75
7 Comments
 
LVL 43

Accepted Solution

by:
ravenpl earned 172 total points
ID: 16320126
Is Your squid run in transparent mode? The host may have redirected connections to 8888 back to local squid.
No, then edit squid.conf and add
acl Safe_ports port 8888
0
 
LVL 19

Expert Comment

by:Gabriel Orozco
ID: 16324970
or, enable NAT in your linux box.

then any connection to a non standard port (port 80) still will be able to succed but not monitored nor accelerated by squid.
0
 
LVL 5

Assisted Solution

by:ranadastidar
ranadastidar earned 164 total points
ID: 16334070
try to run squid on transparent mode, if u dont know how to setup that visit the follwing link


http://wrt-wiki.bsr-clan.de/index.php?title=Squid_Transparent_Proxy
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:lemaitre75
ID: 16337850
Hi all

i'm not using the server as a router and not doing NAT on it, i just want it to cache http pages.
0
 
LVL 19

Expert Comment

by:Gabriel Orozco
ID: 16338420
okay then

how do you configured your browser to use the proxy?
0
 
LVL 43

Expert Comment

by:ravenpl
ID: 16339970
> I'm not using the server as a router and not doing NAT on it, i just want it to cache http pages.
very well then. Have You reconfigured the squid (and reloaded) as I suggested?
0
 
LVL 3

Assisted Solution

by:kiitii
kiitii earned 164 total points
ID: 16361358
Assumption:-
You squid server is in the LAN.
There is a firewall/NAT to go to internet.

Did you enable the NAT for port 8888 to internet at the firewall level?
Did you block the port 8888 at the firewall level?
Mind tell us, which line (squid.conf) did you edit to startup the squid proxy?



0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
Are you ready to place your question in front of subject-matter experts for more timely responses? With the release of Priority Question, Premium Members, Team Accounts and Qualified Experts can now identify the emergent level of their issue, signal…
Suggested Courses

864 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question