Upgrade to Apache 2.2 from 2.0.54

Posted on 2006-03-29
Last Modified: 2013-12-15
I may be doing something obviously wrong here, so somebody please set me straight.  In my quest to make XML and XSLTs work together, I updated a few packages on my Fedora Core 4 Linux installation.  To make a long story short, I followed these instructions:  
Installed the following in this order:
- expat-2.0.0
- Sablot-1.0.2
- php-5.1.2

Now, when I restarted apache, I got this error:  
[root@TankJr ~]# service httpd start
Starting httpd: Syntax error on line 191 of /etc/httpd/conf/httpd.conf:
Cannot load /usr/lib/httpd/modules/ into server: /usr/lib/httpd/modules/ undefined symbol: _pcre_default_tables

When I comment out line 191, apache starts fine, but without PHP.  

So, I decided to install the latest version of Apache, thinking that this would pick up all my latest changes and make everything good again.  Well, obviously that didn't happen because I am here.  

I followed the instructions on the Apache site: and tried to restart and it would not pick up the latest version. Here is the status

[root@TankJr src]# /usr/sbin/apachectl start
httpd: Could not determine the server's fully qualified domain name, using for ServerName
[root@TankJr src]# httpd -v
Server version: Apache/2.0.54
Server built:   Jan 17 2006 06:36:00

Bottom line now is that I can run apache, but not the newer version that I just installed.  I'm probably approaching this with a "Windows Mentality", but I'm stuck here and need some help.  Can anyone please jump in and give me some pointers?  
Question by:gcmachel
    LVL 4

    Author Comment

    Update on this issue:  The PHP now works fine, but I still cannot start the Apache version 2.2, it defaults to my older instalation of Apache.  
    LVL 16

    Expert Comment


    Do the following:


    Once you have done that open your httpd.conf file and place the correct path to the file.
    LVL 4

    Author Comment

    Thanks for your response.  The PHP is OK now (per my previous post), but I still cannot get the Apache 2.2 to engage.  How do I get my system to see the Apache 2.2 that I installed?  That's the million dollar question at the moment.  
    LVL 4

    Accepted Solution

    If you followed the Apache instruction to install v2.2, then it got installed in the directory /usr/local/apache2. You'll need to edit the conf file under /usr/local/apache2/conf, and start apache using /usr/local/apache2/bin/apachectl start.

    I suggest to stop using "service httpd" since it will start your old Apache. After Apache 2.2 is working fine, you should remove older version to make sure that nothing conflict using "rpm -e httpd".
    LVL 4

    Author Comment

    Thank you, that gets me on the right track here!  I tried just what you said and it works!  :)  

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Threat Intelligence Starter Resources

    Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

    Suggested Solutions

    Title # Comments Views Activity
    Openwrt vnstat 9 74
    copying mp4 filename to title 4 56
    busybox bash/ash - bash -x | grep 19 62
    Webserver access problem 5 44
    If you have a server on collocation with the super-fast CPU, that doesn't mean that you get it running at full power. Here is a preamble. When doing inventory of Linux servers, that I'm administering, I've found that some of them are running on l…
    Setting up Secure Ubuntu server on VMware 1.      Insert the Ubuntu Server distribution CD or attach the ISO of the CD which is in the “Datastore”. Note that it is important to install the x64 edition on servers, not the X86 editions. 2.      Power on th…
    Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
    Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:

    759 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    11 Experts available now in Live!

    Get 1:1 Help Now