Send Mail 8.12.11-4.24

Posted on 2006-03-29
Last Modified: 2013-11-13
Hi Experts,

After Installing Send mail 8.12.11-4.24 on a RH9 server for security reason I am non able to send mail from my computer using my Server SMTP, and some forms like formmail.cgi do not send mail any longer, even though they apperantly work
it used to work perfectly before

what should I check?

Question by:rcinformatica
    LVL 4

    Expert Comment

    If you've upgraded I would check the following:

    The configuration for Sendmail is set as before, or set as necessary for your server. Configuration files may have been refreshed to default upon upgrade.

    Also, were you using an earlier version of Sendmail previously or a different Mail Transfer Agent entirely? (i.e. Postfix).

    What do you mean by 'for security reasons' you are unable to send now? Perhaps you should check your IPTables configuration or any newly installed firewall management software, i.e. Bastille.

    It might just be something as simple as Sendmail needing to be reconfigured again with basic details such as hostname and other such things.

    Author Comment


    thanks for the answer, according to a security whole has been found and we needed to uograde sendmail.

    I went to to download the latest rpm and installed. The problem that comes up is with SMTP authentication.

    I cannot send any mail from my local computer using my SMTP server it keeps asking for password and some programs like formmail do not send mail any longer
    LVL 4

    Expert Comment

    It sounds like SMTP-AUTH is installed / active, whereas i'm assuming it wasn't before. SMTP on its own doesn't have any authentication like POP does. This is where SMTP-AUTH comes in, it allows you to authenticate SMTP access as you would with POP.

    So to get rid of this password request for SMTP, I would imagine you would have to remove the SMTP-AUTH add-on. This may be possible within

    Chances are the RPM was built with SMTP-AUTH included; So you could also try a different RPM.

    Author Comment


    the problem is that i NEED TO ENABLE SMTP-AUTH but only to authenticated users otherwise anybody could send mail from my server
    LVL 2

    Accepted Solution

    I could be bursting into an open door, have you checked your access file?
    In /etc/mail/ there is a file called access, that if you wish to allow mail from the computer, you need to add the lines
    localhost RELAY
    localhost.localdomain RELAY RELAY.

    It should work fine with any of those lines, but I was told it best to include them all. After that write:
    cd /etc/mail
    /etc/init.d/sendmail restart

    If thats the problem, then what we did here should solve it.
    Have a nice day

    Featured Post

    What Should I Do With This Threat Intelligence?

    Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

    Join & Write a Comment

    One of the major drawbacks of deploying applications by GPO is the complete lack of any centralized reporting. After a normal deployment, there are two ways to find out if it was successful – by looking in the event log, and by looking in the log of…
    Installations often have prerequisites, such as “Microsoft .Net framework is required for this product”. The usual implementation in MSI installations is system search for a particular registry setting representing the required prerequisite, followe…
    Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
    Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.

    733 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    17 Experts available now in Live!

    Get 1:1 Help Now