Wireless ActiveSync

I am running an SBS2003 server which automatically sets up SSL (with own certificate) and FBA. OWA and OMA work fine from my PPC 2003. I can also sync with Exchange Mailbox from the desktop using AS 4.1. However, when I try to sync wirelessly, it connects, looks for changes but then errors with an HTTP_403 error "Your account does not have permission to sync with your current settings...". I have double checked my logon/password. Any help much appreciated.

Thanks.
octopusdataAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

SembeeCommented:
Ditch the self generated certificate to start with. It will make deployment a nightmare. Get a purchased certificate and if required install the root certificate on the clients.

Within Exchange 2003 ESM, is every setting enabled on the properties of Global Settings, Mobile Services?
Are you on Exchange 2003 SP2? If not, then you should as there are changes to the way that the mobile devices are handled.

Simon.
octopusdataAuthor Commented:
Many thanks for your comments.

I'll look into the certificates but there are only 3 of us so deployment isn't really and issue. I didn't think it was certificates as OWA and OMA work fine with our current certificate and I even tried disabling certificate checking (disablecertchk.exe) on the PPC, but that didn't mke any difference.

Isn't an HTTP_403 error more to do with permissions within IIS?

Thanks,
Haris
SembeeCommented:
http_403 is forbidden. However there can be loads of causes for this.
One that I have seen recently is where the certificate settings have been set wrongly. The two that immediately spring to mind is where the system has been set to use client certificates instead of a server certificate, and where the /exchange virtual directory has been set to REQUIRE an SSL connection. You have to remove that setting.

Simon.
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

octopusdataAuthor Commented:
Thanks once again Simon,

I have disabled certificate checking on my PPC but still get the HTTP_403 error. When I enable certificate checking, I get a different error messsage so I still don't think it's a cert issue. The /exchange virtual directory does not require an SSL connection, niether does the Microsoft-Server-ActiveSync virtual server. Could it be IP address related as all but server and localhost are denied on Microsoft-Server-ActiveSync virtual server?

Haris
SembeeCommented:
Why have you put restrictions on the Microsoft-Server-ActiveSync virtual directory?
That isn't standard. Remove them, set it back to "Granted Access"

Simon.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
octopusdataAuthor Commented:
I didn't - this is the standard restriction with SBS2003. I have set it to "Granted Access" and it now works fine.

Thanks,
Haris
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.