Cannot get Cisco 2621 router working.

Just trying to get a basic config going on a 2621 router. Having some trouble. See my show run below. Any ideas?

Provider issued ip's.

WAN:x.x.170.52/24

Default Gateway:x.x.170.1

LAN:x.x.64.160/28
 
I have a PC directly connected to the router and I can ping interface 0/1 and 0/0. I cannot ping anything past that.
 
From the router I can ping interface 0/0, 0/1, default gateway and beyond. I can also ping the connected computer.

See show run listed below.
 
Computer ip: x.x.64.162
mask: 255.255.255.240
gw: x.x.64.161

---

s.gw.t#show run
Building configuration...

Current configuration : 771 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname s.gw.t
!
logging rate-limit console 10 except errors
enable secret 5 $1$gdkl$x2ap6Xuyur8tdT5jBmr.p1
enable password s
!
ip subnet-zero
!
!
no ip finger
!
!
!
!
interface FastEthernet0/0
 ip address x.x.170.52 255.255.255.0
 speed auto
 full-duplex
!
interface FastEthernet0/1
 ip address x.x.64.161 255.255.255.240
 no ip mroute-cache
 speed auto
 full-duplex
!
ip classless
ip route 0.0.0.0 0.0.0.0 x.x.170.1
no ip http server
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password s
 login    
!
end
funkyjoe1Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Another-DanCommented:
Hi

Is your provider providing you a WAN connection via ethernet? if so, what are the dialer-lists for?, also can you ping the gateway address from the router?
0
funkyjoe1Author Commented:
Yes. The WAN connection is via ethernet. I can ping the gateway of x.x.170.1 from the router. The dilaer-lists were in the config already. I didn't add that.
0
GRDTCommented:
Are the IP addresses on you Ethernet Interfaces Public or Private Addresses?

You could try entering a routing protocol on the router

conf t
router rip
network x.x.170.52
network x.x.64.161

otherwise, if the addresses are private, you will need to set up NAT on the router.
0
Powerful Yet Easy-to-Use Network Monitoring

Identify excessive bandwidth utilization or unexpected application traffic with SolarWinds Bandwidth Analyzer Pack.

GRDTCommented:
I should have said on FE0/1, your LAN
0
funkyjoe1Author Commented:
They are public addresses.

I tried what you suggested and I don't think it worked. See below. I also removed the dialer-list.

sterling.gw.twtc#config t
Enter configuration commands, one per line.  End with CNTL/Z.
(config)#router rip
(config-rout)#network x.x.170.52
(config-rout)#network x.x.64.161
(config-rout)#^Z

resulting show run:

s.gw.t#show run
Building configuration...

Current configuration : 802 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname s.gw.t
!
logging rate-limit console 10 except errors
enable secret 5 $1$gdkl$x2ap6Xuyur8tdT5jBmr.p1
enable password s
!
ip subnet-zero
!
!
no ip finger
!
!
!
!
interface FastEthernet0/0
 ip address x.x.170.52 255.255.255.0
 speed auto
 full-duplex
!
interface FastEthernet0/1
 ip address x.x.64.161 255.255.255.240
 no ip mroute-cache
 speed auto
 full-duplex
!
router rip
 network x.0.0.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 x.x.170.1
no ip http server
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password s
 login
!
end
0
Another-DanCommented:
Hi can you ensure ip routing is running with:

sh protocols

then ensure that the /28 is routed through the outside interface correctly but tracerouting the inside int ip from a remote location, you may have to 'call a friend' to do this
0
funkyjoe1Author Commented:
Dan,

I don't know what "sh protocols" is. Can you elaborate?

I know that I cannot trace to the inside interface. Now I'm confused. When I trace to the outisde interface it succeeds. When I trace to the inside interface it ends up on the sbcglobal network which I know I am not. Does this mean my inside is a private scheme and I need to NAT?
0
GRDTCommented:
on the Router

type
Show Protocols
Show ip interface brief
show ip route

Enter each of these commands and report the results please.
0
funkyjoe1Author Commented:
Here you go. Thanks.

s.gw.t#show protocols
Global values:
  Internet Protocol routing is enabled
FastEthernet0/0 is up, line protocol is up
  Internet address is x.x.170.52/24
FastEthernet0/1 is up, line protocol is up
  Internet address is x.x.64.161/28


s.gw.t#show ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            x.x.170.52   YES NVRAM  up                    up      
FastEthernet0/1            x.x.64.161   YES NVRAM  up                    up      


s.gw.t#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is x.x.170.1 to network 0.0.0.0

     x.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       x.x.64.160/28 is directly connected, FastEthernet0/1
C       x.x.170.0/24 is directly connected, FastEthernet0/0
S*   0.0.0.0/0 [1/0] via x.x.170.1

0
GRDTCommented:
That looks fine to me, can you check with your ISP to make sure they have your Public IP addresses on your LAN enabled?

If they do have a route in their next hop router advertising these routes, then you will not be able to do anything from the LAN side without NAT set up.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
GRDTCommented:
Also, try and have someone do a tracert from another network to your LAN interface, if these are public addresses and the routes are set up correctly from the ISP, the last address they will hit should be your WAN side IP address on your router.
0
funkyjoe1Author Commented:
I'm still waiting to hear back from my ISP regarding a static route.

I can do a trace from another network to the WAN side of my router.
0
funkyjoe1Author Commented:
After lots of phone calls to my ISP an engineer fixed me up. I never got the details of what exactly was wrong, but whatever he did fixed it. My router config was good. Thanks!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.