Can't get ActiveSync and Rights Management Server to work on same SBS 2003 SP1 server

I had RMS up and running and "working", but I can't seem to get it to live harmoniously with ActiveSync.  FYI, I've never touched RMS before, so I'm a total noob here...and not really strong w/ IIS either.

My setup is SBS 2003 SP1 behind a hardware firewall.  I am running Exchange, SharePoint, and RMS on this server (will break them out later as money permits and size of our organization requires.)  At this time, I'm also testing WM5 devices w/ ActiveSync.  I had them working until I installed RMS which broke ActiveSync.  The fix is to make the following change in the IIS Metabase:
LM\W3SVC\1\ROOT\NTAuthenticationProviders  change from "NTLM" to "Negotiate,NTLM"

However, this fix seems to break RMS.  After the change I receive the following error opening an RMS protected document:
"A problem occurred trying to contact the restricted permission service."

On a possibly related note, RMS is not acting as I would expect it to.  When protecting or opening a document, it always prompts to "Select Service" and the options being a .NET Passport account or a Windows Account.  I expected it to automatically use the current logged in user's AD credentials.

Thanks for any help.
GeckotekAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
There are a couple of registry entries that need to be added on an SBS for RMS to work.  Please see this post about that.  Also note the reference to the RMS newsgroup as a good source of assistance for RMS:
http://msmvps.com/blogs/bradley/archive/2004/01/19/1896.aspx

Jeff
TechSoEasy
0
GeckotekAuthor Commented:
Thanks, I've run across this post.  This appears to address PCs from outside the network, not the issue I've asked about here since my PCs are on the domain and connected to the network (sorry if that wasn't clear).
0
GeckotekAuthor Commented:
Solved it on my own.
Solution was to change "Negotiate,NTLM" to "NTLM,Negotiate"
0
VenabiliCommented:
Changed recommendation: PAQ and points refunded
Thanks for sharing :)
0
GranModCommented:
PAQed with points refunded (500)

GranMod
Community Support Moderator
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Fonts Typography

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.