• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1022
  • Last Modified:

Startup hangs recurrently on msmouse.vxd

Emachines C733combi - a hand-me-down that I'm trying to get working.

Did clean install of Windows 98. Fine.
Install an Ethernet card (Realtek RTL8139). Fine. The computer connects to others in the network, and to the Internet.
Install IE6 SP1. Fine.

The problem: after further steps in setting it up, the computer starts always to stall during Normal startup of Windows. (The Windows 98 screen freezes, and nothing happens. I have to unplug the computer in order to turn it off and try to restart it). On doing step-by-step startup, the stall is always after msmouse.vxd. It stalls whether I say yes or no to loading msmouse.vxd.

It starts fine in safe mode.

What triggers this problem has been different on three different attempts to start again from a clean install. (Each time I've run fdisk and format c: again, to ensure a completely clean beginning).
First time: it started stalling after I ran Windows Update.
Second time: it started stalling after I tinkered with the network settings (and the problem remained after I restored the old network settings).
Third time: it started stalling after I installed anti-virus software (Grisoft). I had not touched the network settings or attempted Windows Update.

Every time System File Checker says that setupx.dll is corrupted. But when I reinstall setupx.dll, and System File Checker says the system is fine, the problem remains unchanged.

I've tried:
1. Reinstalling Windows 98 from CD (without deleting the old installation) in case some Windows files have been corrupted. No effect.
2. Deleting the Enum entry from the registry (an idea from http://www.geeknewz.com/board/lofiversion/index.php/tt21.html). No effect.
3. Removing the network card from the system. No effect.
4. Removing the PS/2 mouse from the system and replacing it with a serial mouse.
5. Checking everything in the System Information utility of Windows 98. It says everything is fine.
6. The successive steps recommended at http://support.microsoft.com/kb/188867/en-us. If that's right, it's a Protected-Mode Driver problem rather than a Startup Folder problem.
7. Looking at the bootlog.txt file. It does not mention msmouse.vxd - or the other vxd files loaded before it - but terminates as follows:
Init = Installable Drivers
InitDone = Installable Drivers
Init = TSRQuery
InitDone = TSRQuery
[0013F71B] Starting Unknown (HTREE\RESERVED\0)
[0013F71B] Started Unknown (HTREE\RESERVED\0)
[0013F71C] Enumerating Unknown (HTREE\RESERVED\0)

I have tried to investigate IRQ clashes, but since I can't get the computer to start in Normal mode, I can get information only from the BIOS, which assigns only two IRQs, IRQ 4 for serial port and IRQ 7 for parallel port.

I haven't tried disabling all devices, then enabling them all one by one, as recommended at http://support.microsoft.com/kb/188867/en-us, because that would take more time than is worth spending on an old machine and doesn't seem likely to resolve the problem.

I haven't tried flashing the BIOS, as a friend suggested to me, because (a) the BIOS looks fine; (b) I can't find a flash BIOS to download on the Web.

It's an old machine, and I don't have all the time in the world... so I'm looking for some quick fix that I've overlooked, not a recommendation to take the machine apart, research every component on the Web, replace each component one by one etc.

Any suggestions?

Thanks.
0
martinworkerslibertyorg
Asked:
martinworkerslibertyorg
  • 10
  • 5
  • 3
  • +2
1 Solution
 
JonveeCommented:
Surely it's not this straightforward .. perhaps worth reading though:
"Corrupted Setupx.dll After Installing Windows 98 Second Edition":
http://support.microsoft.com/?id=231793
0
 
martinworkerslibertyorgAuthor Commented:
Don't think so. As mentioned above, I have reinstalled setupx.dll, and System File Checker now says it's fine - but the problem remains just the same.
0
 
blue_zeeCommented:

Try renaming CONFIG.SYS and AUTOEXEC.BAT to CONFIG.OLd and AUTOEXEC.OLD.

You can do that in Safe Mode.

Restart in Normal Mode.

Zee
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
nobusCommented:
>>   I have to unplug the computer in order to turn it off   << if you hold the power button for 5 sec; it will turn off
BTW did you try another mouse?
what you can try also is this : download a copy of knoppix, burn it to cd, and boot from it. if you have no problems, you are sure the hard is ok, and the problems come from soft. if not, vice versa
0
 
BillDLCommented:
Try booting to a Win98 boot floppy with CD-Rom support, and extracting the file VMOUSE.VXD to the folder C:\Windows\System\VMM32 (substitute the X:\ with the drive letter of your CD-Rom, bearing in mind that it is pushed one letter higher because of the temporary RamDrive created by a Win98 boot floppy):

EXTRACT  /A   X:\win98\BASE4.CAB   vmouse.vxd   /L c:\windows\system\vmm32

The file VMM32.VXD is a monolithic file created during the Windows installation and packed with other VXD drivers dependent on the hardware configuration at that time.  Subsequent installations that need to update files in this VXD file drop the new vxd files into the VMM32 folder before rebooting.  This adds, refreshes, or updates the contents of vmm32.vxd.

vmouse.vxd (used as one of the PS/2 mouse drivers) should have been packed into vmm32.vxd during original installation, but there may be some glitch with the setup process from CD whereby a corrupt or damaged version ends up in there each time.

No Win98 boot floppy?
Run this download on a functional PC and a blank floppy in the drive to create an exact copy of a Win98se boot floppy:
http://www.mbhs.edu/~jaosborn/boot98se.exe
0
 
BillDLCommented:
I should have made it clear that I AM talking about Vmouse.vxd above and NOT MSmouse.vxd which should be in the C:\Windows\System folder.  It's just a hunch.
0
 
martinworkerslibertyorgAuthor Commented:
Thanks for all the suggestions.

1. Renaming autoexec.bat and config.sys - no effect. (I'd already tried bypassing them on startup).

2. Yes, holding the power button for 5 seconds does work to turn the machine off.

3. Re-extracting vmouse.vxd: no effect.

4. Haven't tried using knoppix. Explain more? The machine and its networking have worked fine, no problems, each of the 3 times I've done a clean reinstall of Windows 98, until I try to add some additional thing (Windows Update, anti-virus...). If it works in knoppix, how can that tell me more than the fact it works in Windows 98... up to the point when I start adding the bits and pieces needed for everyday use?
0
 
martinworkerslibertyorgAuthor Commented:
Oh, and 5. yes, I have tried a different mouse. I tried removing the PS/2 mouse from the system and using a serial mouse instead. (See above). No effect.
0
 
nobusCommented:
read my post : it will tell you if it is hardware or not.
0
 
martinworkerslibertyorgAuthor Commented:
What I mean is, if I can draw the conclusion that the machine working in knoppix tells me that the problem is software, then why couldn't I already draw the same conclusion from it working in Windows 98 before I add whatever it may that will trigger the problem (Windows Update, anti-virus software)? It looks to me as if the problem must be some sort of interaction between software and hardware, rather than some bit of hardware that wouldn't work with any software, or some bit of software that wouldn't work with any hardware...
0
 
martinworkerslibertyorgAuthor Commented:
But I'll get a copy of knoppix on CD (don't have access to a machine with CD-burning software until this evening, but will do it then) and see - unless someone can come up with a better idea before then.
0
 
JonveeCommented:
May save you a few minutes. Knoppix information:
http://www.knoppix.org/
0
 
JonveeCommented:
Select "Info",  then select "This page in English".
0
 
nobusCommented:
well, i will try to answer your questions.
First i do agree with the most of what you are saying in your post Date: 03/30/2006 02:03AM PST
But , after you install some other software, you get problems.
Right now you have no clue as to what is causing it (me included).
If you run a different OS like knoppix, AND since you are booted then from a cd, the software environment and drivers are totally different.
To me, it looks like you may have a "tiny" hardware problem, that only gets adressed after doing different things.
And this could be located in the mouse controller (on-board) or around it.
Maybe i did not express myself as clearly as i should, but if you want to get something clarified, please ask
0
 
martinworkerslibertyorgAuthor Commented:
OK, right. I'll try knoppix. As I wrote above, won't be until tomorrow because I don't have access to CD-burning software until this evening.
0
 
martinworkerslibertyorgAuthor Commented:
But any other suggestions? Suppose the machine works in knoppix (as I expect it will), then what do I do?
0
 
nobusCommented:
Then you "only" have to concentrate on software problems, and are sure no hardware problem is involved (1/2 of the trouble eliminated)
0
 
martinworkerslibertyorgAuthor Commented:
Well, the machine *doesn't* work in knoppix, and I guess that gives us more information. Now I need someone who knows something about knoppix to interpret for me.

I've tried booting the machine in knoppix four times.

Twice it hung on "loading ieee 1394" (which is odd, because the machine has no Firewire ports).

Twice it got past that, and then said:

Segmentation fault [repeatedly, but a different number of times on each occasion]
Read-only CD successfully merged with read-write/ramdisk
/linuxrc: cannot create /var/run/utmp: directory nonexistent
Kernel panic - not syncing. VFS: Unable to mount root fs on unknown block(1,3)

On each occasion there was also a message, right at the start of knoppix loading:

You passed an undefined mode number.

What does all that tell us?
0
 
martinworkerslibertyorgAuthor Commented:
Won't be back at the machine in question now until Monday morning, but will be very grateful to anyone who can interpret the messages from knoppix.
0
 
nobusCommented:
well, you have definitely hardware problems. now you can :
-test devices on another system, like disk, cd, ram and even cpu, add-on boards.
-test this system : download the ultimate boot cd, it contains a lot of tests. (ram, disk etc)
you can also do a disk scan for errors on the drive in windows.
After running ram and disk tests, i would boot this system with the minimum attached : mobo + cpu + 1 ram stick, video card, keyboard and mouse. disconnect all other devices, or disable them in the bios. then run the setup again.
0
 
martinworkerslibertyorgAuthor Commented:
Thanks. All that is more than I'm competent to do, so I'm going to pass this machine on to a friend of mine with a lot more technical knowledge and experience. Maybe he'll be back here with some results and some more questions.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 10
  • 5
  • 3
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now