We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you a podcast all about Citrix Workspace, moving to the cloud, and analytics & intelligence. Episode 2 coming soon!Listen Now

x

Linksys Wireless G USB Network Adaptor uninstallation error.  ctor.dll file

eshapley
eshapley asked
on
Medium Priority
1,084 Views
Last Modified: 2008-01-09
I am trying to fix a PC issue on a desktop which is not mine.  The user installed a Linksys Wireless G USB Network adaptor and it failed to work correctly.  When I try to uninstall the program I get a windows error:

"An installation support file c:\program files\common files\install shield\engine\6\intel32\ctor.dll could not be installed access is denied."

Any suggestions for uninstalling this network adaptor software so that I can re-install it?
Comment
Watch Question

Did u remove the usb adaptor before uninstalling the software??...

try uninstalling by going in to safe mode( restart ,press f8 while booting and go to safe mode )

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Author

Commented:
I did not remove the usb adaptor.  I will give that a try.

I did try uninstalling earlier in safe mode but that did not work.  Maybe the usb adaptor is the major barrier though?  I'll let you know tomorrow if it works.

Thanks for the suggestion.
ALthough this doesnt exactly match your problem the section on how to remove drivers from your machine will be helpful. I had a similar problem and this was my fix.

http://support.microsoft.com/Default.aspx?kbid=823771

Best of Luck ( may be off line for a few days- so may not be able to follow up)
Surly1966

Author

Commented:
I tried without USB wireless adaptor plugged in, and no good.

I also tried the instructions in the link which Surly1966 provided.  The steps were good until it came time to dig down deeper into the registry.  There were no Linksys driver files in the registry except at the software level.  I removed those drivers, and rebooted.  Now the USB adaptor is working.

The issue with the USB adaptor is that when I open the window to tell me what wireless routers are available, none show up.  How could that be if I am in fact connected to the Linksys router in the area.  Shouldn't that show up as the one I am connected to?  I suspect that this software is still not installed all the way correctly.

I tried installing a new Linksys USB wireless adaptor, but the software won't allow me to install without the old software being uninstalled first.

However...
I still cannot un-install the adaptor software from what appears to have been a bad install performed by the user.  That was in fact my earlier quest, and could be what haunts this whole USP wireless adaptor issue.
Its better to go in to safe mode and use system restore to go back to the date when it was working fine. It is totally safe and no data will be lost. ..I think the file got corrupted while installing. Go to start -> all programs ->accessories->system tools-> system restore ...Did u see the log files to check xactly wat the error is ??
(control panels -> administrative tools->event viewer and see the problem .(you can also find the help links from microsoft  once you double click the error message)
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.