We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you a podcast all about Citrix Workspace, moving to the cloud, and analytics & intelligence. Episode 2 coming soon!Listen Now

x

Corrupted or missing HAL.dll after restoring a disk image.

BruceWDenen
BruceWDenen asked
on
Medium Priority
551 Views
Last Modified: 2008-01-09
I created a disk image for cloning purposes and when I tried to restore it to another Computer, I received the message stating that the HAL.dll was missing or corupted and to copy another to Windows\system32.  I have re-done the image, tried extracting the HAL.dll from my windows disk and everything else I could think of, but to not avail.  My question is this, what causes this message after restoring an image?  My first thought is that the hardware abstaction layer is just different enough between the machines to cause the problem.  However, I've tried two different versions of the image on 4 different machines, all Dell Optiplex 270's that are identical, (they are from the same order with consecutive serial numbers and I imaged them a while back, so I'm pretty confident they are identical.)

Could it be a problem with the image?  I've done this a few hundred times, and have received this message maybe six times in the past.  But the problem is generally fixed with a new image.  Not this time.  I'm at a loss and any help wold be appreciated.

Thanks.

Bruce
Comment
Watch Question

Commented:
Well before I begin to speculate, what program are you using to create the images?
Irwin SantosComputer Integration Specialist

Commented:
yeah

Commented:
What version of Windows are you running?
Is there some kind of dual boot on the image?
The boot.ini file may be corrupted, which could of course mean more files are corrupted.  There is a solution for this but if more files are corrupted in won't help very much... check out : http://support.microsoft.com/support/kb/articles/Q289/0/22.asp
CERTIFIED EXPERT
Distinguished Expert 2019
Commented:
if you put the image on another type of hardware, it will not work like this.   Look here :

http://65.24.134.81/KipSolutions/MovingXPNewMotherboard/MovingXP.htm      move XP to other mobo
http://support.microsoft.com/?scid=kb;nl;314070                       "     "     "    "      "   

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Author

Commented:
I am using Drive Image 2002, and the OS on the base machine is Win XP SP2.  No dual boot, nothing fancy.  I build the base machine straight up the same way I always do it and imaged it.  Then I tried to restore the image to other "identical" machines.  Funny thing happened last night though,  I tried to restore one of the images,(I've made 3 at this point) on a 5th Optiplex 270 (identical to the others, from the same order and all that) and it worked perfectly.  So my guess it has to be something with the PC that the image is being restored to.(?)

I checked the boot.ini on the base machine and it was fine.  No way to check it on the target because it won't boot up far enough to do check it.

nobus,  I thought of that because there had been a MB exchange on a couple of these PC's, but when Dell sent the new MBs I assumed they would send the same hardware!!(?) and there were no problems when the new board went in.  But after reading the article I'm going to give that a try and see if that works.  I'll let you know.
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
i thought  you implied the hardware was different in your post. That would account for your error and problems.

Commented:
The HAL is NOT IDENTICAL! A HAL is very specific to the system for which it is DYNAMICALLY created for! It may be possible to use a HAL on a system which may have a very similar setup, but it genearlly will fail! As you move on working with the system, after a while you will begin to get hardware failures, blue screens, and dll coruptions.

Unless you are tring to create backup copies, you need to come up with another way for creating software replicas on systems.

I recommend, if this is what you are trying to do, you create answer files for each computer, and then roll out multiple copies of the operating system.

Good Luck.
James
www.Elletech.com

Author

Commented:
Nobus,  I tried what the article suggested about setting the IDE controller drivers to standard and so foar so good.  I had to re-install the chipset drivers.  I'll let you know if anything else shows up as a problem.  Thanks.
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.