• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 685
  • Last Modified:

MSDE SA Password doesn't work

I've installed MSDE to a pc connected to a new Canon ImageRunner multi-function device.  The manual has instructions on how to install MSDE so that you can create an address book which users can pull email addresses from when they use the machine to email.

When installing MSDE, I used the syntax:
 
  setup SAPWD=<password>

After successful installation and rebooting, the MSDE icon appears in the system tray with a green arrow signifying that it is running correctly.

Then I went into the configuration program to create a new address book.  When I click the create button, I am prompted for:

   an SQL server, to which I chose "local"
   a User ID, to which it defaulted to "SA"
   a password, to which I entered the password I set during the install
   a name for the address book I am creating, to which I entered "ShareScan"

But when I click OK, it says "Invalid Username or Password."  I was 99.99% sure I knew what I set the SA password to during install, but to make sure, I uninstalled MSDE, then reinstalled it and took a screen shot of the command line with the SAPWD= switch for reference.  Armed with a screen shot, I'm 100% sure what I set the SA password to!  Yet, I STILL get the invalid username or password message when I try to create the address book.

What would I be doing wrong?

Phil

0
witzph1
Asked:
witzph1
  • 6
  • 5
  • 2
1 Solution
 
fefo_33065Commented:
1-Double-click on the MSDE icon to make sure you have the correct server name
2-Try a blank password
0
 
MikeWalshCommented:
Connect to the MSDE server in Enterprise manager with your Windows authentication. Assuming you are in a group that has rights mapped to local admin.. Look at your security mode, make sure you are in fact truly in mixed mode authentication and not Windows only. If you are in Windows only the SA username and password would not work..

You can see this by right clicking on the server within enterprise manager, go to properties then security tab.
0
 
witzph1Author Commented:
fefo:  The name of the server I installed is ECOPY1.  With this install, I now have 3 servers running on the network, one called "ECOPY", one called "KDC1" and one called "UNIT390."  

But when I go into the Canon configuration utility to create an address book, the servers it lists are "local", "KDC1", and "UNIT390".  It doesn't explicitly list "ECOPY1", but ECOPY1 would be "local" so that's what I am choosing.

Also, I tried a blank password and it doesn't work.

Phil
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
witzph1Author Commented:
Mike:  I'm pretty new to SQL and MSDE.  When you say open the server in Enterprise Manager, where would I find that program?  Do I have to download it?

Phil
0
 
MikeWalshCommented:
You would have to download and install the SQL Server Client Tools. Enterprise Manager is one of those client tools.
0
 
witzph1Author Commented:
OK.  I was hoping not to have to get that complicated.  I don't want to kill a flea with a sledge hammer, but maybe I will have to.  

I just can't understand why if I know what I set the SA password to, why it won't take it.  If you say that maybe it's in "Windows Only" mode, such that it won't accept the SA username and password, what Windows username and password is it looking for?  
0
 
fefo_33065Commented:
Did you try NO entering a password when you go to create an address book?


Remember that the first time you log in to an instance of SQL Server, use sa as your login identification and no password.

So,
if you have the SQS server Client Tools installed (as suggested by Mike) then

Go to START > All Programs > Microsoft SQL Server and look for Query Analyzer

Try connecting to your server from there (do not use a password for the SA if this is the first time)
That way you know for sure that you have access to SQL server for real...


0
 
witzph1Author Commented:
fefo:

As I mentioned in my last posting to you, yes, I have tried NOT entering a password when I created the address book.

I will have to download the SQS Server Client Tools I guess as you and Mike have suggested.  I've never really worked with SQL server or server tools before.  I'm not really even sure where to download the client tools.  I guess Microsoft?
0
 
witzph1Author Commented:
Can either of you give me a link to download this SQL server client tools?  I can't find it on Microsoft.
0
 
MikeWalshCommented:
Fefo's advice is not correct. If you set a password this will not work. In SQL 2000 you are prompted for an SA password at install I believe. This does not tell you anything about whether or not you can connect.

Go to www.microsoft.com/sql and from there you should be able to get them. I imagine you might have Windows only authentication right now and will need to log on to the box as the admin and register your server in Enterprise manager that way, then change your authentication as I discussed. Also along with the client tools comes Books Online, this is a great help program for this situation it will walk you through it.
0
 
witzph1Author Commented:
Mike:  

I feel really stupid, but I went to the link you provided then branched to the SQL Server 2000 Downloads page at http://www.microsoft.com/sql/downloads/2000/default.mspx.  But I'm looking for a download similar to what you described as SQL Server Client Tools and don't see anything like that.  The closest I find is something called SQL Server Management Studio Express, but that's for 2005, not 2000.  I feel like a real pest, but could you help me find the right download?  
0
 
MikeWalshCommented:
Not stupid, I couldn't find it easily either.. The best bet is going to be for now to just download the SQL Server 2000 evaluation edition. Don't install the server. From the install choose client tools only:

http://www.microsoft.com/downloads/details.aspx?familyid=d20ba6e1-f44c-4781-a6bb-f60e02dc1335&displaylang=en
0
 
MikeWalshCommented:
This will install (among other things) Query Analyzer and Enterprise Manager. From there you can configure security.


But before you even try that. Try logging in again. Check the obvious stuff like your caps lock, and double check to make sure the service is running. This time instead of typing in local just type in a period. For the servername.

So connect to: .
0

Featured Post

Restore individual SQL databases with ease

Veeam Explorer for Microsoft SQL Server delivers an easy-to-use, wizard-driven interface for restoring your databases from a backup. No expert SQL background required. Web interface provides a complete view of all available SQL databases to simplify the recovery of lost database

  • 6
  • 5
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now