Outlook 2003: security settings prevent running ActiveX

I have a client with this issue.  When he sends me a message that has a graphic signature the first message he sends me works fine.  I see the signature and the pictures in it.  If I reply to him, he gets this error when he opens the e-mail "Your current security settings prohibit running ActiveX controls on this page.  As a result, the page may not display correctly.", and when he replies to that message I then get the error message.  In that message I can see his first e-mail with the signature displayed correctly, but the latest signature just shows x's where the pictures are.  And also in the reply the pictures are attached to the e-mail, but they are not attached in the first e-mail.  Hope this makes some sense, any suggestions to get rid of the error?
LVL 7
lukecaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

war1Commented:
Greetings, lukeca !

http://support.microsoft.com/?scid=kb;en-us;816948&spid=2488&sid=776

CAUSE
This problem may occur if any of the following conditions are true:
•    You have set your Web browser so that it does not allow cookies.
•    You have not visited a home page Web site that downloads a cookie to authorize specific permissions on the Web site.
•    You have set your Web browser so that it does not allow scripting to run.
•    You have set your Web browser so that it does not allow ActiveX Controls to run.
RESOLUTION
To resolve this problem, do one or more of the following:
•    Configure your Web browser so that it accepts cookies. For more information about how to do so, see your Web browser's Help file.

-or-
•    Use your Web browser to visit the home page of the Web site. If you are prompted to accept the cookie, click Allow Cookie.

-or-
•    Configure your Web browser to allow the actions of scripts on the Web site. For more information about how to do so, see the security features that are described in your Web browser's Help file.

-or-
•    Configure your Web browser so that it permits ActiveX Controls to run. For more information about how to do so, see the security features that are described in your Web browser's Help file.

Go to Tools > Options > Advanced. Make sure all ActiveX options are enabled. Go to Security tab > Customized.  Make sure all ActiveX options are enabled.

Best wishes!
0
David LeeCommented:
Hi lukeca,

Are you using Word as your email editor?  If so, try using Outlook's built-in editor.

Cheers!
0
f_umarCommented:
u can download and install a free Add-in for adjusting which attachments you can open under Outlook's increased security, for Outlook 2003, 2002 and Outlook 2000 SP3 or later

http://www.mrhtech.com/Downloads/downloads.asp?filename=OutlookSecurity_Addin.zip&q=1
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

lukecaAuthor Commented:
Well thanks for the responses guys, I tried all the solutions and none of them worked :( .   What I need to find out is what gets added or changed in the signature when a reply is made that triggers an active x prompt.  I know why I am getting the error is because Outlook is set to open e-mails in the restricted zone which disables active x, but there is really no reason a signature should be triggering an active x prompt anyway.  Any ideas?
0
David LeeCommented:
One cause is using Word as the mail editor in Outlook.  Word 2003 adds SmartTags and Outlook sometimes sees those as objects in an HTML message.  But if you're not using Word as your email editor, and neither is the person at the other end, then that's not it.  A good troubleshooting step would be to save the message in question as an HTML file, then open it in an editor (e.g. Notepad) and see if you can see what it is that Outlook is taking to be an object.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
lukecaAuthor Commented:
I think you are on the right track BlueDevilFan, I found out that there is an option in Word that adds smart tags to the e-mail if  you are using word as the editor.  I turned those off and I think it may have solved the problem.
0
David LeeCommented:
Great!
0
jwnrbCommented:
I would like to add that I have a client that has the same problem, but this did not work.  I do not have a viable solution, but I told him to disable the signature, or remove the graphic from it completely.  Once that was done, everything was fine.

However, this individual gets the error when he composes/replies, and when certain people receive that email.  I know of a person that receives his email and he gets the message.  But only if the sender gets the Active X error himself when composing the email.

Just thought I would add this to the discussion.
0
doncavinCommented:
After more time than I would like to admit, including a complete remove and reinstall of Office 2003 Pro, the Active X warning and the inability to attach a file when using Word as the email editor remained.
Finally with a hint from the information from lukeca and Blue Devil Fan (above) I deleted my signature that included a graphic.  I realized that I had recently edited the graphic using the "Advanced Edit" which opens Word.  I looked at the HTML source behind the word document and was astounded at the amount of hidden code.
Apparently Word modifies the embedded code with every edit of the signature. When I rebuilt the signature from scratch to the identical appearance, and with the same graphic, both the Active X error and the inability to attach a file when using Word as the email editor went away as well as other previously unexperienced problems.
Everything is now back to normal.
0
joemwhiteCommented:
doncavin's suggestion worked for me.  This machine has Outlook 2003 and Office XP for the other apps.  I recreated this user's signature when moving them to this machine, and used "Advanced Edit" the first time, and copy/pasted their signature from an email in their Sent Items folder.  I was getting the same ActiveX error when trying to compose a new message.  I deleted the signature and then created it without using "Advanced Edit", pasted in the same exact contents from the clipboard, and it worked fine.  Thanks doncavin!
0
specialistservicesCommented:
Removing the smart tags option in Word options fixed this problem for me as well.  Thanks BlueDevilFan
0
David LeeCommented:
You're welcome, specialistservices.
0
Technical_SpecialistCommented:
Once I removed the smart tags, the error went away, but it also put spaces in between the lines once the signature is added to the email.  In word and in the edit signature 'box', there are no spaces and it looks as it should.  In word, under paragraph editing, spacing is single as well.  Any suggestions?
0
David LeeCommented:
Save a message to disk in HTML format.  Open it with Notepad and see if you can identify what's causing the spaces.
0
Technical_SpecialistCommented:
This is the part that is in the signature...  If it's somewhere else in the notepad file, where should I be looking?  Thanks for the assistance.

<p class=MsoNormal><span style='font-size:10.0pt;font-family:Arial'>Sid Atkin</span></p>
<p class=MsoNormal><span style='font-size:10.0pt;font-family:Arial'>Front
Office Manager</span></p>

<p class=MsoNormal>&nbsp;</p>
<p class=MsoNormal><span style='font-size:10.0pt;font-family:Arial'>The
Dahlmann Campus Inn</span></p>
<p class=MsoNormal><span style='font-size:10.0pt;font-family:Arial'>615 E.
Huron</span></p>
<p class=MsoNormal><span style='font-size:10.0pt;font-family:Arial'>Ann Arbor,
MI&nbsp; 48104</span></p>
<p class=MsoNormal><span style='font-size:10.0pt;font-family:Arial'>(734)
769-2200</span></p>
<p class=MsoNormal><span style='font-size:10.0pt;font-family:Arial'><a
href="http://www.campusinn.com">www.campusinn.com</a></span></p>
0
David LeeCommented:
Look at the padding and margin options defined for the MsoNormal class in the style sheet that goes with the signature.  As you can see from the HTML, Microsoft adds A LOT of stuff to the HTML they generate.  One possible solution is to create your signature outside of Outlook (i.e. a third-party HTML editor or, if you're comfortable with HTML, Notepad).  The problem with doing it this way is that you'll only have an HTML version of your signature.  When you create your signature using Outlook it automatically generates three versions: HTML, RTF, and plain-text.  Of course you can match that by making the other two, but it's a lot more effort.  On the positive side, if you always send mail in HTML format, then that's the only one you need.
0
Technical_SpecialistCommented:
I found another posting about this and ended up going back into word to edit the signature.  Instead of Enter when I wanted a new line, I used Shift-Enter.  This worked!  Thanks for extra thoughts though.
0
David LeeCommented:
You're welcome.  Glad you found a solution.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Outlook

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.