?
Solved

FC4, Samba fileserver, not able to write

Posted on 2006-03-30
7
Medium Priority
?
307 Views
Last Modified: 2013-12-06
i can see and open the folder that i have created on the FC4 machine(/shared) but can't write, when i try to paste anything from my windows machine to the said folder it gives me an error message "Access Denied: Source file may be in use". executed chmod 777 /shared command... what could i be missing?
0
Comment
Question by:DexterJones
7 Comments
 
LVL 17

Expert Comment

by:Dushan De Silva
ID: 16331483
Start --> System Settings --> Server Settings --> Samba -->

Select your particular folder --> Properties.
Make sure you have gave not "Read-only" option and , you should give "Read/ Write" Option.

BR Dushan
0
 

Author Comment

by:DexterJones
ID: 16332221
I did check and its set to "Read/Write".
0
 
LVL 17

Expert Comment

by:Dushan De Silva
ID: 16333214
Then please check, that perticular folder's access groups are in samba group.

BR Dushan
0
Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

 

Author Comment

by:DexterJones
ID: 16333318
i would assume it is there, since im able to open/read the folder from my windows machine.
0
 

Author Comment

by:DexterJones
ID: 16333364
I have verified that:
The directory has permissions of:  “drwxrwxrwx”

My smb.conf file contains the following line for the said directory:
[shared]
comments = shared files
path = /shared/%U
read only = No

I have created a number of shared samba directories and they all work the
same – reading is OK but can’t write.

My samba version is 3.0.14a-2
I am running Fedora Core with kernel 2.6.14
0
 
LVL 1

Accepted Solution

by:
verborghs earned 2000 total points
ID: 16342895
You will probably need to disable the SE Linux Extensions:
http://fedora.redhat.com/docs/selinux-faq-fc3/
0
 
LVL 1

Expert Comment

by:WayneFourie
ID: 16378706
That sounds like an easy one...

RESTART THE SAMBA SERVICE... oh by the way i use chmod 0777 /share then restart samba.

Have fun let me know if it worked.

Regards,
Wayne
0

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I. Introduction There's an interesting discussion going on now in an Experts Exchange Group — Attachments with no extension . This reminded me of questions that come up here at EE along the lines of, "How can I tell the type of file from its cont…
This article explains how to use the rsync command to create backups and sync data across hosts. Rsync is a very useful command that is often used to copy data, make backups, migrate hosts, and bridge the gap between site staging and production envi…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

601 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question