Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

VSS error

Posted on 2006-03-30
13
Medium Priority
?
866 Views
Last Modified: 2008-01-09

Error come up when i try to do ntbackup to file or tape. I tried diffrent ideas form microsoft but i am stuck.

Thanks for any suggestions

Event Type:      Error
Event Source:      VSS
Event Category:      None
Event ID:      20
Date:            30/03/2006
Time:            11:37:23
User:            N/A
Computer:      SERVER01
Description:
Volume Shadow Copy Service error: A critical component required by the Volume Shadow Copy service is not registered.  This might happened if an error occurred during Windows setup or during installation of a Shadow Copy provider.  The error returned from CoCreateInstance on class with CLSID {faf53cc4-bd73-4e36-83f1-2b23f46e513e} and Name VSSEvent is [0x80040154].

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 2d 20 43 6f 64 65 3a 20   - Code:
0008: 42 55 45 43 58 4d 4c 43   BUECXMLC
0010: 30 30 30 30 33 32 38 31   00003281
0018: 2d 20 43 61 6c 6c 3a 20   - Call:
0020: 42 55 45 43 58 4d 4c 43   BUECXMLC
0028: 30 30 30 30 37 30 39 36   00007096
0030: 2d 20 50 49 44 3a 20 20   - PID:  
0038: 30 30 30 30 35 30 37 32   00005072
0040: 2d 20 54 49 44 3a 20 20   - TID:  
0048: 30 30 30 30 34 35 38 38   00004588
0050: 2d 20 43 4d 44 3a 20 20   - CMD:  
0058: 22 43 3a 5c 57 49 4e 44   "C:\WIND
0060: 4f 57 53 5c 73 79 73 74   OWS\syst
0068: 65 6d 33 32 5c 6e 74 62   em32\ntb
0070: 61 63 6b 75 70 2e 65 78   ackup.ex
0078: 65 22 20 20 20 20 20 20   e"      
0080: 2d 20 55 73 65 72 3a 20   - User:
0088: 54 41 59 4c 4f 52 42 55   company
0090: 43 48 41 4c 54 45 52 5c   name\
0098: 61 64 6d 69 6e 69 73 74   administ
00a0: 72 61 74 6f 72 20 20 20   rator  
00a8: 2d 20 53 69 64 3a 20 20   - Sid:  
00b0: 53 2d 31 2d 35 2d 32 31   S-1-5-21
00b8: 2d 32 31 35 31 39 30 32   -2151902
00c0: 36 2d 31 30 37 36 31 31   6-107611
00c8: 36 35 39 38 2d 37 37 35   6598-775
00d0: 36 31 35 38 38 34 2d 35   615884-5
00d8: 30 30 20 20 20 20 20 20   00      
0
Comment
Question by:mickinoz2005
  • 4
  • 4
  • 2
  • +2
12 Comments
 
LVL 48

Expert Comment

by:Jay_Jay70
ID: 16330888
Hi mickinoz2005,

do you have SQL installed on the machine?

Cheers!
0
 
LVL 48

Expert Comment

by:Jay_Jay70
ID: 16330900
mickinoz2005,

maybe also try running this

regsvr32 vss_ps.dll

taken from
http://backupassist.com/phpBB2/viewtopic.php?t=17
0
 
LVL 12

Expert Comment

by:Mazaraat
ID: 16334845
Have you installed SP1 and all of the latest patches...?  There was a bug in SP1 that dealt directly withi ntbackup and VSS, here is the fix that MS gave another user:

http://groups.google.com/group/microsoft.public.windows.server.general/browse_thread/thread/3ff9e9b4ddd8bb26/cf2ab0a2c82c5c20?lnk=st&q=event+id+20+VSS&rnum=8&hl=en#cf2ab0a2c82c5c20

Excerpt:
:It is a bug with SP1.  The resolution is as follows.


Option 1 or Option 2.  I found option 2 easier as option 1 requires a server
restart and will mean AD DB & Log are both on C: drive.


1. Moving the AD log files back to the default location (“C:”).


2. Select “D:” (or a file in that volume) to force a shadow copy on it.
This, in turn will suppress the NTDS writer error.  (I created a dummy text
file on the drive where my NTDS Log files were and included in the backup
set.)


The likely reason behind those error messages is that AD is configured such
that it keeps the databases and the logs on separate volumes.
The AD writer (NTDS) will report an error if you try to create a shadow copy
set that has one of the volumes but not the other.
The problem is that in this configuration (AD databases and logs are on a
different volume) NTBackup doesn't pick up the correct set of volumes.
By selecting system state, NTBackup requests for a shadow copy to be created
on the boot volume.
By the time NTBackup requests for the location of the AD database and logs,
the shadow copy has already been created.
Thus, NTBackup will not create a snapshot on “D:”.
This throws the NTDS writer off, thinking that NTBackup is not going to pick
up all its data on D: thus causing an error.
"
0
Veeam and MySQL: How to Perform Backup & Recovery

MySQL and the MariaDB variant are among the most used databases in Linux environments, and many critical applications support their data on them. Watch this recorded webinar to find out how Veeam Backup & Replication allows you to get consistent backups of MySQL databases.

 
LVL 5

Author Comment

by:mickinoz2005
ID: 16390344
Hi,

Thanks for all tips but it still doesn’t work. In my sbs I have all ntds files in default location. I have re-registered all dll:
regsvr32 ole32.dll
regsvr32 vss_ps.dll
Vssvc /Register
regsvr32 /i swprv.dll
regsvr32 /i eventcls.dll
regsvr32 es.dll
regsvr32 stdprov.dll
regsvr32 vssui.dll
regsvr32 msxml.dll
regsvr32 msxml3.dll
regsvr32 msxml4.dll

plus one for a sql. Restart a server and still nothing. I tried to compare these registry key from error ({faf53cc4-bd73-4e36-83f1-2b23f46e513e}) with other working sbs server and everything seems to be ok (the name, value, and permission on this key).

So if any other ideas I am looking forward to hear it.

Thanks guys for your time 
0
 
LVL 5

Author Comment

by:mickinoz2005
ID: 16569620
Just wondering if anybody has any more ideas on this one as the problem still exists and we need to get it fixed.

If we backup the server without system state we have no problem just when we include system state we have the above prob.
0
 
LVL 12

Expert Comment

by:Mazaraat
ID: 16587231
When you re-registered the DLL's did you first **stop** the volume shadow copy service, go to a cmd prompt navigate to c:\windows\system32??

start->run->cmd
in command shell-
---net stop vss
 regsvr32 ole32.dll
 regsvr32 vss_ps.dll
 Vssvc /Register
 regsvr32 /i swprv.dll
 rRegsvr32 /i eventcls.dll
 regsvr32 es.dll
 regsvr32 stdprov.dll
 regsvr32 vssui.dll
 regsvr32 msxml.dll
 regsvr32 msxml3.dll
 regsvr32 msxml4.dll


Also, if the above steps do not resolve the issue, you may have to
reinstall the COM+, and then re-register the services and binaries **again**.

On a pre-SP1 system, you do not need to reinstall COM+. On the Pre-SP1
system
install the COM+ Rollup from:

883955 Availability of Windows Server 2003 COM+ 1.5 Rollup Package 3
(requires a
reboot).

On a post SP1 System

----------------------------------

Reinstall COM+

1. Backup and then delete HKLM\Software\Microsoft\COM3

2. Boot to Recovery console and rename clbcatq.dll to ~clbcatq.dll. Be
sure to use
the tilde.

3. Boot to normal mode and in Control Panel, open the Add or Remove
Programs tool,
and then open the Add/Remove Windows Components tool. Do not make any
changes, just
click "Next". This reinstalls COM+.

NOTE: You must have your Windows Server 2003 SP1 files available during
this step.


0
 
LVL 12

Expert Comment

by:Mazaraat
ID: 16587243
oops forgot to add when in the cmd shell to navigate to c:\windows\system32, very important
0
 
LVL 5

Author Comment

by:mickinoz2005
ID: 16832537
Hi there,

The problem has not been solved, the guy looking after it has been away. i will get him back on to this.

So please keep this question open.

Thanks

Michael
0
 
LVL 5

Author Comment

by:mickinoz2005
ID: 16893540
Hi all,

The solution to this problem was found at

http://www.backupassist.com/KnowledgeBase/index.php/Main/ErrorVolumeShadowCopy

Mazaraat you comment was close but it is missing some information thanks for your help anyway.

As this was solved by myself I would like a refund off the points please.

Thanks

Michael

0
 
LVL 9

Expert Comment

by:vsg375
ID: 16894429
Hi mickinoz2005

Since you found the solution by yourself, and experts here gave valuable information, my suggestion will now be :

PAQ with points refunded

Cheers

vsg375
EE Cleanup Volunteer
0
 
LVL 12

Expert Comment

by:Mazaraat
ID: 16894907
Glad you were able to solve the problem
0
 
LVL 1

Accepted Solution

by:
DarthMod earned 0 total points
ID: 16991436
PAQed with points refunded (500)

DarthMod
Community Support Moderator
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I guess it is not common knowledge to most Wintel engineers/administrators: If you have an SNMP-based monitoring system in your environment (and it's common to have SNMP or Syslog) it's reasonably easy to enable monitoring of the Windows Event logs,…
On July 14th 2015, Windows Server 2003 will become End of Support, leaving hundreds of thousands of servers around the world that still run this 12 year old operating system vulnerable and potentially out of compliance in many organisations around t…
This Micro Tutorial will teach you how to add a cinematic look to any film or video out there. There are very few simple steps that you will follow to do so. This will be demonstrated using Adobe Premiere Pro CS6.
As many of you are aware about Scanpst.exe utility which is owned by Microsoft itself to repair inaccessible or damaged PST files, but the question is do you really think Scanpst.exe is capable to repair all sorts of PST related corruption issues?

810 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question