vsftpd setup problems (virtual users)

Still new to linux and Suse10, but I have managed to get apache2 and some form of vsftpd running , but now trying to only allow local users and virtual users.

I have followed the documentation at http://vsftpd.beasts.org  almost to the letter and I have managed to get the server started and if now asks for user/pass which it never accepts.

I would really appreciate any pointers.  Of course, just let me know any additional info you need.  Here are some settings that I have.

/etc/pam.d/vsftpd.pam
  auth required /lib/security/pam_userdb.so db=/etc/vsftpd_login
  account required /lib/security/pam_userdb.so db=/etc/vsftpd_login

/etc/vsftpd.conf
  anonymous_enable=NO
  local_enable=YES
  write_enable=NO
  anon_upload_enable=NO
  anon_mkdir_write_enable=NO
  anon_other_write_enable=NO
  chroot_local_user=YES
  guest_enable=YES
  guest_username=virtual
  #listen=YES
  #listen_port=10021
  pasv_min_port=30000
  pasv_max_port=30999

vsftp_login.db  seems to have successfull been created as a binary file

Thanks for any info
Rockman
LVL 10
rockmansatticAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

mightyoneCommented:
make sure all users exist and are known to system.

nice german tuitorial
http://archiv.debianhowto.de/de/vsftpd/installation_konfiguration.html

this one is english and not to bad either
http://www.chinalinuxpub.com/doc/www.siliconvalleyccie.com/linux-hn/ftp-server.htm

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rockmansatticAuthor Commented:
thanks, I have opted for teh english version and gotten it to work sort of.  

With this config, I can ftp via terminal from anywhere on my network, but I get a "Child Died" when I attempt via browser.  

Any ideas?

thanks
Rockman
rockmansatticAuthor Commented:
Im now very close...

I am now using local users ,NOT VIRTUAL.

Here the last step for me.

I can login with command line from remote.
I can login through browser fine only if Firewall is OFF.
I can make first connection to server (where it asks for password) if I add port 21 to my "additional allowed ports" in YAST.  But it then stalls.
I have attempted to add port 20 but that doesnt work the way I tried it.

Thanks for any info.
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

mightyoneCommented:
ftp uses more ports,

main ports are
20,21,,989,990
supplement for some special clients
47,247,349,574,1031
rockmansatticAuthor Commented:
Still no go.
I have opend? all these ports using YAST in the TCP location and still stalls AFTER I put in a correct password.

You have answered my first question. Thanks
mightyoneCommented:
make sure it is tcp and udp u allowed.  maybe think of putting your ftp on dmz settings or change to ssh and scp
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage Software

From novice to tech pro — start learning today.