vsftpd setup problems (virtual users)

Still new to linux and Suse10, but I have managed to get apache2 and some form of vsftpd running , but now trying to only allow local users and virtual users.

I have followed the documentation at http://vsftpd.beasts.org  almost to the letter and I have managed to get the server started and if now asks for user/pass which it never accepts.

I would really appreciate any pointers.  Of course, just let me know any additional info you need.  Here are some settings that I have.

/etc/pam.d/vsftpd.pam
  auth required /lib/security/pam_userdb.so db=/etc/vsftpd_login
  account required /lib/security/pam_userdb.so db=/etc/vsftpd_login

/etc/vsftpd.conf
  anonymous_enable=NO
  local_enable=YES
  write_enable=NO
  anon_upload_enable=NO
  anon_mkdir_write_enable=NO
  anon_other_write_enable=NO
  chroot_local_user=YES
  guest_enable=YES
  guest_username=virtual
  #listen=YES
  #listen_port=10021
  pasv_min_port=30000
  pasv_max_port=30999

vsftp_login.db  seems to have successfull been created as a binary file

Thanks for any info
Rockman
LVL 10
rockmansatticAsked:
Who is Participating?
 
mightyoneCommented:
make sure all users exist and are known to system.

nice german tuitorial
http://archiv.debianhowto.de/de/vsftpd/installation_konfiguration.html

this one is english and not to bad either
http://www.chinalinuxpub.com/doc/www.siliconvalleyccie.com/linux-hn/ftp-server.htm
0
 
rockmansatticAuthor Commented:
thanks, I have opted for teh english version and gotten it to work sort of.  

With this config, I can ftp via terminal from anywhere on my network, but I get a "Child Died" when I attempt via browser.  

Any ideas?

thanks
Rockman
0
 
rockmansatticAuthor Commented:
Im now very close...

I am now using local users ,NOT VIRTUAL.

Here the last step for me.

I can login with command line from remote.
I can login through browser fine only if Firewall is OFF.
I can make first connection to server (where it asks for password) if I add port 21 to my "additional allowed ports" in YAST.  But it then stalls.
I have attempted to add port 20 but that doesnt work the way I tried it.

Thanks for any info.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
mightyoneCommented:
ftp uses more ports,

main ports are
20,21,,989,990
supplement for some special clients
47,247,349,574,1031
0
 
rockmansatticAuthor Commented:
Still no go.
I have opend? all these ports using YAST in the TCP location and still stalls AFTER I put in a correct password.

You have answered my first question. Thanks
0
 
mightyoneCommented:
make sure it is tcp and udp u allowed.  maybe think of putting your ftp on dmz settings or change to ssh and scp
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.