Pix Configuration for Multiple Servers

How do I configure my pix to pass traffic to my web server (IP 10.1.1.5), my Mail Server (10.1.1.2), and my FTP server (10.1.1.3).

PIX
Outside: 12.18.x.x
Inside: 10.1.1.1

Does anyone have a simple guide for me to follow?

Thanks
LVL 1
zejokaAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Italia_NYCCommented:
Could you possibly be any more specific?

For starters......What kind of traffic? What version of the PIX software are you running?
zejokaAuthor Commented:
web server (IP 10.1.1.5) ports 80 & 8080
my Mail Server (10.1.1.2), port 25 & 80
and my FTP server (10.1.1.3). Ports 22

Basically i can configure for ONE IP 10.1.1.2 (25 & 80) address using ACL, Static, etc...  But I can't pass other traffic to the other servers 10.1.1.3 (ftp) and 10.1.1.5 (80 & 8080)

Pix 515 6.3(4)
naveedbCommented:
Can you post your existing configuration from PIX. As always remove public IPs/ passwords
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

zejokaAuthor Commented:
At the moment, one server handles everything, but we've just upgraded equipment and everything is ready to switch over.  The new IP scheme will be in the 10 range, but basically you can use the 192 range to illustrate the config differences between the different servers.  Instead of everything going to 192.168.6.2, I want to put Mail traffic to 192.168.6.2 (80 and 25) web traffic 192.168.6.3 (80 and 8080), and ftp traffic on 192.168.6.4 (22) and RRAS server on 192.168.6.4 (pptp)

PIX Version 6.3(4)
interface ethernet0 auto
interface ethernet1 auto
interface ethernet2 auto shutdown
nameif ethernet0 outside security0
nameif ethernet1 inside security100
nameif ethernet2 intf2 security4
enable password ***** encrypted
passwd ***** encrypted
hostname pix515ny
domain-name ceramiassociates.com
clock timezone EST -5
clock summer-time EDT recurring
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol pptp 1723
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 192.168.100.0 CAIDC
access-list inside_outbound_nat0_acl permit ip 192.168.6.0 255.255.255.0 CAIDC 255.255.255.0
access-list outside_cryptomap_20 permit ip 192.168.6.0 255.255.255.0 CAIDC 255.255.255.0
access-list outside_access_in permit tcp any any eq smtp
access-list outside_access_in permit tcp any any eq www
access-list outside_access_in permit tcp any any eq 3389
access-list outside_access_in permit tcp any any eq pptp
pager lines 24
logging on
logging timestamp
logging buffered informational
mtu outside 1500
mtu inside 1500
mtu intf2 1500
ip address outside 12.xx.xx.xx 255.255.255.240
ip address inside 192.168.6.100 255.255.255.0
no ip address intf2
ip audit info action alarm
ip audit attack action alarm
pdm location 192.168.6.2 255.255.255.255 inside
pdm location 192.168.1.0 255.255.255.0 inside
pdm location CAIDC 255.255.255.0 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
global (outside) 2 12.xx.xx.xx
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 192.168.6.0 255.255.255.0 0 0
static (inside,outside) tcp interface smtp 192.168.6.2 smtp netmask 255.255.255.255 0 0
static (inside,outside) tcp interface www 192.168.6.2 www netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 3389 192.168.6.2 3389 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 47 192.168.6.2 47 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface pptp 192.168.6.2 pptp netmask 255.255.255.255 0 0
static (inside,outside) 12.xx.xx.xx 192.168.6.2 netmask 255.255.255.255 0 0
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 12.xx.xx.xx
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.6.0 255.255.255.0 inside
http 0.0.0.0 0.0.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server community *****
no snmp-server enable traps
tftp-server inside 192.168.6.50 /515newcfg
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto map outside_map 20 ipsec-isakmp
crypto map outside_map 20 match address outside_cryptomap_20
crypto map outside_map 20 set peer 67.xx.xx.xx
crypto map outside_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map interface outside
isakmp enable outside
isakmp key ******** address 67.xx.xx.xx netmask 255.255.255.255 no-xauth no-c
onfig-mode
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash sha
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
telnet 192.168.6.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
vpdn enable outside
dhcpd lease 3600
dhcpd ping_timeout 750
terminal width 100
Italia_NYCCommented:
Is this PIX performing NAT with a pool of public IP's?

If so, all you need to is create a static translation and open up the desired ports.

For instance for 10.1.1.5 and ports 80, 8080

static (inside,outside) 12.18.?.? 10.1.1.5 netmask 255.255.255.255

Then, modify the access-list to allow the desired ports.

access-list acl_out permit tcp any host 12.18.?.? eq 8080
access-list acl_out permit tcp any host 12.18.?.? eq 80

That's it.
zejokaAuthor Commented:
Only one public IP address.  Will this change anything?
Italia_NYCCommented:
Not really; the logic and the basic principal is the same.

you need to statically map the port you want open to the internal IP address of the server (ie: static (inside,outside) 12.18.?.? 10.1.1.5 netmask 255.255.255.255).

then you need to open up the ports (ie: access-list acl_out permit tcp any host 12.18.?.? eq 8080).

That's pretty much it.

Where you may run into issues, is mapping multiple internal IP addresses (servers/workstations) to the same port with only ONE public IP.

For instance; if you mapped port 80 (www) to two servers inside your network; when somone enters your Public IP address into their browser, this may cause problems as to which server responds (if at all).

Hope this helps.
zejokaAuthor Commented:
OK, when I put:-

static (inside,outside) 12.18.xx.xx 192.168.6.5 netmask 255.255.255.255

It says duplicate of existing static, but the existing static is:-

static (inside,outside) 12.18.xx.xx 192.168.6.2 netmask 255.255.255.255
                                                               ^^
I'm sure I'm missing something retarded, but I'm still lost
Italia_NYCCommented:
static (inside,outside) tcp interface www (or any port) 192.168.6.5 www netmask
255.255.255.255


this should map port www (80) to 192.168.6.5 for you.

calvinetterCommented:
>Basically i can configure for ONE IP 10.1.1.2 (25 & 80) address using ACL, Static, etc...  
>But I can't pass other traffic to... 10.1.1.5 (80 & 8080)
  Sorry for the bad news, but it is *not* possible on the PIX for you to forward the same port (ie, TCP port 80) to 2 different internal servers. Nope, can't do it.  That's why the PIX complains about duplicate entries.

>static (inside,outside) tcp interface www 192.168.6.2 www
   With an entry like above, you *can't* add something like this:
static (inside,outside) tcp interface www 192.168.6.15 www
   Nor even this:
static (inside,outside) tcp interface www 192.168.6.15 8080

Here's what you could do, with a single IP for multiple servers:  You'd have to configure your internal servers (ftp, www or otherwise) to listen on a different port, & anyone on the outside trying to access the 2nd web server would have to specify the non-standard port in the URL.  For example:
    Existing entry:
>static (inside,outside) tcp interface www 192.168.6.2 www
    New entry, with new web server listening on TCP port 3001:
static (inside,outside) tcp interface 3001 <IP of web server #2> 3001
  [ And always run 'clear xlate' when making changes to your NAT config, 'static' or otherwise. ]

  So to access the 2nd web server, a user on the outside would have to specify the port in their web browser like so:
http://website.com:3001

Obviously, having to specify a port in the web browser probably isn't an option you want to be stuck with.  It's better to get a small block of public IPs from your ISP, so you at least have a separate public IP for each of the servers that will be running similar services.

cheers
zejokaAuthor Commented:
OK, how about this:-

I port all SMTP traffic to 192.168.6.5 (Barracuda Spam Firewall - which autmatically forwards accepted mail to Mail server 192.168.6.2)
I port web and OWA traffic to the Exchange server (192.168.6.2)

Therefore, wouldn't I just need two entries something like:-

access-list outside_access_in permit tcp any any eq smtp
access-list outside_access_in permit tcp any any eq www

static (inside,outside) tcp interface smtp 192.168.6.5 smtp netmask 255.255.255.255 0 0
static (inside,outside) tcp interface www 192.168.6.2 www netmask 255.255.255.255 0 0

static (inside,outside) 12.xx.xx.xx 192.168.6.2 netmask 255.255.255.255 0 0
static (inside,outside) 12.xx.xx.xx 192.168.6.5 netmask 255.255.255.255 0 0

access-group outside_access_in in interface outside

Or is my logic still totally screwed?
Italia_NYCCommented:
Yes, that should work fine. Matter of fact, I have my setup at home configured VERY similiar to that.

You shouldn't need these lines;
static (inside,outside) 12.xx.xx.xx 192.168.6.2 netmask 255.255.255.255 0 0
static (inside,outside) 12.xx.xx.xx 192.168.6.5 netmask 255.255.255.255 0 0

Your just mapping ports, so this is correct;
static (inside,outside) tcp interface smtp 192.168.6.5 smtp netmask 255.255.255.255 0 0
static (inside,outside) tcp interface www 192.168.6.2 www netmask 255.255.255.255 0 0

Just add the following access-list entries and you should be able to call it a day;
access-list outside_access permit tcp any host 12.xx.xx.xx eq www
access-list outside_access permit tcp any host 12.xx.xx.xx eq smtp

As previously mentioned; it is good practice to issue a "clear xlate" command after making these entries.

Good Luck.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Italia_NYCCommented:
Yes?
zejokaAuthor Commented:
Sorry for the delay.

OK, so my logic was a little flawed given that I am CCNA and routers differ slightly from Firewalls.  Basically, I followed your advice but created a virtual interface with another public IP address we had in our pool and that did the trick.  Thanks for your help!
Italia_NYCCommented:
No problem, glad you got it working. :)
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Software Firewalls

From novice to tech pro — start learning today.