SQL Server 2005 Reporting Services, Export report as Read Only

I built a report using SQL Server 2005 reporting services and Visual Studio 2005. Is there a way to make the exports read only. I don't want them to export it to excel, for example, and be able to edit.
lyptusAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

simon_kirkCommented:
Hi,

Not sure you can, as RS is limited on what it can get the exports to do.  If you export to PDF, unless the user has the full version of acrobat, this export would be read only.  TIFF export's would also be readonly.

Maybe you could write a custom rendering extension that does this, but it's a lot of work for the result!
lyptusAuthor Commented:
simon kirk -
Where would I write the customer rendering extension? Is it in the rsreportserver.config file? I saw there were rendering exts for the different exports there. I thought if I commented the excel line out then excel would not be available. However, this did not work. I'm not too concerned about the work load. I really need to make this happen.
Do you know anything about the rsreportserver.config file? If I can't make it read only I would like to have the exports that can be modified removed.
Thanks,
Brett
simon_kirkCommented:
Easiest way is to remove the export options that allow editing.  In the ReportServer config file add Visible="false" at the end of the extension you wish to hide.  e.g.

<Extension Name="EXCEL"Type="Microsoft.ReportingServices.Rendering.ExcelRenderer.ExcelRenderer,Microsoft.ReportingServices.ExcelRendering" Visible="false"/>

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
lyptusAuthor Commented:
I found out why it didn't work when I commented out the excel line in the config file. You have to restart IIS for it to take effect. So, if I can't set it to read only, I'll use this option.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
DB Reporting Tools

From novice to tech pro — start learning today.