We help IT Professionals succeed at work.

Veritas restore of Exchange 2003 emails

Dilan77
Dilan77 asked
on
Medium Priority
1,077 Views
Last Modified: 2013-12-01
Hi,

We are running Veritas 9.1 rev 4691.

I am trying to restore a couple of emails to a user's inbox, but the restore job is getting stuck at 99%.

I've tried twice today for two different users. The first time, the restore job stuck at 99% but the mails were restored to the box. I then cancelled the job.

Now, the mails are not being restored and the job is stuck at 99% even after 15 mins. We are only restoring about 11Kb of data, so it should not take this long.

We are running Exchange 2003 SP2 on a Windows 2000 server with the remote agent installed. The backup server is Windows 2000 SP4.

Does anyone have any ideas on how to resolve this? There is no problem with restoring files.

Thanks
Dilan
Comment
Watch Question

Commented:
Try to have a look at this, Dilan !

http://seer.support.veritas.com/docs/275586.htm "

Best Regards !

Commented:
Or this one " http://seer.support.veritas.com/docs/238618.htm "

Best Regards !

Author

Commented:
Thanks Jon, but I am not actually receiving any error messages - the restore job just hangs at 99% for some reason!
Not sure if you have resolved this one but is the Veritas job waiting for confirmation from the Exchange server? This would probably only happen if the IS was to be stopped and restarted?

Not ideal, but maybe worth a try.

Alternatively, are you confident that the IS is error free? Have you run a defrag or ISEUTIL /Fix on it recently? Could be some lost indexes that Veritas is trying to restore but can't find in the store.

Hope this helps
Barny

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Author

Commented:
Hi Barney,

Nope, still hasn't been resolved. I'm going to try a Recovery Storage Group when I have time over the weekend and see how that goes.

I am not confident that the IS is error free, I've been running for the network for a year now and I haven't run any manual defrags. We haven't had any large scale creation of mailboxes, so I assumed the nightly online defrag that Exchange 2003 was enough?

I will run the ESEUTIL and ISINTEG checks to see if there are any problems. No automatic repairs or fixes at this stage yet though.

Thx

Author

Commented:
Ok, attempted to restore the mailbox store to a RSG following the instructions in the article

http://seer.support.veritas.com/docs/264815.htm

But the restore job hung. The Veritas job log states -

Restore - \\MAILSERV\Microsoft Information Store\First Storage Group Access denied to database Mailbox Store (MAILSERV).
Error writing file data.
The media operation was terminated by the user.
Error writing file data.
Connection to the restore target has been lost. Operation canceled.

My question also is, how does Veritas know to restore the Mailbox Store to the Recovery Storage Group and not the live First Storage Group?

Thanks.
Commented:
The Exchange Agent from Veritas should take care of that !

Best Regards !

Author

Commented:
Upgrading Veritas to Service Pack 4 solved the issue of the restore job getting stuck at 99%
Ran the Recovery Storage Group after that.
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.