Throughput of LTO II only 12GB/Hr

Hi I have an LTO 460 on a XP pro box with a raid 0. The drive is connected via a 29160 and is displayed at boot time as connected at 160 MB/s.

I cannot achieve better than about 12GB/hr transfer rate on the drive. I have tried the StorageWorks Tape Tools perfomance test and achive the same poor performance (3MB/s). I also receive the same performance when reading from the tape and discarding the output. So it is not the hard disks that are the bottleneck.

The health tab in Tape Tools says that current configuration is narrow and the recommended is wide - i would not have thought this a problem as the drive is connected at 160MB/s according tothe BIOS display at  boot  time.

Is narrow likely to be enough to limit the performance?  
 

I tried two totally different machines one a 3.4GHz P4's with 1GB memory the other a 3.8GHz machine with 4GB (both running XP Pro)

Two Ultrium 460's with the latest firmware

a 29160LP and a 39160 with the latest drivers


I have run out of things to try

Any suggestions very gratefully received.
 
LVL 2
sandy771Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

gurutcCommented:
Hi,

Yes, narrow is slow.  no, not slow, stopped almost.  You need to connect to these drives with an UltraSCSI LVD connection.  This is the difference between 5-10 MB/sec potential and 40-80MB/sec potential.  And since your SCSI connection is so slow, the tape drive is slowed down possibly by more than 50% by not being able to stream the data to the tape.  It has to continually reposition the write heads which will lead to premature drive failure and dramatically shorter tape life and may cause you to lose data.  Get a good Ultra2LVD controller, cabling and connection to this drive.  If it doesn't support LVD (which I've never seen  an LTO not have), at least go to wide which will double your speed.

Here's a good link:  http://www.unylogix.com/data_storage/tape_mirroring/tml_series.html

- Travis
0
gurutcCommented:
Also, when the machine is booting, go into the SCSI controller utility by hitting CTRL-A when it says to.  Then reset the controller to its defaults.  I've run into this too where somehow the controller had been set to a slow state, perhaps for compatibility with super old slow devices.

Good Luck,
Travis
0
Renato Montenegro RusticiIT SpecialistCommented:
29160 is a Ultra 160 board --- and old board---, while your tape drive supports much faster speeds. But ok, 3MB/s is too low. Please, pay attention to this factors:

1) When you copy lots of small files, the throughput decreases
2) When you copy larger files, the throughput increases
3) When a copy take few seconds, the throughput will be low
4) Longer backups with larger files perform better

So, its possible to achieve slow rates when you're copying a folder full of small files or when you're doing a very smal backup - in terms of time.

Another think to take in account is that your tape is supported with your driver and with your SCSI board. Some firmware and drivers upgrades can make you achieve the best performance.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

sandy771Author Commented:
Thanks for your replies

Although the TapeTools software is reporting the connection as Narrow I have a U320 cable connected to the external LVD SCSI VHDCI connector  - this is the cable that was supplied with the drive. The card is an Ultra SCSI LVD card.

The card and cable should be more than adequate for the task in hand.

As I mentioned in my original post the conrtroller BIOS has negotiated a 160MB/s connection with the drive

0
sandy771Author Commented:
rmrustice

The software I have written myself has a test mode that does not read form a hard disk drive but sends the samne buffer of data time after time.

But more importantly HP's own test software gets the same poor throughput
0
gurutcCommented:
Have you tried a new cable?  Mine crap out all the time.

Travis
0
dovidmichelCommented:
Not sure about the RAID 0 comment, but the same bus should not be sharred with tape and disk.

There is the possibility of a problem with the drive or tapes.

No mention on the data source, if it has been local then ok fine, but if it is remote then the problem could be there.
0
gurutcCommented:
Is the raid on the same SCSI controller?  If so move it.  And what else is running on this box?  How about updated controller drivers?  And in CMOS, is PCI bus mastering enabled/disabled?  Also, just because it negotiates 160 doesn't mean it's running that fast.  Negotiation means 'I found this' not I'm gonna run that fast.  Go into the controller app and reset to default.  And make sure nothing else is connected.  Older and slower SCSI devices will slow the whole thing down.

Travis
0
Renato Montenegro RusticiIT SpecialistCommented:
So, i aggree with travis. It happens all the time.
0
sandy771Author Commented:
Sorry no the raid is not the same controller - it is a sata raid

please note that the tape tools test software does NOT READ FROM DISK when testing the performance of the tape drive
0
Renato Montenegro RusticiIT SpecialistCommented:
I spoke about the SCSI cable.
0
sandy771Author Commented:
as I said in my first post I have tried three different cables

Two of them new
0
dovidmichelCommented:
The default for the controller is to automatically set the transfer speed on startup. It would be a good idea to go into the configuration and fix it at a set rate.
0
gurutcCommented:
Also, note that anything connected to this controller besides the tape drive, like disks, a scanner or even an empty scsi cable on an unused connector, even if they aren't in use, will crap out the speed.  Are you using the built-in driver support for this controller?  If so, download and use the Adaptec drivers.  And again, have you reset the controller using the built-in utility?

And finally, is it properly terminated?  Besides trying a new cable also replace the terminator at the tape drive.

Travis
0
gurutcCommented:
What I was saying is that the controller may not currently be set at default.  Even if it is brand new.

Travis
0
gurutcCommented:
Your original post was not clear that you had used separate cables.  We are trying to help you.

- Travis
0
sandy771Author Commented:
Travis the controller displays the speed it has negotitaed with the drive when you boot the computer

The speed is displayed as 160MB/s

Even so I have checked the controller and it is set to 160

If I put a SE terminator on the drive (which I did by mistake) then the speed displayed at boot time is 40MB/s

The HP 460 has active termination and therefore does not need a terminator when it is the only device on a  bus (which it is) I have however tried with an LVD terminator and get exactly the same results

0
sandy771Author Commented:
My apologies Travis I did not post that I had used three cables on this forum but on another.

I do appreciate that you are trying to help

S
0
gurutcCommented:
Ok, do you have a scsi drive you can hook up internally?  If so, how fast does it run?  Also, is the spec on the drive 160MB/s?  It may negotiate even if it's not rated as such, cut the controller speed down to 80 and see what happens. You need another SCSI device to hook up, sounds like maybe a bad tape drive.  Also did you hook up that terminator accidentally the first time?  If so, you may have fried something.

Travis
0
sandy771Author Commented:
I dont have a scsi drive so cant do that

I have two of these Ultrium 460's both exhibit exactly the same problem

The term should not have fried anything as the spec says that placing a SE device on the chain will just drop the whole bus down to SE performance - anyway it has only been on one of the two drives.

FWIW I now have the 39160 card back in the machine - and still the same results.

I have been tempted to purchase a 320 device - but as the 160 should be man enough of rthe job I think I would be wasting my money
0
gurutcCommented:
Don't buy a new drive yet!!! We'll get this licked.  

Are the workstations you're trying major manufacturer?  Sometimes Dell and others need a patch for the most unexpected things.  

Also, in device manager, are there any unknown/question mark devices?  Other seemingly unrelated drivers may be misbehaving and troubling you.

In CMOS, is there any IRQ sharing enabled?  If the video is built-in have you set the AGP aperture at 64 megs(best setting for me so far), and can you set the CMOS settings as close to default as you can?

Also, for the backups themselves, what is the software you're using?  CA ArcServe, for instance, installs its own drivers which are significantly different than the drive manufacturers' ones or the ones included in Windows.  

And another thing to check is whether the removable storage service is running on this machine.  Unless you're using the built-in Windows NTBackup program you should disable this service.  

Are there any events that occur or recur in the event logs, all of them, including application, security and system?

When you list the running system services, sort by startup type.  Are any of the ones that are set to start automatically not running?  If so, which ones.

Is there any high-end or upgraded hardware in these systems including video?

Since the RAID is built-in SATA you're loading motherboard drivers.  Have you installed all the included drivers including for every built-in chipset?  And does the motherboard have a built-in SCSI port?

Can you try the controller in another, not so fast, system?  And are these systems overclocked?

Second to last idea for this post:  Have you unplugged the tape drives from everything, SCSI, Power, everything, and let them sit for an hour or two?  LTO or better drives are clever, sneaky buggers and stuff like that has to settle down for an hour or two sometimes to really forget how to act up, no kidding.

And finally, believe it or not, sometimes the 'latest firmware' is not the best one.  I've had to downgrade my IBM LTO-2 drives in my Dell Powervault Jukebox because the latest firmware, beleive it or not, made them run horribly slow with my system.

Hoping this helps,
Travis
0
Renato Montenegro RusticiIT SpecialistCommented:
I still vote for a firmware issue. Its a common issue. The last firmware isnt always the best. The best firmware is the manufactor(scsi, drive, OS)-supported one.
0
sandy771Author Commented:
Right a lot to do here :)

Workstations are are not major manufacturer

Device mangler is clear

Will check the IRQ's again - they are all on auto and I have tried setting them manually with no difference - I may have missed something though
Video is built in on one of the machines but not on the other -I'll investigate the aperture

The software I am using I have written myself - HOWEVER the tape does not pass hte L&TT Dev Performance test so I know it is not my software (yet !!)
BackupExec is installed but I have stopped the services
Removable storage us not running

Nothing of interest in the event logs

ScriptBlocking service is set to auto and not running

The video in one system is dual head driving two 20" 1600x1200 monitors. Earlier today I disabled one monitor and set the res to 1200x1024 in 16bit colour - it has been left loike this
The other machine has on board graphics

The drivers for sata were pre installed on one machine when delivered
The other machine I installed the via drivers earlier today

The systems are not overclocked and yes I can, and have tried the controllers in slower machines.

Yes they have been unplugged for 1hr+

One of the drives had older firmware in - I upgraded it this morning - it was not performing with the old firmware

Cheers
0
gurutcCommented:
OK!!! I've got something...  Uninstall backup exec to be sure that it's drivers are also gone.  It puts it's own ones on the system.  then in dev mangler(i like that) uninstall the tape drives.  then reboot, with latest manufacturer's drivers at hand, and manually control driver selection to be sure not to use backupheck(i mean exec) drivers.

- travis
0
sandy771Author Commented:
OK will give that a go
0
sandy771Author Commented:
hmmmm. Am trying anyway but the other machine built earlier today does not have BUE installed...
0
gurutcCommented:
Super hmmm

what's hooked up to this box?  mice, kb, net etc?

if hooked to net, unhook and see what happens.

scanned for spyware or virii yet?  try housecall at www.trendmicro.com

just may be something whack like that

- travis
0
gurutcCommented:
also, is your vendor local?  time to call in the 'value add' of the reseller imho

- travis
0
gurutcCommented:
here's another thought.  is the scsi controller in a pci-32 slot?  if so, there may be a timing issue. (at your own risk) stick it in a regular pci slot.  i've done that and it's worked fine even tho half the controller hangs out in space.

- travis
0
sandy771Author Commented:
No sorry that did not work

Going back to my first post the bit that bothers me is the narrow wide warning from L&TT - I have attcahed the portion of the L&TT report here


|__ Device Analysis
    ||__ version: V31.11.2005
    ||__ Firmware rev F5CD is up-to-date for Ultrium 2-SCSI as of Thu Sep 2 19:00:00 2004.
    ||__ Rule 19:
    ||__ The current SCSI configuration is likely to be limiting the performance of the drive.
    ||__ Please check that your HBA is the correct type for the drive and that the cabling is good.
    ||__ The SCSI configuration referenced is the one for which device analysis was run and/or the support ticket was pulled.
    ||__ If this is not via your backup server then you may not have an issue.
    ||__ Current SCSI configuration: narrow   Recommended: wide
    ||__ The drives hardware compression algorithm is currently switched off.
    ||__ This was probably set by the backup software.
    ||__ The drive's setup has not been altered.
    ||__ Current SCSI transfer rate limited to: n/a   Recommended: 160 MB/sec. or better
    ||__ There were 19 rules checked.
    ||__ Device Analysis completed, and warnings have been reported.
0
sandy771Author Commented:
The HBA is the correct type - 29160 is apprrently HP's recommended card

I don't think all three cables are tits up but I have ordered another just in case.

My software would swicth on compression - but even if off I should get a bit closer tothe theorotical uncompressed 108GB/Hr
0
sandy771Author Commented:
I have still not git this working - the latest test was on a shuttle PC with a fresh install of XP Pro, 1 GB memory the only device attached is the LTOII drive and I still get 3MB/s

I have also treid with an AIT3 and get even worse performance

I have looked at the irq's and cant see a problem but I am a little unsure of myself here - any pointers to rule these out would be useful.

This really must be a basic issue given the various combinations of cables(3) SCSI cards (3 I have now got a standard 39160 - all falashed to the latest bios) 4 different PC's

I have checked for virus, spyware trojans etc - the machines are clean

It is not the hard disks as the test tools dont read from them

This has got to be something basic - I am tearing my hair out.
0
sandy771Author Commented:
Just increased to 500 as this is going on too long
0
sandy771Author Commented:
Right more info

I have gone into device mangler and looked ta devices by type and then clicked on irq (didn't know that you could do that)

IRQ 19 is shared by

29160
PCI express root port
SATA RAID controller

In the resources tab the 'use automatic settinsg' is enabled and grayed out

How can I change the irq of the scsi card to something else - or change the irq od the sata raid controller so it deconflicts?

Are there any irq's that I need to avoid?
0
sandy771Author Commented:
easy enough - move the card

problem is it didn't work - tried an AIT 3 drive (with AIT3 tape) and get a measley 6GB/hr about 2MB/s
0
sandy771Author Commented:
Is there any way I can up the points past 500 - this is now a pressing issue.
0
dovidmichelCommented:
Has the data source remained the same, or was that changed when you tried different computers?
0
sandy771Author Commented:
Dovid

The data source is irrelevant I am using either the HP L&TT tape software and my own software

Both of these do not read from a disk but create a single buffer full of data and write te same buffer to the tape over and over - this isolates the disk structure from the test scenario and means that the bottleneck must be driver, controller cable or tape drive.

I have tried three different drives -
2xLTO (with latest firmware)
1xAIT

I have now tried 4 different computers
a dual xeon 2.8GHz with 2GB RAM
a 3.8MHz P4 with 4GB
2x shuttle P4 (1 a P4 3.4 and the other a fast AMD (cant remember spec) computers each with 1 GB ram

I have used 3 different cables - all new

3 different adaptec SCSI cards all flashed to the latest firmware - these cards are recommended by HP for use with their LTO's
36160
29160
29160LP

I have checked the IRQ's for conflicts - there are non

There is nothing else on the SCSI buses therefore the drives do not need terminating (i.e. they use their own active termination)

Removalble storeage service is off
agp aperture is 64

I cannnot understand what is wrong here - anything that could sensibly be the cause has been swapped out.
0
dovidmichelCommented:
ah, how about the terminator, don't laugh I've seen it before and if it has not been tried it is the only thing left I can think of.
0
David_FongCommented:
The drive, controller and cable are wide but it's running in narrow mode? Perhaps that's been set on the adaptec controller, hit <ctrl> A during boot and check.
0
sandy771Author Commented:
terminators are not the prob as mentioned above

have also rechecked controllers - none are in narrow mode
0
mcp_jonCommented:
Hi Sandy,

Just got here, but I'll try not to duplicate tests, and so on . . .

Do you have your workstation fully updated ? and Tapetools ?

Have you ever got higher results with those tapes ? If so, what changed in the meanwhile ?

Checked event viewer for anything unusual ?

Error or Warning Id's ?

Best Regards !
0
Lee W, MVPTechnology and Business Process AdvisorCommented:
Let me just throw this out there - there's a lot already posted and I didn't read through most of it, so I apologize if I'm duplicating someone elses comment in whole or in part.

I had a similar problem with Windows 2000, an SDLT tape library, and Adaptec Controller cards.  We spent a month trying to figure this out and even changed our backup software because we thought (as did a consultant) that the tape drivers provided by the software (ArcServe at the time) were causing our problem.  We installed Veritas Backup Exec and had the same problem.  We changed out the controllers (one Adaptec for another) and had the same problem. so we reinstalled the server and I believe the problem went away (this was about 5 years ago, so memory is a little fuzzy on all the details).  I don't remember exactly how we determined this, but we eventually were all but certain it was the Adaptec Controller's Windows Drivers that caused the problem.  I suggest looking at that.
0
cooleditCommented:
hi, there

I am not sure but you seemed to mention a SCSI card 39160 Adaptec. if you install the 39160 be sure that it does not show up as 39160/3960D while that is the wrong driver.

Should be looking like 39160 ultra 160

Cooledit
0
gurutcCommented:
interested - gurutc
0
sandy771Author Commented:
The question was noty answered - and is still ongoing. I guess I should ask for a refund but would be happy to award half the points to gurutc for the amount of effort he put into helping me try and sort this - is there a way of doing this?
0
sandy771Author Commented:
I say again - The question was noty answered - and is still ongoing. I guess I should ask for a refund but would be happy to award *HALF* the points to gurutc for the amount of effort he put into helping me try and sort this - is there a way of doing this?
0
gurutcCommented:
And... I put in the effort cuz I'm one of those crazy folk who only want to help.  I make my points easily every month.  So your gratitude is plenty of thanks.  Take the Refund.  I'm happy to have helped you in any way I could.  But, if you want us to keep chugging on this one, I'm game.  And if the moderator's cool.  Or you could take the refund, then re-ask the question with the info we already have.  The site mods are pretty diligent about not wanting old unresolved questions.

Your call, but don't fret about me getting points, I want your problem solved.

- gurutc
0
David_FongCommented:
I think the only way you will resolve the problem is to find someone else who has an LTO2 and get them to test yours for you. You've tried everything else except swapping the probably faulty tape drive.
0
sandy771Author Commented:
Thanks Gurutc

David - I have two LTO II's I have the same scenario on both drives... go figure
0
Renato Montenegro RusticiIT SpecialistCommented:
I think there's a few relevant suggestion here, but no direct solution. I would vote for point split:

Me and gurutc
0
Renato Montenegro RusticiIT SpecialistCommented:
I didnt want to mean "few". The right word would be "some". There are some good suggestions from both of us.
0
gurutcCommented:
split cool with me  - gurutc
0
sandy771Author Commented:
Sorry guys but nobody managed to answer the question - the problem still exists and even HP have given up.

If I can't give half of the points to gurutc then I would request that the question is deleted and no points awarded.
0
gurutcCommented:
I'm fine with any resolution.  - gurutc
0
Renato Montenegro RusticiIT SpecialistCommented:
ok with me too.
0
gurutcCommented:
cool with me - gurutc
0
CetusMODCommented:
PAQed with points refunded (500)

CetusMOD
Community Support Moderator
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.