[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3103
  • Last Modified:

After logging into Citrix the connection window opens then closes but nothing else happens

I have one sales guys who can't get inot citrix with his laptop. He can log in from any other PC so I know it's not his account. I can log into Citrix from any other PC (internal or external) so it's not the server. I thought it was the client as I had this happen once before and reinstalling the client cleared it up. SO I have his laptop here and I have reinstalled the client a few times and nothing. I uninstalled it, rebooted, reinstalled, rebooted, then tried again....still nothing.

I'm not sure what to try next. I added citrix to the XP firewall just in case (never had to do that before, but what the heck right?) still nothing..

Is there a way to troubleshoot this? Can I turn on logging on the client?
0
t1clausen
Asked:
t1clausen
1 Solution
 
gsgiCommented:
Well, rdp into the machine, see if that works.
Log in as administrator on the laptop and see if you can log into citrix.
Setup a new user on the machine, maybe the profile is bad.
Clear the terminal server license from the registry, sometimes they get stuck.

Put the ip address of a citrix server in the ica client and see if that works.

Make sure the laptop can resolve local wins, dns ... especially the citrix box and the windows ts license server.

You do not list citrix version, laptop citrix client software being used, and windows server version.

thanks,

gsgi


USNET POST COPIED BELOW


 win2k/ICA
All 2 messages in topic - view as tree
      
From:            Oliver - view profile
Date:            Thurs, Jun 20 2002 5:37 am
Email:             ogal...@descom.es (Oliver)
Groups:             alt.os.citrix
Not yet rated
Rating:       
show options

Reply to Author | Forward | Print | Individual Message | Show original | Report Abuse | Find messages by this author

Hi,
I have installed citrix metaframe version 1.8 on a w2k server with a
base licence with subscription. During the grace period of terminal
server on application mode. I didn't have problem to connect with by
ICA. But after this period I couldn't connect to citrix metaframe ?
Really iI don't understand because my base licence give me the rights
to 15 users ?

Could somebody help me please ?

Thanks
Oliver

      
From:            rallan - view profile
Date:            Sat, Jun 22 2002 12:51 am
Email:             <rallan>
Groups:             alt.os.citrix
Not yet rated
Rating:       
show options

Reply to Author | Forward | Print | Individual Message | Show original | Report Abuse | Find messages by this author

Each client that attached to a W2K terminal server must have a Microsoft
terminal server license in addition to the Citrix licensing. I noticed in
your post you have 15 Citrix licenses but did not state that you had
terminal licenses as well. They run about $75.00 for each client device. W2K
and XP clients do not need this license, it is included with the OS.
If you did buy terminal licenses and you are still having the problem try
this:
Physically Removing the TS CAL
WARNING : If you use Registry Editor incorrectly, you may cause serious
problems that may require you to reinstall your operating system. Microsoft
cannot guarantee that you can solve problems that result from using Registry
Editor incorrectly. Use Registry Editor at your own risk.

If you want to physically remove the TS CAL from the original client device,
you can delete the local registry key containing the license. This ensures
that the client cannot connect to a terminal server in the future without
being issued a new license.

Microsoft recommends that only system administrators who are knowledgeable
about the Windows 2000 registry make this change. Note that deleting this
key only removes the license from the client; it does not remove the
issuance history contained in the Terminal Services License server.

NOTE : LICENSE000 is typically the license for the operating system and the
LICENSE001 is typically the TS CAL. To tell the TS CAL, the ProductID will
be the way to tell the TS CAL verses the operating system.

The line for a TS CAL is:
  ProductID:REG_BINARY: 41 00 30 00 32 00 00 00
The key to be deleted is LICENSE000 or LICENSE00x:
  HKEY_LOCAL_MACHINE\Software\Microsoft\MSLicensing\Store\LICENSE00x
Then, have the clients reconnect.

This problem occurs when a client PC attaches to a Citrix server prior to
any Windows terminal services licenses being installed on the server. Once
the terminal server licenses (cals) are installed on the server perform the
above procedure to wipe out the expired temporary license. The next time the
client logs on their client pc will be issued a new license.

"Oliver" <ogal...@descom.es> wrote in message

news:84894b26.0206200237.48495c61@posting.google.com...

- Hide quoted text -
- Show quoted text -
0
 
Darwinian999Commented:
Is there anything in the eventlog?

I had a similar problem today. It turned out to be an interaction problem between Windows Server 2003 DEP (Data Execution Prevention) and Citrix Latency Reduction (zlc_api.dll). I fixed it by adding Windows Explorer & Task Manager to the list of exceptions for DEP (in the Performance Options in the Advanced section of Properties of My Computer).

http://support.citrix.com/article/CTX107148
0
 
mrwaqarCommented:
I use to have similar problem in a client. Not really sure the reason (could be something to do with terminal servers licensing) It worked by deleting HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSLicensing key from the registry. Though it is harmless to delete this key but I would still suggest you to take a backup of registry before you play with it. Reboot once after deleting the key and see if that solves your problem.
0

Featured Post

Prepare for your VMware VCP6-DCV exam.

Josh Coen and Jason Langer have prepared the latest edition of VCP study guide. Both authors have been working in the IT field for more than a decade, and both hold VMware certifications. This 163-page guide covers all 10 of the exam blueprint sections.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now