Lotus Archive settings "Document Has Been Deleted"


Notes 6.5.4  Windows XP SP2

Out of several hundred people 1 person is having this Archiving problem.
 I did a complete uninstall and reinstall and it fixed it for a few days now it is doing it again, what is he doing to it?

The Problem:  Archive File folder is where it should be    (C:\lotus\notes\data\archive)

If I click on the archive file it self, it will open notes and open the archive. But if I try to open it from within notes it doesn't even see the Archive.

Then if I go to  Actions>Archive>Settings>  (as if I was going to enable archiving) it throws up the following error   "Document Has Heen Deleted"

What could be the problem?

dalettcoAsked:
Who is Participating?
 
dalettcoAuthor Commented:
OK,  I blew it all away, deleted the subfolders out of the program files and reinstalled.

It let me set up the Archive folder but would not let me access it.

Then it started doing the "Document Has been Deleted" thing  again.

So I removed it again, deleted all the folders , and cleaned the registry of all "Lotus" entries and rebooted.

Then I reinstalled it fresh.

It is now working like it should.  Thanks guys for all of your help!

I guess sometimes you just have to whip out the regedit !!!!!
0
 
SysExpertCommented:
That is strange.
WHat hapens if yo try the File open option ?

As long as the Icon apears on the desktop r bookmark, it should work.

I hope this helps !
0
 
dalettcoAuthor Commented:
Not sure I follow you with the File Open Option.

There is no option to open a file (under the file option)
0
Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

 
marilyngCommented:
Hi dalettco,
> "Document Has Heen Deleted"

Means the archive profile has been deleted, or has a different name than the user name who originally saved it.

If an archive database exists, try this first but use a different archive database name (just in case Notes wants to recreate the database of the same name with no documents in it.)

With the mail file open, select Actions>>Archive>>Settings.

This will open the Archive Profile, enter a new database name, you can use the archive path, and log file name.  Press OK, then check to be sure that Notes created the new archive.  Test by selecting ONE document to archive manually.  And then verify that the document was copied and then deleted from the Notes DAtabase.

If you haven't refreshed the design of the user's mail file, you might want to either refresh or replace the design before you embark on the solution.

Regards!
0
 
SysExpertCommented:
From the workspace choose - File-database-open. Navigate to the exisiting archive and open it.

0
 
marilyngCommented:
I believe SysExpert is still responding to the part of your question: File Open Option,   and that will confirm that you do have an archive database, and will put the icon on the workspace, or a bookmark in your bookmark folders.


>> Actions>Archive>Settings>  (as if I was going to enable archiving) it throws up the following error   "Document Has Heen Deleted"<<  means the archive profile is missing or deleted in the mailfile, doesn't it?  

If you are unable to open and configure the Archive Settings.. then try compacting the database, then replace the design.  



0
 
dalettcoAuthor Commented:
  When I do this >> (With the mail file open, select Actions>>Archive>>Settings.)
         
                 It gives me the "Docunment Has been Deleted" error


   When I do this>>( From the workspace choose - File-database-open)

                  It says that Archiving is not set in the policy.


So it has to be a setting in his profile right? This will have to be fixed within Lotus Admin and not his client?

Thanks
0
 
marilyngCommented:
Try running an agent to delete the archive profile in the mail database.  

Go to Create>>Agent
Give it a Name: Delete Archive Profile
Set Target to NONE
Set it to Shared
Change the Run to LotusScript

Paste this into the Intialize section:

'Sub Initialize
Dim session As New NotesSession
Dim db As NotesDatabase
Set db = session.CurrentDatabase
Dim profile As NotesDocument
Set profile=db.GetProfileDocument("Archive Profile")
Call profile.remove(True)
msgbox "Archive Profile Removed"
'End Sub

Also change the Properties (second tab) to #2- allow restricted operations.

Save and Close the agent, and return to the inbox.

Now select the agent from the Actions menu,  Actions>>Delete Archive Profile

The messagebox will appear.

Now try Archive>>Settings and see if you can configure the settings.

Solution from:  http://www-1.ibm.com/support/docview.wss?rs=0&q1=document+has+been+deleted&q2=archive&uid=swg21090347&loc=en_US&cs=utf-8&cc=us&lang=en
0
 
dalettcoAuthor Commented:
Will try it Monday 04/3/2006 thanks!
0
 
dalettcoAuthor Commented:
Ok I tried it,

 It gave me the MSGBOX "Archive Profile Has Been Deleted"

But when I go to  Archive>>Settings

It still says "Document Has been Deleted" .

0
 
marilyngCommented:
Sheesh!  

Let's see, did you:  Compact the mail file on the server and on local.
Is the archive agent running on the server or on local?
Did you replace the design of the server mail file and then replicate with the local?
Is the mail file FT indexed either on the server or on local?

Is there a local copy?  If not, throw a new local replica, compact that, then try to archive from the local copy.

If there is a local copy and you've been using the local copy, then move the local replica out of the Notes Data directory, or do File>>Database>>New Copy and name it mailfilebu.nsf.

Then delete the local replica and throw a new local replica.
Try the archive from that new replica.
0
 
marilyngCommented:
My goodness!  So sorry you had to go through all of that.  It would seem the uninstall didn't really uninstall everything.  I had that happen with a migration from 4.6 to 5.  Glad you got it solved.

You can request a refund of your points by posting a note in customer service.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.