• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 464
  • Last Modified:

changing perrmissions on public folders?

I have about 25 public folders under the root public folder and many dozens folders under those.  They consist of contacts, folders and calendars.  Is there a way i can set a standard permission policy to ttrickle to all of the child folders?  Otherwise i have to go into everyone to set the client permissions and there are hundreds.

thanks.
0
YankeeFan03
Asked:
YankeeFan03
  • 5
  • 2
  • 2
  • +3
1 Solution
 
Will SzymkowskiSenior Solution ArchitectCommented:
When you apply the permissions to the "Parent" folder the "Child" foler inherits the permissions. If you want to have someone beable to access the parent folder and only some child folders you can also set this up.

hope this helps
0
 
ChabneyCommented:
What OS are you running?  Windows?  Linux?

Spec01 is right on the money if you're running Windows.  You can set the permissions at the parent level and then choose to have them "trickle down", as you say.  If you're wanting to change the permissions on existing folers, then just be sure to go into the [Advanced] button on the Security tab.  From there you can set the level of "trickling" that you want to occur......"This folder only", "Subfolders and files", etc....  (Also note the "Replace permissions...." checkbox on the Advanced screen.  You'll use this when you want to override permissions that were already set on child objects.  Just be cautious that you don't overwrite permissions that you didn't intend to!)

Good luck!
0
 
YankeeFan03Author Commented:
i am using windows.  I have set the permissions at the root folders through ESm but i do not see any option under client permissions to apply to child objects.

0
Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

 
YankeeFan03Author Commented:
also, when i try to add a group or member to the client permissions i get a "the operation failed" ID no. 80004005.
I am the owner on all of the public folders.
0
 
ChabneyCommented:
Ahah!  Just realized that you're talking about objects within an Exchange structure.  I'll have to plead ignorance here, as I'm definitely not an Exchange expert (and don't have a system in front of me to do any testing.)

BTW, you may get a faster response if you get the mods to move this question to the "Apps" area, as I'm guessing that there are more Exchange guru's in there.  Just a thought. :-)
0
 
YankeeFan03Author Commented:
my mistake
I found out that the error was from me trying to add a DL group not a security group.  I need to find out how i can add a security group to public folders.
0
 
MIMIS_ISCommented:
Yankee,

Did you try to Create A Global Distribution Group (You Can Prevent People From Using it to Send Mail) - Add Members you want to have Access to the Public Folder, then under Client Permissions of the Public Folder - Add the Distribution Group.

D>
0
 
Dushan De SilvaTechnology ArchitectCommented:
use "chmod" with -r

example : chmod 777 /root/ -r

BR Dushan
0
 
Walter PadrónCommented:
Best Practices for Public Folders
http://www.microsoft.com/technet/prodtechnol/exchange/2003/pubfoldersbp.mspx

quoted from Microsoft
"Now, let's assume you are the person who's in charge of rolling out public folders at a huge corporation. Or maybe you're the person who just has to maintain an existing public folder infrastructure. And you need some help. Who at Microsoft would be best suited to help you in make sure that your Exchange Server public folder deployment is sound?"
0
 
YankeeFan03Author Commented:
MIMIS, i did that and it worked through Outlook.  I was trying to add permissions before through ESM.  I guess you have to use outlook.  One last questions.  Is there a way to push the permission down to the child objects.  I have a Contacts folder with about 100 other contacts under it.  I would hate to have to do them individually.
0
 
MIMIS_ISCommented:
Did you actually create the Group and add the group to the Top-Level Public Folder through ESM?

Once you add the group under client permissions (IN ESM) to the TOP Level Folder and set the attributes Follow these steps:

In Exchange System Manager
Right-click the top-level public folder again and click All Tasks
Then Select Manage Settings
When the Wizard Starts - Select Client Permissions
Here you can modify, add, delete and most of all propogate down to all Sub Folders with your Group(s) you created.

I wasn't sure based on your question, but I hope this is the answer your looking for.

D>
0
 
YankeeFan03Author Commented:
thank you sooo much, ecactly what i was looking for.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

  • 5
  • 2
  • 2
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now