We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you a podcast all about Citrix Workspace, moving to the cloud, and analytics & intelligence. Episode 2 coming soon!Listen Now

x

No letter for HD

raymm
raymm asked
on
Medium Priority
538 Views
Last Modified: 2011-10-03
http://img51.imageshack.us/img51/8879/hdnoletter8jv.png

See Disk 1 186.3 in picture.  No letter for drive, doesn't show up in Explorer.  Right click options = convert to Dynamic Disk, Properties.  Nothing unusual under Properties.

What can I do to get letter for Disk 1, and to be able to see Disk 1 in Explorer?
Comment
Watch Question

Commented:
Hi raymm,

  If you right click on the Disk 1 - on the left side, you'll only get the options you mentioned (convert and properties)
  Instead, right click on the word DATA (or anywhere in the box under the blue line in your image for that partition)
  Then you'll see a nice menu that says 'change drive letter and paths'
  from there you can do what you need to.

- Jack
CERTIFIED EXPERT
Top Expert 2012

Commented:
The option to format it under the right-click options is all you need to make it visible to Explorer.  It's a big disk, so formatting will take some time.

Author

Commented:
But formatting the HD will erase the data I have on it, right?
CERTIFIED EXPERT
Top Expert 2012

Commented:
Yes.  So you haven't told us everything about this hard drive, such as was it a new drive or a drive from another machine, how was it formatted and with what OS?

Commented:
Callandor,

The screen shot clearly shows the drive in question is already formatted to NTFS. formatting it would wipe out all his data. We don't have enough info from raymm to determine if this is a new drive or one being moved from another system.


Commented:
posts crossed, I ws typing my reply before raymm posted his.

Sorry, didn't mean to come off argumentative....

Raymm, please comment if my original post has given you what you needed.
Gary CaseRetired
CERTIFIED EXPERT
Most Valuable Expert 2013
Top Expert 2009

Commented:
fruhj's first post will ALMOST do the trick :-)

First, however, in My Computer right-click on your D: drive and choose "Rename".   Give it a different name -- perhaps "Data 1".   XP will not work well with two volumes that have identical names (at the moment you have named both the 2nd partition on Disk 0 and the only partition on Disk 1 with the same name -- "Data").

AFTER you do that, just do as suggested earlier -- go to Disk Management; right-click from within the "Data" partition display; and assign a drive letter.   You might want to then rename that partition to "Data 2" just for consistency.

Commented:
WOW Gary,

  Great Catch! I totally missed that!

  - Jack
my xp system works great with my configuration:
SeagateA920 C:
SeagateA950 D:
were the default names of the drives (never really had a reason to change it).

Two separate drives both formatted to NTFS (not just a partitioned single drive).  Either way, just thought to throw out my two cents.

Niklaus.

Author

Commented:
Instead, right click on the word DATA (or anywhere in the box under the blue line in your image for that partition)
  Then you'll see a nice menu that says 'change drive letter and paths'
  from there you can do what you need to.

No, that option is greyed out.  What to do?

Author

Commented:
Only allows "Delete Partition" and help.

Author

Commented:
Drive formatted by Win XP Pro, has data on it, (10% free).
Retired
CERTIFIED EXPERT
Most Valuable Expert 2013
Top Expert 2009
Commented:
Did you rename your current D: drive?   You MAY have to remove the 2nd drive before doing this.   As I noted earlier, having two identical volumes in XP can cause problems => it some cases it can cause corruption of BOTH volumes.

The safest thing to do here is:  (a)  shut down the system and disconnect your 2nd drive (Drive 1);  (b)  boot up and do what I suggested earlier -- r.e. rename the 2nd partition on Drive 0 (your current D: drive); and then (c)  shut down, reconnect the 2nd drive, and boot back up.   Now you should be offered an "Assign Drive Letter" option when you right-click on it in Disk Management.

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts
Gary CaseRetired
CERTIFIED EXPERT
Most Valuable Expert 2013
Top Expert 2009

Commented:
raymm -- Did you get this resolved?   It should have been a simple case of renaming the current D: volume; then assigning a drive letter for the other drive.   (ideally removing the 2nd drive, as I noted above)   Very simple to do -- just curious if you have any further questions or if it's done.

Commented:
Just for reference,

here's what menu We're talking about, and please note where on the screen I was when I right clicked

http://img347.imageshack.us/img347/7647/image15yd.jpg
Quick Question what Operating System are you trying to install this in.  If it's 2000 then XP uses a later version of NTFS and 2000 will not be able to access it and you would have to move all your data off, delete the partition and reformat as NTFS under 2000.
Gary CaseRetired
CERTIFIED EXPERT
Most Valuable Expert 2013
Top Expert 2009

Commented:
raymm -- did you fix this??   As I noted before, your key issue was having two identically named volumes.   If you simply physically removed the 2nd drive; then renamed the 2nd partition of the 1st drive; and then re-installed the 2nd drive you should have easily been able to assign a drive letter to it.   Did you try this??
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.