?
Solved

File extension does not run

Posted on 2006-03-31
4
Medium Priority
?
2,475 Views
Last Modified: 2008-02-26
Hello,

I have a Windows Server running 2003 standard. I'm using Webex's recordings files with extension .wrf.

I have a web page that has links to these recordings. When I test the page by allowing the contents to be browsed, the files with the .wrf extensions to not initaite a popup which asks whether I want to save or open the file. This would help since it would tell me the file is recognized in some way. When I click the file, it generates a "Page Not Found" error.

How can I edit permissions to allow this file to run? All pewrmissions are set as well as script/executable but still the same problem.

I tested it on another server running 2000 Advanced and it does give the open/save popup when I test the same page.

Thanks.
0
Comment
Question by:rorlini
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 15

Expert Comment

by:Tray896
ID: 16344397
You need to add .wrf under the allowed web service extensions within IIS.  


# Open the Internet Services Manager found in Control Panel /Administrative Tools
# Open the local computer branch and go to Web Service Extensions
# Select Add a new Web service extension
# For the Extension name type in WRF
# Hit the Add button
# Hit the Browse button and find the path to your .wrf files
# Enable the checkbox for Set extension status to Allowed and hit OK
0
 

Author Comment

by:rorlini
ID: 16344885
Thanks for the quick reply.

I'm using Win 2003 server and I don't see the options you are referring to when I right-click on the local computer branch in IIS 6.0. It displays MIME types I can add. Is that it?
0
 
LVL 15

Expert Comment

by:Tray896
ID: 16345086
Sorry, that may be worded confusingly.  You need to expand the local computer in IIS, you should see a folder that a web services extensions folder at the bottom.  It will look similar to this image:


http://phydiux.com/cfmx_and_IIS6/IIS60%5Cweb-service-extensions-post.jpg
0
 
LVL 34

Accepted Solution

by:
Dave_Dietz earned 2000 total points
ID: 16348071
Actually from the description of what you want you will need to set a MIME type for the wrf extension. Simply set wrf to application/octet-stream and you should get the behavior you are looking for.

If you were using an ISAPI extension to process the file and send a request you would need to add the ISAPI dll tothe Web Service Extensions list.

By default IIS 6 will not serve any file that does not have a MIME type set.

Dave Dietz
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Running classic asp applications under Windows Server 2008 R2 (x64) and IIS 7 is not as easy as one may think. It took me a while to figure it out while getting error 8002801d a few times. After you install the OS you will need to install the fol…
A phishing scam that claims a recipient’s credit card details have been “suspended” is the latest trend in spoof emails.
NetCrunch network monitor is a highly extensive platform for network monitoring and alert generation. In this video you'll see a live demo of NetCrunch with most notable features explained in a walk-through manner. You'll also get to know the philos…
Add bar graphs to Access queries using Unicode block characters. Graphs appear on every record in the color you want. Give life to numbers. Hopes this gives you ideas on visualizing your data in new ways ~ Create a calculated field in a query: …
Suggested Courses

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question