• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 251
  • Last Modified:

XP Pro Firewall disabling File sharing capability

Hi!
Getting kind of crazy here.
My network is made of 1 desktop PC (XP Pro SP2), one wireless notebook (Windows Tablet PC SP2), one Xbox, one Xbox 360 and one Squeezebox 2 (Slimdevices music streaming device).

The desktop connects to the internet through a small hub on a residential network (fiber optics cabling throughout the city, Milan, ISP is Fastweb if somebody is familiar with it). The hub provides DHCP and assigns IP in the 1.39.ABC.xxx range. At the same hub I connect a Wi-Fi Access Point, and the Tablet PC gets its IP from the hub too, always in the 1.39.ABC.xxx range (I put ABC for privacy reasons, it's a regular number).

Xbox, Xbox360 and Squeezebox connect to the network through a shared Internet connection. The desktop PC has two network adapters and the second one is used to create a local network in the 192.168.0.xxx range. All three devices connect to the internet without any problem, even with the XP Firewall activated, nothing wrong with the 192.168.0.xxx network for what I need.

The problem arises because, although I have the exception set for File Sharing, as soon as I activate the XP Firewall on Ethernet card #1, the Tablet PC can't see the shared folders on the desktop PC.

Both machines are on the same workgroup, the Tablet PC can ping regularly the desktop (with the firewall activated too), it can even use Remote Desktop on it. But no shared folders. If I open the workgroup I see the desktop machine, but if I double click on it, I get the message "COMPUTER is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions. The network path was not found."

I've given full permissions to EVERYONE on the folder I'm trying to share.

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa] sets everyoneincludesanonymous to 1. restrictanonymous is set to 0.

Without the firewall on Ethernet card #1, file sharing works fine.
0
gorman70
Asked:
gorman70
  • 7
  • 6
  • 2
1 Solution
 
EricIT ManagerCommented:
Go to Control panel | Windows firewall | Exceptions
Check File and Printer Sharing
check the General tab and uncheck Don't allow exceptions
0
 
gorman70Author Commented:
Nope, everything is already setup that way.
0
 
EricIT ManagerCommented:
do you have another firewall? norton internet security, mcafee, zone alarm..
they can fight with eachother...
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
Jay_Jay70Commented:
Hi gorman70,

if you have simple file sharing enabled, disable it   windows explorer - tools - folder options - view

make sure enable simple file sharing is not ticked

Cheers!
0
 
gorman70Author Commented:
No other firewall. Simple file sharing is disabled.If you read my original question I mention giving permissions to the Everyone user, you cant do that with simple file sharing.
0
 
Jay_Jay70Commented:
fair call   i work in domains so am a slightly out of practice with the intricasies of work groups..

you have matching accounts on each machine?
0
 
gorman70Author Commented:
No. And I need two different accounts. But I tried with identical user name and password... things didn't change anyway.
0
 
Jay_Jay70Commented:
you still need an identical account on the other machine for authentication.... dont have to use it but it has to exist
0
 
gorman70Author Commented:
Sorry but... when I disable the firewall I can access the shared folder with no problem, with no identical user onthe tablet PC.
0
 
Jay_Jay70Commented:
hmm i see

i havent dealt with tablet PC's is there much difference in their networking stucture   as in you have allowed F & P sharing through    but does the tablet use a diff protocol or is it the same as standard windows
0
 
gorman70Author Commented:
totally identical AFAIK
0
 
Jay_Jay70Commented:
hmm thats what im reading also

http://support.microsoft.com/kb/298804

does this help at all      kind of poking at straws here!
0
 
gorman70Author Commented:
Nope... I might add that in the past, on the same machine, I had the nVidia Firewall going. Then I uninstalled it because it was constantly crashing. Nothing should have remained but, maybe, somebody knowledgeable enough could recognize this as a tell-tale of something else...
0
 
gorman70Author Commented:
Found the answer... I might say by myself... but Jay Jay has actually pointed me to the Knowledge base article from where I linked and linked and linked to other articles, and finally came to the answer by trial and errors. I'll give the answer to you Jay, thanks for being here. :)

For anybody interested... I needed to change the scope of the File and Printer Sharing exception (which was set to Subnet) to allow for the specific IP range that the tablet PC gets assigned usually. Note that the Tablet PC has got the exception set to Subnet and can share properly. I guess having two network adapters on the same machine made the desktop PC consider the Subnet as the one on Ethernet adapter #2, in the 192.168.0.xxx range. I hope this can help somebody in the future. :)
0
 
Jay_Jay70Commented:
good stuff my friend well done

thankyou for the points but i think you deserve the credit here

all the best mate
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 7
  • 6
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now