• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 444
  • Last Modified:

VPN through Cisco 501 Pix firewall - Help please

I am trying to configure my Pix firewall to allow Standard PPTP VPN traffic to the internal network.  
Here is my config file.  IP address have been starred out for security purposes.

Result of firewall command: "show config"

Any ideas?

 
: Saved
: Written by enable_15 at 13:10:27.051 UTC Fri Mar 31 2006
PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 6.zG4UTOgxjrZ6Lj encrypted
passwd 9.3cC3Lq/yHiv1EY encrypted
hostname GSP
domain-name GSP
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 101 permit ip any any
access-list 100 permit tcp any host ***.***.***.*** eq smtp
access-list 100 permit tcp any host ***.***.***.*** eq ftp
access-list 100 permit tcp any host ***.***.***.*** eq pop3
access-list 100 permit tcp any host ***.***.***.*** eq https
access-list 100 permit tcp any host ***.***.***.*** eq domain
access-list 100 permit tcp any host ***.***.***.*** eq 3389
access-list 100 permit tcp any host ***.***.***.*** eq www
access-list 100 permit tcp any any eq www
access-list inside_outbound_nat0_acl permit ip any ***.***.***.*** 255.255.255.192
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside ***.***.***.*** 255.255.255.240
ip address inside ***.***.***.*** 255.0.0.0
ip audit info action alarm
ip audit attack action alarm
ip local pool vpnusers ***.***.***.***-***.***.***.***
pdm location ***.***.***.*** 255.255.255.255 inside
pdm location ***.***.***.*** 255.255.255.255 inside
pdm location ***.***.***.*** 255.255.255.0 inside
pdm location ***.***.***.*** 255.255.255.0 outside
pdm location ***.***.***.*** 255.255.255.192 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 ***.***.***.***
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) ***.***.***.*** ***.***.***.*** netmask 255.255.255.255 0 0
access-group 100 in interface outside
route outside 0.0.0.0 0.0.0.0 ***.***.***.*** 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http ***.***.***.*** 255.255.255.0 inside
http ***.***.***.*** 255.0.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-pptp
telnet ***.***.***.*** 255.255.255.0 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh ***.***.***.*** 255.255.255.0 outside
ssh ***.***.***.*** 255.0.0.0 inside
ssh timeout 5
console timeout 0
vpdn group PPTP-VPDN-GROUP accept dialin pptp
vpdn group PPTP-VPDN-GROUP ppp authentication mschap
vpdn group PPTP-VPDN-GROUP ppp encryption mppe auto required
vpdn group PPTP-VPDN-GROUP client configuration address local vpnusers
vpdn group PPTP-VPDN-GROUP client configuration dns ***.***.***.*** ***.***.***.***
vpdn group PPTP-VPDN-GROUP pptp echo 60
vpdn group PPTP-VPDN-GROUP client authentication local
vpdn username ****** password ********
vpdn enable outside
terminal width 80
Cryptochecksum:e84158c9c504dddad15bdad2107c4190

0
paulmmalone
Asked:
paulmmalone
  • 2
  • 2
3 Solutions
 
JoesmailCommented:
Your configuration looks ok.  It might be better to add ip addresses (not real addresses)...

access-list inside_outbound_nat0_acl permit ip any ***.***.***.*** 255.255.255.192
*This access list should be more controlled. e.g. the exact internal traffic allowed to the pptp clients.
Try somthing like:
acess-list inside_outbound_nat0_acl permit ip 10.99.99.0 255.255.255.0 ***.***.***.*** 255.255.255.192

ip local pool vpnusers ***.***.***.***-***.***.***.*** (I assume this is the pool above in the access-list...you might want to add ip addresses....example ones.)


You might also want to debug the tunnel events when clients connect....
debug vpdn events

0
 
nodiscoCommented:
Hey there
Can you post the ip local pool, inside ip address and inside_outbound_nat0 access-list details - these will be private ip so don't need to be masked.  
What is the exact problem - are you connecting via pptp but not able to contact inside hosts?  Or are you not connecting at all?

hth
0
 
paulmmaloneAuthor Commented:
I trying to setup VPN and I know very very little about cisco firewalls and routers.

My DSL comes in through a bridge modem, then to a Cisco Router, then to my firewall which is connected to my 16 port switch.

What does this line in the config file mean?
....  nameif ethernet0 outside security0 ....

Does that mean that it is blocking everything from coming in?

I can deduce that ethernet port 1 has the "access list 100" applied to it from this line
... nameif ethernet1 inside security100....     right?

Thanks for any help.  
0
 
nodiscoCommented:
<<What does this line in the config file mean?
....  nameif ethernet0 outside security0 ....

nameif is the command for naming the ethernet interface and setting its security level.  On a 501 you just have ethernet0 and ethernet1 - which are ouside and inside respectively.  Their security levels are 0 and 100 respectively and these cannot be changed.  From PIX 515 up you have extra interfaces which you can name and give different security levels between 1-99

PIX uses ASA to determine how traffic flows.  Traffic from a high security level (e.g. inside 100) can flow out a less secure one (e.g. outside 0) but not the other way around.  Unless, you specify a static translation and relevant access list.
Your static and access-list 100 applied to the outside interface are allowing certain protocols through - pop3, smtp, www etc


<<I can deduce that ethernet port 1 has the "access list 100" applied to it from this line
... nameif ethernet1 inside security100....     right?

No.  This is just coincidental - an access-list can have any name applied to it to describe it - your access-list is named 100 - which is causing you the confusion.  Common access-list names would be fromoutside or access_in etc

Access-list 100 is applied to your outside interface in the line:

access-group 100 in interface outside
This is telling the pix to use the access-list with the name matching "100" and apply it to all traffic coming in to the outside interface.

hope this helps explain
0
 
paulmmaloneAuthor Commented:
Still can't get VPN to work this sucks.
I am starting a new question.
Thanks for the responses.
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now