SONY VAIO Brightness control

Hello Friends,

I have a SONY PCG-FRV26 which came with Windows XP Home. This was about 2 year ago. I have now installed Windows XP Pro and therefore had to re-install all the drivers. The drivers are working fine except for the FN key functionality. I had installed the HotServ.exe (from ftp://ftp.vaio-link.com/pub/Vaio/Hotkey/) but it does not do anything. So I am not able to control the brightness of my machine.

My questions are:
1) How do I get the FN key functioning? I do not want to install the VAIO recovery wizard as I do not wan XP Home.
2) Is there a different way to control the brightness other than the FN key?

Thanks
srinivas_vemlaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

nobusCommented:
one way is to install it with recovery wizard, then an upgrade to XP pro
btw, i did not find your exact model
0
Jay_Jay70Commented:
sony dont provide efficient tools for a clean install    i have seen this numerous times with different models        funny that a clean install and their magic util still doesnt work...... i would go with Nobus Idea and use the recov disks        just wait for the fun with sony laptops!! I've had three sent back and two that need to be but are out of warranty..... needless to say they should stick with Sound Systems :)!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
srinivas_vemlaAuthor Commented:
Well, I finally got one Customer Service agent who was knowledgeable enough of the issue. The issue is that the "Shared Library" (http://esupport.sony.com/perl/swu-download.pl?mdl=PCGFRV26&upd_id=1325&os_id=7) should be installed before the HotKey Utility (ftp://ftp.vaio-link.com/pub/Vaio/Hotkey/SonyUtils_Hotkey_10_ITA.zip). This fixed my issue.

Thanks for your comments JJ and nobus.

Thanks
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Laptops Notebooks

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.