[Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1477
  • Last Modified:

Remote printing through Remote Desktop doesnt work

I have a situation using XP's Remote Desktop to my wifes work machine over a simple VPN connection.

First off, I had issues getting her work machine to even see the attached USB printer (Lexmark X73) and a network printer that is attached to my server (HP Officejet 5600). I got the standard 1111 event error when connecting to her work machine about not having a driver locally. Well, Printer drivers now adays are not like they used to be. If I want to install a driver, I have to download a 50+ MB package and install EVERYTHING, and then the computer expects to see the printer hooked up directly to the work machine when I install the driver, which it is not of course. and then the installation of the driver fails.

I tried to copy the subfolders in the her windows/system32/spool/drivers/w32x86 folder to the work machine and try to fool it into thinking it had the drivers. I spent like 4 hours messing with this and looking all over the Internet for a solution. I then found this tool from microsoft to assign a mini-port driver to all unknown printers that initiate the 1111 event errors. It is called Terminal Server Printer Driver Redirection Wizard. I used this on her work machine and pointed the Lexmark X73 to a lexmark driver that she already had installed on that machine. I pointed the HP Officejet 5600 to another Officejet driver that was installed already. I then rebooted the work machine and connected back to her work machine, this time all the printers showed up like they were supposed to. The default Printer on the work machine  (Officejet 5600) changed to her default printer on the local machine and then the Lexmark also showed up as a printer. The issue now is that nothing will print to either printers while using the RDP session. I can print directly to each printer from her machine just fine when I close the RDP window and go back to her local machine. I have tried to print to both printers and nothing prints from the session. I can open the print queue and see the job print and then disappear. No errors. I know for a fact that the RDP printing works because I can RDP to my server from her very same machine and then print to the same two printers redirected through the RDP session. The only issue is when I connect to her work via a normal VPN connection, using the built-in MS VPN connection. I can transfer files from her work machine to the local machine fine, just no printing.

I turned off the XP firewall on the local client, even though I know that it couldnt be that, or I would not have connected in the first place using RDP.

I have done all I can to figure this out, anyone that has any suggestions, I would appreciate it.

Just copying files from one machine to the other and then printing them is not a fix either, she needs to print directly from applications she is using on that work machine.
0
Robguad
Asked:
Robguad
1 Solution
 
FermionCommented:
My take:

Load ALL drivers in the remote computer.
Enable File and Print sharing on BOTH computers.
The firewalls on both machines must be configured to allow this access.
0
 
Rob WilliamsCommented:
Are the printers physically attached to the local (home) machine ? If not the problem may be with the VPN connection itself. Local networking will not work when connected through the VPN tunnel. this is a security feature. To remedy this, open the properties of the Virtual adapter on the local machine, choose the networking tab, TCP/IP properties, advanced, general tab and uncheck "use default gateway on remote network".

As for the drivers, simplest way to install them on the computer you are connecting to (office end) is open the printers window and on the menu bar choose file, server properties, drivers, add, and then point to the .inf file located in your expanded driver folder.

At best printing to many USB printers over a RD session can be a little flaky. It is supposed to improve with the new Vista O/S.
0
 
Lee W, MVPTechnology and Business Process AdvisorCommented:
Download the driver file and extract the setup program and subsequent files.  I had a similar problem with an HP printer just yesterday and rather than running the setup program, I just used the Add Printer wizard and browsed through the extracted files until I found the inf files with the driver info - then I installed that and all was fine.  (Don't use the printer driver's setup program).
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
RobguadAuthor Commented:
The officejet at home is not attached to her machine, it is a network printer. The Lexmark is. Like i said, I have RDP'd to two other machines on my network here from here machine and it works fine. It is just when I go over the VPN connection, it does not work.

I tried both checked and unchecked already - "use default gateway on remote network"

I tried to find the inf for the officejet in the installation files, I did a search. None of the Inf files shows the 5600 in the list at all. I DL the package straight from HP as well. Same thing.
0
 
Rob WilliamsCommented:
Didn't realize HP was multi-function. They can be even more difficult with RD sessions. Afraid I have no more to offer, other than following link is often helpful with non-standard printers/ports and terminal services/remote desktop sessions:
http://support.microsoft.com/?kbid=302361
0
 
RobguadAuthor Commented:
I saw that article thanks. This printer uses a standard USB port so this wouldnt apply.
0
 
RobguadAuthor Commented:
I went and bought a new printer for my wifes machine, officeJet 5900. I set that up on here machine and used the article that RobWill had sited. This worked. I still cannot get the other two printers to work. But I have a configuration that will work for her. thanks for the help.
0
 
Rob WilliamsCommented:
Thanks Robguad.
Hang in there for Vista. It may resolve a lot of these issues. I do find the old basic LPT1 HP laser printers seem to work the best, or at least with the least difficulty, with RD. Probably due to the fact that the drivers are native to Windows O/S's
0

Featured Post

Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now