Fatal Error when editing code in compiler

I currently get fatal errors that cause IDE to shut down when browsing and or editing code in Delphi editor. Two weeks ago I did my first debugging session and assume I may have not converted all settings correctly after finsihing debug mode. Another symptom of this complication is the size of the file when I do get it to compile. It is roughly three times the size of file before I changed the settings. I have gone through every setting I had in my notes to shift to debug mode but now can't get back. what are the specific setting I should check to get back to editor/compiler?

Newbie needs help. Stuck between debug mode and clean editor/compiler mode.
proddevAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

BlackTigerXCommented:
you're not using Delphi 8 or 2005 are you?

those 2 versions (specially 8) were very buggy
Mark BradyPrincipal Data EngineerCommented:
If your ee is to large maybe look at the toolbar up top and go to Project/Options then click on the 'packages' tab.  Make sure the option 'Build with runtime packages' is Unchecked.  also once this is unchecked, check the box at the bottom 'default'
now all projects will use this info.  What version of delphi are you using ?

Hope this helps a little.

Elvin
proddevAuthor Commented:
I am using Delphi 2005. I will try this suggestion thx.
Exploring SQL Server 2016: Fundamentals

Learn the fundamentals of Microsoft SQL Server, a relational database management system that stores and retrieves data when requested by other software applications.

proddevAuthor Commented:
elvin6,

'Build with runtime packages'  unchecked already and default is checked correctly. This did not fix my problem. If you have any other suggestions would be great. If not may just do reinstall of ide. Getting a clean install again may help as a last resort.
BlackTigerXCommented:
make sure you get the official as well as the non-official updates

http://blogs.borland.com/abauer/archive/2005/09/13/21124.aspx
Mark BradyPrincipal Data EngineerCommented:
I use 2oo5 to.  ok if you end up dooing a reinstall make sure you do an uninstall first.  then after it is done, please check your registry (search) for any delphi keys in case it points to an ini file somewhere on your pc.  A new install may find an old ini file anjd use it's settings by default so best get rid of everything except of course your projects (move them to a different directory ok.

Regards
Elvin

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
proddevAuthor Commented:
Thanks for the newbie help Elvin...greatly appreciated.

Regards
Mark BradyPrincipal Data EngineerCommented:
you're most welcome proddev :)
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Delphi

From novice to tech pro — start learning today.