We help IT Professionals succeed at work.

Novell Client 4.91 doesnt connect to the NDS tree over the wireless only for IBM T42 laptop

deepup asked
Medium Priority
Last Modified: 2008-01-09

We here have a Novell  Netware network (edirectory 8). One problem we are not able to understand is that when a domain user logs on to the network using an IBM T42 with Novell Client 4.91 and Windows XP SP2 using inbuilt wireless NIC (Intel PRO/Wireless 2915\ABG Network Card) the user doesnt get the NDS tree through the wireless if he uses the inbuilt WLAN NIC. But instead if he uses an external WLAN card there seems to be no problem. I am, infact we are really concerned because we will be going full wireless in the near future.

I would also like to inform that I have unistalled and installed the new drivers for the WLAN card using the Lenovo software installer and has the latest drivers as of MArch 3 2006. Can anyone please advice.

Watch Question


The Novell client does NOT include a wireless supplicant.  It does integrate with commercial wireless supplicants, though, like Aegis from Meetinghouse and Odyssey from Funk.  If you want the Novell GINA to be primary, you need to buy one of those supplicants.

If you don't want to spring for the 40-50 bucks for a wireless supplicant, you'll have to make the Novell login secondary, which means you won't have some features of ZEN available (if you use ZEN) and you have to set the client to send login event on each login so Workstation Manager can see a login event occurred.


actually I didnt understand what you said. I am a bit new to the novell environment. anyway in layman's language I would like to ask that why does the Novell tree be available in case of an external wireless card and not available with an in built IBM wireless NIC. and the other thing we noticed was that the tree is available with the inbuilt card if we let the Windows manage the wireless networks rather than use an Intel based wireless software. anyone please explain.


It's a matter of hardware vs. software.

Wired NICs just need a driver set and you're connected.  You can even connect in a pre-boot environment with wired NICs, and don't even need a local OS running - the PXE environment downloads the OS for you from the PXE server...

Wireless NICs have to negotiate a link and, if you have any kind of wireless security established (like WPA-802.1x authentication) you have to have a supplicant client "log in" to the access point.  The supplicant function is NOT included in wireless NICs.  It is included in Windows XP SP2, more or less, plus the trimmed-down supplicant software included with the wireless NIC.  If you want to create a secured wireless connection before Windows gets that far, you need a 3rd-party supplicant that doesn't rely on Windows "Wireless Zero Config."


Now the way it is , we have removed the Intel Proset software for WLAN and uses the Windows XP to manage the WLAN. Doing this I get the NDS tree once the machine starts up and reaches the Novell Login prompt, which was not happening before when the INtel software was present. Ring any bell?


That probably means you're using something like WPA-PSK or (I hope not) WEP for wireless security and not WPA-I or WPA-II 802.1x security, and the native Windows "Wireless Zero Config" supplicant is connecting and authenticating to the WAP before the login part of Windows startup, while the Intel Proset supplicant was starting up later in the Windows startup process.

If you use a strong, Enterprise-level wireless security scheme like 802.1x, then the Windows WZC supplicant won't authenticate until later in the startup process, so a 3rd-party supplicant that replaces or properly enhances WZC so it authenticates before login or integrated with the login dialog would be required.  Both the Aegis and Odyssey supplicants will integrate with the Novell client to allow the Novell login to be part of the wireless authentication, or will let you have a separate WPA login process prior to the Novell/Windows login that works with 802.1x/WPA-II.  The only way the Windows WZC will work pre-login is if you use the weaker WEP security, or WPA-PSK wireless security.  The supplicants that come with wireless cards (like the Intel one you stopped using) are often stripped-down versions of the Aegis client, and tend to only function post-login for some reason.


Hi shineon,

I would like to appreciate your effort here. But also would like to inform you that this works well if you have an external wireless card connected to the laptop as was the case with IBM T30.

Also would like to inform you that we have been successful in solving the problem. What we did was, we installed the IBM access connections V 4.12 listed on the IBM website and are able to attain the NDS tree at logon. In this you have an option of applying the profile at login, by which you get the IP address and are able to logon with out any problems.

Thankyou for your effort

Don't understand the "external wireless card" thing.  What that has to do with how wireless NICs work is unclear.

Looking at the IBM site's info on their "Access Connections" product, it is a wireless supplicant and login manager rolled into one.  What I said earlier still applies, just add "Access Connections from IBM" to the list of supplicants that can authenticate to the WAP pre-login, along with "Odyssey from Funk" and "Aegis from Meetinghouse."

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.


Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.